颜色/符号/线条类型的数字编码方案是什么?

Minitab 帮助中包含有记录各种编码的主题。您只需通过搜索即可找到这些主题。

  1. 选择帮助 > 帮助,然后单击参考下面的会话命令
  2. Minitab 会话命令帮助窗口中,选择搜索选项卡。
  3. 键入“标准颜色”、“符号类型”或“线条类型”,具体取决于您要查找的代码。
  4. 选中仅搜索标题
  5. 单击列表主题查看包含数字编码方案表的标准颜色、符号类型或线条类型主题。

我该如何使用命令将 Minitab 图形另存为 JPEG、PNG、TIF 或 Windows BMP 文件?

使用会话命令、GSAVE 子命令和适用的图形格式子命令创建图形。例如,假设您要创建列 C1 的直方图,并将此图形以 JPEG 格式保存在 C: 驱动器的根目录下,文件名为 Defects。请使用以下命令:

HIST C1;
GSAVE "C:\Defects";
JPEG.
注意

对于 TIFF(标签图像文件格式),请使用 TIFC 子命令。对于 PNG(可携式网络图形文件),请使用 PNGC。对于 Windows BMP(Windows 位图文件),请使用 BMPC。

注意

在宏中,您可能会发现 GSAVE 使用在了其他命令中,如 CALL。在这种情况下,就不应插入此处提及的图像格式子命令(如 JPEG)。

如何从我写的宏中打印图形?

使用 GPRINT 命令。

示例 1

此示例创建直方图和箱线图,并打印箱线图。

HIST C1;
BOXPLOT C1;
GPRINT.

示例 2

此示例创建直方图和箱线图,将这些图形分别另存为 HIST.MGF 和 BOX.MGF,并打印箱线图。

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

示例 3

此示例创建直方图和箱线图,将这些图形分别另存为 HIST.MGF 和 BOX.MGF,并打印直方图。

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIST.MGF"
注意

在没有参数的情况下(如示例 1 和示例 2 所示),GPRINT 将打印活动的图形窗口。在带有参数的情况下,GPRINT 将打开指定的图形,然后将它发送到计算机的默认打印机。

我该如何使用当天的日期(或当天的日期和时间)作为我使用局部宏创建的图形上的脚注?

例如,假设您要将当前日期作为名为 YIELD 的列的直方图上的脚注。

注意

以下步骤假设局部宏的声明部分中列出了名为 YIELD 和 TMPDATE 的列和名为 DATE 的常量,并且列 YIELD 中包含数据。

  1. 使用 TODAY() 功能可将当前日期存储在一个列中:
    LET TMPDATE = TODAY()
    注意

    如果您想让当前日期和时间显示在图形上,则使用 NOW() 而不是 TODAY()。

  2. 更改数据类型,以便将此列格式化为文本列:
    TEXT TMPDATE TMPDATE
  3. 将此日期存储为常量:
    LET DATE = TMPDATE
  4. 在 FOOTNOTE 子命令中使用常量:
    HIST YIELD;
    FOOTNOTE DATE.

我想在创建图形后控制暂停,应该如何编写宏?

要控制暂停,请将以下其中一种形式的 GPAUSE 命令包含在您的宏中:

GPAUSE

此命令可让 Minitab 在显示每个图形之后暂停 K 秒(K 可以是介于 0 到 1800 之间的任何整数),直到您按任意键或鼠标按键。

GPAUSE K

有没有可以关闭最后一个图形或所有图形的会话命令?

可以使用未记录的会话命令 GMANAGER 来关闭图形。

注意

此命令是试验性命令,没有像在帮助信息中记录的命令那样经过严格测试。虽然此命令可用,但是您应谨慎应用它 -- 我们不对任何意外结果承担责任。此命令的形式和语法随时可能更改。

要关闭最后一个图形,请使用以下命令:

GMANAGER;
CLOSE.

要关闭所有图形,请使用以下命令:

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

如果您不想在关闭前提示保存图形,请执行以下操作:

  1. 选择工具 > 选项 > 图形 > 图形管理
  2. 选择关闭前提示保存图形旁边的从不。单击确定

请注意,在关闭所有将来的图形时,将应用您在工具 > 选项中所做的更改。

如何对不包含子命令(如 GSAVE 和 WTITLE)的图形使用这些子命令

如果您同时使用 LAYOUT 命令,则可以对不包含子命令(如 GSAVE 和 WTITLE)的图形使用这些子命令。

对 GSUMMARY 使用 GSAVE 和 WTITLE

统计 > 基本统计量 > 图形化汇总

假设您要将 C1 的图形化汇总以名为 YIELD.JPG 的 JPEG 文件保存在在 C:\My Statistics 中,并且您要在图形的标题栏中显示“旧金山”。请使用以下命令:
LAYOUT;
GSAVE "C:\My Statistics\YIELD.JPG";
JPEG;
WTITLE "旧金山".
GSUMMARY C1
ENDLAYOUT.

对 GageRR 使用 GSAVE 和 WTITLE

统计 > 质量工具 > 量具研究 > 量具 R&R 研究(交叉)

假设您要运行以下量具 R&R 研究(交叉)命令:
GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.
假设您要将此图形以名为 GageRR.JPG 的 JPEG 文件保存在 Q:\Project 中,并且您想要在图形的标题栏中显示“量具 1”。请使用以下命令:
LAYOUT;
GSAVE "Q:\Project\GageRR.JPG";
JPEG;
WTITLE "量具 1".

GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.

ENDLAYOUT.
使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策