此宏生成用来评估设计实验的正交性的相关图。相关图通常用于筛选试验以评估别名结构,还可用于其他设计。

下载宏

确保 Minitab 知道可在何处找到您下载的宏。选择工具 > 选项 > 常规。在宏位置下,浏览到您保存宏文件的位置。

重要信息

如果您使用较低版本的 Web 浏览器,则在您单击下载按钮时,此文件可能会在 Quicktime 中打开,因为 Quicktime 与 Minitab 宏使用相同的 .mac 文件扩展名。要保存此宏,请右键单击下载按钮并选择目标另存为

必需输入

至少 2 个表示设计试验因子或者表示连续预测变量列的数据列。

可选输入

SQUARES
用于为包括主效应和平方项的模型创建配对相关。
INTERACTS
用于为包括主效应和双因子交互作用的模型创建配对相关。
FULL
用于为包括主效应、双因子交互作用和平方项的模型创建配对相关。
EXPAND
用于展开彩色图例以显示从 -1 到 1 的相关性,而不是从 0 到 1 的相关性的绝对值。
注意

仅使用 SQUARES、INTERACTS 或 FULL 中的一个。

运行宏

假设您有 6 因子设计,表示因子的列在 C5、C6、C7、C8、C9 和 C10 中。要仅为主效应创建相关图,请选择编辑 > 命令行编辑器,然后键入:
%CORRPLOT C5-C10。

单击提交命令

要为包含主效应和平方项的模型创建可显示模型相关性的相关图,请选择编辑 > 命令行编辑器,然后键入:
%CORRPLOT C5-C10;
SQUARES;
EXPAND。

单击提交命令

使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策