在 Minitab 中,与特定的一组数据相关联的所有数据都包含在工作表中。您可以输入工作表说明,使用快捷键在工作表中移动,并为工作表定义常量,等等。

输入工作表说明

带有说明的工作表在位于行号上方的单元格中有一个红色三角形。

  1. 在工作表中单击,然后选择编辑器 > 工作表属性 > 说明文件 > 说明 > 工作表
  2. 输入工作表信息。例如,在注释中,可以输入工作表的说明,以及用来分析数据的命令。
  3. 单击确定
  4. 要查看工作表的说明,请执行以下操作之一:
    • 将指针放在行号上方单元格中的红色三角形上。
    • 选择窗口 > Project Manager,然后单击工作表文件夹。

重命名工作表

要重命名工作表,请执行以下操作之一:

  • 右键单击标题栏中的工作表图标,然后选择重命名工作表
  • Project Manager中,右键单击工作表文件夹,然后选择重命名
  • Project Manager中,选择工作表,然后按 F2 键。
  • 在工作表中单击,选择文件 > Save Worksheet As,然后输入工作表名称。
    如果您以前保存过工作表,则原始文件会保持原样,最新的更改将保存在新文件中。

在工作表中移动

当您在某个单元格中单击时,该单元格会变为活动状态。您还可以使用编辑器菜单或键盘来移动光标,并使其他单元格变为活动状态。

下表描述了如何移动到活动工作表中的位置。

位置 操作
特定的单元格 选择编辑器 > 查找并替换 > 转到
向右、向左、向上或向下移动一个单元格 按箭头键。
移动到下一个单元格或右侧的单元格(取决于数据输入方向箭头) Enter 键。
移动到下一行或下一列的开始处(取决于数据输入方向箭头) 选择编辑器 > 查找并替换 > 转到 > 下一列编辑器 > 查找并替换 > 转到 > 活动单元格,或者按 Ctrl+Enter 键。
移动到数据窗口可见部分的边缘 Ctrl + 箭头键。
移到工作表的第一个单元格 Ctrl+Home 键。
移动到上次使用的工作表单元格 Ctrl+End 键。
移动到下一个/上一个被刷行(如果已经刷过图形) 选择编辑器 > 查找并替换 > 转到 > 下一被刷行编辑器 > 查找并替换 > 转到 > 上一被刷行
移动到下一个/上一个带格式的单元格(如果您有带格式的单元格) 选择编辑器 > 查找并替换 > 转到 > 下一个已设置格式的单元格编辑器 > 查找并替换 > 转到 > 上一个已设置格式的单元格

更改当前工作表中的数据输入方向

数据输入方向由工作表左上角中的箭头确定。此箭头的方向还确定 HomeEnd 箭头的工作方式。

箭头方向 操作
Enter 键时,活动单元格将向下移动。
Enter 键时,活动单元格将向右移动。

要更改方向,请单击箭头或者在工作表中单击并选择编辑器 > 工作表属性 > 更改条目方向

为所有新工作表更改默认数据输入方向

默认情况下,数据输入方向是沿着列从上到下。要将新工作表的数据输入方向更改为沿着行,请完成以下步骤。

  1. 选择工具 > 选项 > 数据窗口 > 常规
  2. 输入方向中,选择沿行横向输入
  3. 单击确定

复制工作表

要将活动工作表的全部内容复制到另一个工作表,请完成以下步骤。

  1. 单击要复制到其中的工作表的标题栏,使其成为活动窗口。
  2. 选择数据 > 复制 > 工作表到工作表
  3. 存储复制的数据中,选择是要创建新工作表,还是使用现有的工作表。
  4. 要复制列、常量和矩阵的名称和内容,选择命名复制的列、常量和矩阵
  5. 单击确定

修改工作表文本大小

要增加或减小工作表中的文本大小,请执行以下操作之一:

  • 在工作表处于活动状态时,在按住 Ctrl 键的同时滚动鼠标滚轮。
  • 要更改已打开工作表和新工作表中数据的默认文本大小,请选择工具 > 选项 > 数据窗口 > 数据字体
  • 要更改已打开工作表和新工作表的列号、行号和列名称的默认文本大小,请选择工具 > 选项 > 数据窗口 > 标签字体
在调整文本大小之后,您可以调整列宽。执行以下操作之一:
  • 要更改新工作表的默认列宽,选择工具 > 选项 > 数据窗口 > 常规
  • 要更改所选列的宽度,选择编辑器 > 列属性 > 宽度

定义存储常量

存储常量是随工作表一起存储的单个数字或文本值。存储常量可以用在公式、计算、会话命令、宏和可执行文件中。所有的存储常量都有一个以 K 开头的唯一 ID(K1、K2,以此类推),但是您还可以对存储常量进行命名(例如,将 K1 命名为“调整”,将 K2 名为“目标”)。

注意

接受文本字符串的对话框控件无法识别存储常量。例如,如果 K1 包含文本字符串“My Scatterplot”,您在图形 > 散点图的标签选项下的标题中输入 K1,则 Minitab 会将“K1”显示为图形的标题。

要定义存储常量,请完成以下步骤。

  1. 选择计算 > 计算器
  2. 将结果存储在变量中中,输入存储常量的名称(例如,K1)。
  3. 表达式中,输入常量的值。用双引号将文本值括起来(例如,"Green")。
  4. 单击确定
注意

存储常量不显示在工作表中。要在会话窗口中查看存储常量,请选择数据 > 显示数据

将常量复制到列

要将数据从存储常量复制到当前工作表中的新列中,请完成以下步骤。

  1. 选择数据 > 复制 > 常量到列
  2. 从常量复制中,输入要复制的存储常量(例如,K1 K2 K3)。
  3. 在当前工作表中,在列中:中,输入目标列。
  4. 单击确定

将常量复制到常量

要将数据从存储常量复制到新的存储常量,请完成以下步骤。

  1. 选择数据 > 复制 > 常量到常量
  2. 从常量复制中,输入要复制的存储常量(例如,K1 K2 K3)。
  3. 将复制的数据存储在常量中中,选择存储位置:
    • 在新工作表中:可以输入要将常量复制到其中的新工作表的名称。
    • 在以下工作表中,在最后使用的常量之后:输入要将常量复制到其中的已打开工作表的名称。
    • 在当前工作表中,在常量中:输入要复制到其中的常量。
  4. 单击确定

将列复制到常量

要将数据从列复制到存储常量,请完成以下步骤。

  1. 选择数据 > 复制 > 列到常量
  2. 从列复制中,输入要复制的列。
  3. 在当前工作表中,在常量中:中,输入目标常量(例如,K1 K2 K3)。 您输入的常量的个数必须与列中值的个数相同。例如,如果列中包含 20 个值,则必须输入 20 个常量。要指示一个范围,请使用连字符。例如,输入 K1-K20
  4. 要包括常量名称,选择命名包含复制数据的常量
  5. 要指定想要包括或排除的行,单击划分数据子集并完成以下步骤。
    1. 包括或不包括下,指定是要包括复制列中的行,还是要排除复制列中的行。
    2. 指定要包括的行/指定要排除的行中,选择下列选项之一:
      • 所有行/没有行:包括所有行或者不排除任何行。
      • 匹配的行:包括或排除与条件相匹配的行。单击条件可输入条件表达式。
      • 被刷行:包括或排除与图形上带格式刷的点相对应的行。
      • 行号:包括或排除指定的行。输入单个行号和行号范围。使用冒号 (:) 表示包含范围。例如,输入 1 4 6:10 来表示集合 1、4、6、7、8、9、10。
  6. 单击每个对话框中的确定
使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策