创建可重用的 ODBC 可执行文件

如果您经常使用文件 > 查询数据库 (ODBC)来更新工作表,则可以通过可执行文件自动执行此过程。

创建可执行文件

  1. 使用文件 > 查询数据库 (ODBC)导入数据。 有关更多信息,请转到使用 ODBC 从数据库导入数据
  2. 单击 Project Manager 工具栏上的“显示历史纪录”按钮以打开“历史记录”窗口。
  3. 选择 ODBC 会话命令和子命令,然后右键单击并选择另存为
  4. 保存类型中,选择Exec (*.mtb)
  5. 输入文件名(例如 GetData.MTB)。
  6. 选择文件的位置,然后单击保存
  7. 要运行可执行文件,请执行以下操作:
    1. 选择工具 > 运行可执行文件
    2. 指定要运行可执行文件的次数。
    3. 单击选择文件
    4. 选择可执行文件,然后单击打开

在可执行文件中指定输出列

如果您希望在每次运行可执行文件时都刷新同一个 Minitab 工作表中的数据,则需要编辑可执行文件以指定要在 Minitab 工作表中使用的列。

提示

在 ODBC SQL 或连接字符串中,在一行中的双引号之间最多可以出现 80 个字符。要使用超过 80 个字符的文本字符串,请使用 & 键将文本字符串分成跨多行的短字符串。 例如,在下面的“会话”窗口内容中,& 使双引号中的一个长文本字符串换到下一行中。

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. 在 Minitab 中,选择工具 > 记事本
  2. 在“记事本”中,选择文件 > 打开。将文件类型更改为全部 (*.*),然后打开您创建的 MTB 文件。
  3. 对于每个 ODBC 会话命令和相应的子命令,请执行以下操作:
    1. 将最后一个子命令末尾的句点 (.) 替换为一个分号 (;),然后按 Enter 键。
    2. 在下面的行中,指定要用于存储数据的列。 例如,输入 Columns 'First Name' 'Last Name' 'City' 'Country'只有在对 Minitab 工作表中的列进行命名以匹配可执行文件之后,此示例才适用。

      您可以指定列 ID 的范围(而不是单独命名每个列),例如 Columns C1-C10。当导入大量列时,指定范围将特别有用。

  4. 选择文件 > 保存,然后关闭“记事本”。

运行可执行文件

  1. 选择工具 > 运行可执行文件
  2. 单击选择文件
  3. 选择已保存的可执行文件,然后单击打开
注意

要添加快捷方式以运行菜单或工具栏中的可执行文件,请转到在菜单或工具栏上添加用于运行 Minitab 宏或可执行文件的快捷方式

使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策