概述

当您在 Minitab 中使用菜单命令时,Minitab 保留了用来记录操作的会话命令。您可以使用这些会话命令针对一组新数据快速重新执行分析。

每个菜单命令都对应一个会话命令。会话命令由主命令和(通常)一个或多个子命令组成。主命令和子命令后面都可以跟一系列参数,这些参数可以是列、常量或者矩阵、文本字符串或数字。Minitab 可提供三种使用会话命令的方法:
  • 将会话命令键入到会话窗口或命令行编辑器中。
  • 将会话命令从历史记录文件夹复制到命令行编辑器中。
  • 复制会话命令并将其保存到 exec 文件中。

当您显示命令行,然后从菜单中执行命令时,“会话”窗口的命令行窗格中会显示相应的会话命令。使用这种技巧可以方便地了解会话命令。

当新数据可用时,西部出货中心可连续不断地收集并分析交货时间。在评估质量上的评估质量中,您对三月份的数据进行了能力分析。在本章中,您可使用会话命令对四月份的数据进行能力分析。

启用和输入会话命令

使用会话命令的一种方法是在会话窗口内命令行窗格中的命令提示符处输入命令。Minitab 默认情况下不显示该窗格,因此您必须启用它。

启用会话命令

  1. 如果从前一章继续,请选择文件 > 新建 > 项目。如果不是从前一章继续,请启动 Minitab。
  2. 打开样本数据会话命令.MTW.
  3. 单击会话窗口以使其处于活动状态。
  4. 选择编辑器 > 显示命令行

    MTB> 提示符显示在会话窗口的命令行窗格中。

  5. (可选)默认情况下,所有 Minitab 会话都启用了会话命令。
    1. 选择工具 > 选项。展开会话窗口,然后选择提交命令
    2. 命令行下,单击显示

使用会话命令执行分析

评估质量中,您执行了能力分析,以确定交付时间是否在指定规格内(在 6 个交付日之内)。为执行此分析,您使用了统计 > 质量工具 > 能力分析 > 正态。然后,您输入了数据列、子组列和规格上限。

为继续评估西部出货中心的交货时间,您计划定期重复进行此分析。在您收集新数据后,您可以使用一些会话命令重复进行此分析。

  1. 命令行窗格中,在 MTB > 提示符处输入 CAPABILITY 'Days' 'Date'; 分号表明您要输入子命令。
  2. Enter 键。 注意 MTB > 会变成 SUBC>。使用 SUBC> 提示符从以前的能力分析中添加选项子命令。
  3. SUBC> 提示符中输入 USPEC 6. 句点表明命令序列结束。
  4. Enter 键。
四月份出货数据的能力分析
提示

要打开用来列出 Minitab 中会话命令的 PDF 文件,请在命令提示符处输入 Help

重新执行一系列命令

Minitab 可为大多数菜单命令生成会话命令,并将其存储在历史记录文件夹中。您可以通过选择它们然后选择编辑 > 命令行编辑器来重新执行这些命令。

使用历史记录文件夹和命令行编辑器重新运行能力分析。

  1. 选择窗口 > Project Manager
  2. 单击历史记录文件夹。
  3. 单击 CAPABILITY '天数' '日期';,并按住 Shift,然后单击 USPEC 6
  4. 选择编辑 > 命令行编辑器
  5. 单击提交命令
四月份出货数据的能力分析

几个简单的步骤,便可重新创建能力分析。

使用 exec 文件重复进行分析

Exec 文件是包含一系列 Minitab 命令的文本文件。要在不使用菜单命令或会话命令的情况下重复进行分析,请将这些命令另存为 exec 文件,然后重新运行 exec 文件。

提示

有关 exec 文件和其他更复杂宏的更多信息,请打开 Minitab 宏帮助

从历史记录文件夹创建 exec 文件

将能力分析会话命令另存为 exec 文件。

  1. 选择窗口 > Project Manager
  2. 单击历史记录文件夹。
  3. 单击 CAPABILITY '天数' '日期';,按 Shift,然后单击 USPEC 6
  4. 右键单击所选的文本并选择另存为
  5. 浏览至要用于保存您的文件的文件夹。
  6. 文件名中,输入出货图形
  7. 保存类型中,选择Exec (*.mtb)。单击保存

重新执行命令

您可以通过运行 exec 文件来重新进行此分析。

  1. 选择工具 > 运行可执行文件
  2. 单击选择文件
  3. 选择出货图形.MTB 文件,然后单击打开
四月份出货数据的能力分析

Minitab 执行 exec 文件中的命令以生成能力分析。

如果列名称匹配,则可使用任何工作表运行 exec 文件。因此,您可与其他需要执行相同分析的 Minitab 用户共享 exec 文件。例如,西部出货中心的经理想与其他出货中心的经理共享出货图形. MTB,以便对各自的数据执行相同的分析。如果要对不同工作表或不同列使用 exec,请使用文本编辑器(如记事本)编辑 exec 文件。

保存项目

将所有工作保存在 Minitab 项目中。

  1. 选择文件 > 将项目另存为
  2. 浏览至要用于保存您的文件的文件夹。
  3. 文件名中,输入 MySessionCommands
  4. 单击保存

在下一章中

您学习了如何使用会话命令作为菜单命令的替代方式以及作为快速重复进行此分析的方法。在下一章中,您将创建报表以向同事展示分析结果。

使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策