概述

您经常会使用已为您创建的工作表。但有时您必须将数据输入或导入 Minitab 工作表,然后才能开始进行分析。

您可以通过以下方式在 Minitab 工作表中输入数据:
  • 在工作表中直接键入数据。
  • 从其他应用程序中复制并粘贴数据。
  • 从 Microsoft Excel 文件或文本文件导入数据。

将这些数据放入 Minitab 后,您可能需要对单元格进行编辑或重新排列行和列,以准备好这些数据以便进行分析。一些常见的处理方式包括堆叠、创建子集、指定列名和编辑数据值。

在本章中,您将来自不同源的数据导入到 Minitab 中。您也要学习如何准备 出货数据.MTW 以进行分析。

从不同源获取数据

对于在 Minitab 18 入门中进行的初始分析,已经设置了包含三个出货中心数据的工作表 出货数据.MTW。但是,最初,这三个出货中心按以下方法存储出货数据:
  • 东部发货中心的数据存储在 Minitab 工作表中。
  • 中部发货中心的数据存储在 Microsoft Excel 文件中。
  • 西部发货中心的数据存储在文本文件中。

要分析所有发货数据,请在 Minitab 中打开每个文件,然后将所有文件堆叠到一个工作表中。

打开工作表

从东部出货中心的数据开始。

  1. 打开样本数据,东部.MTW

打开来自 Excel 电子表格的数据

中部出货中心的数据位于 Excel 电子表格中。您可以在 Minitab 中打开 Excel 文件。

  1. 保存样本数据,中部.xlsx
  2. 选择文件 > 打开
  3. 浏览到保存数据集的文件夹。
  4. 双击中部.xlsx
  5. 单击确定

打开来自文本文件 (*.txt) 的数据

西部出货中心数据以文本文件提供。打开文本文件。

  1. 保存样本数据集西部.txt
  2. 选择文件 > 打开
  3. 浏览到保存数据集的文件夹。
  4. 双击西部.txt
  5. 单击确定

将数据合并到一个工作表中

请注意,装运中心的工作表有相同的列名称。为了使数据更便于分析,需要通过将同名的列堆叠在一起来将数据合并到一个工作表中。您可以通过复制和粘贴或者使用数据菜单上的命令来移动数据。

  1. 选择数据 > 堆叠工作表
  2. 堆叠选项中,选择在新工作表中堆叠工作表
  3. 使用箭头按钮将可用工作表中的三个工作表移到要堆叠的工作表中。
  4. 新建工作表名称中,输入我的出货数据
  5. 单击确定

移动和重命名列

来源列包含用来标识出货中心数据的标签。将来源列移到 C1,并重命名中心列。

  1. 单击来源列,然后选择编辑器 > 移动列
  2. 移动选定的列下,选择在 C1 列之前
  3. 单击确定
  4. 在列名称单元格来源中单击,键入中心,然后按 Enter 键。

准备工作表以进行分析

现在,数据位于单个数据表中,但您仍需要按以下方式处理数据:
  • 对数据进行重新编码
  • 添加新列
  • 创建计算值列
提示

有关 Minitab 中提供的数据处理方式的完整列表,请转到帮助和操作步骤概述,并单击左侧导航菜单中的“处理工作表、列和行中的数据”。然后单击“操作步骤”。

对数据进行重新编码

中心列中的标签并未明确地表明这些数据来源于哪个中心。对这些标签进行重新编码以删除文件扩展名。

  1. 选择数据 > 重新编码 > 到文本
  2. 重新编码以下列中的值中,输入中心
  3. 方法中,选择重新编码单值
  4. 已重新编码值下,将“东部.MTW”替换为东部
  5. 已重新编码值下,将“西部.txt”替换为西部
  6. 已重新编码列的存储位置中,选择在原始列中
  7. 单击确定

中心列中的标签现在是东部中部西部

计算差值

在保存新工作表并执行分析前,需要计算订单日期和交货日期之间的天数。可以使用 Minitab 的计算器为计算这些值的列分配一个公式。如果您更改或者添加了数据,计算值将自动更新。

插入列

到达状态之间插入一列。

  1. 单击 C4 列中的任意单元格,使它激活。
  2. 单击鼠标右键,然后选择插入列
  3. 单击 C4 列中的名称单元格。键入天数,然后按 Enter

为列分配公式

使用 Minitab 的计算器来执行基本算术或数学函数。Minitab 会将结果保存在列中或保存为常数。可以对列设定公式,以便在数据发生更改时,自动更新计算值。

计算交货时间并将值存储在天数列中。

  1. 选择计算 > 计算器
  2. 将结果存储在变量中中,输入天数
  3. 表达式中,输入到达 - 订单
  4. 选择设置为公式
  5. 单击确定
注意

通过选择列,然后选择 编辑器 > 公式 > 对列设定公式,可以将公式添加到列中。

提示

有关列中的公式的详细信息,请转到计数器函数。有关 Minitab 的计算器以及可用操作和函数的详细信息,请转到计算器 的概述

检验工作表

天数列包含计算得出的表示交货时间的值。这些值以天数为单位。为列设定公式时,工作表列标题的右上角会出现一个状态指示符。此指示符指定您的公式定义是否正确,数据是否需要通过重新计算值加以更新。绿色复选标记指示数据为最新数据。

提示

将指针悬停在状态指示符上可以查看为该列分配的公式。双击状态指示符可以编辑公式。

更新工作表

假设您得知中部出货区域的货物到达日期不正确。如果您更正工作表中的日期,Minitab 将会自动更新天数列。

更新第 127 行中的到达日期。

  1. 到达列中,双击第 127 行,以将其置于编辑模式下。将 3/7/2013 9:17 更改为 3/8/2013 9:17
  2. Enter 键。
Minitab 将天数列中的值从 2.98125 自动更新为 3.98125
原始工作表
已更新的工作表
注意

如果您更喜欢手动更新公式,则选择编辑器 > 公式 > 自动计算所有公式来取消选中此选项。如果工作表中的值发生更改,并导致列中的公式过时,则该列的状态指示符将变成一个黄色的三角形。选择编辑器 > 公式 > 立即计算所有公式可更新项目中的所有公式。

保存工作表

在 Minitab 工作表中保存您的所有工作。

  1. 在工作表中单击,然后选择文件 > 将工作表另存为
  2. 浏览至要用于保存您的文件的文件夹。
  3. 文件名中,输入我的出货数据
  4. 保存类型中,选择Minitab
  5. 单击保存

在下一章中

来自不同数据源的出货中心数据都已经放入 Minitab 中,并且已经设置好可以进行分析了。在下一章中,您可以调整 Minitab 默认设置以使将来的分析更简单。

使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策