Qual é o esquema de codificação numérica para os tipos de cores/símbolos/linha?

A Ajuda do Minitab Help contém tópicos documentando os vários códigos. É possível encontrar estes tópicos com uma pesquisa simples.

  1. Selecione Ajuda > Ajuda e, em seguida, clique em Comandos da janela Session abaixo de Referências.
  2. Na janela Ajuda dos comandos da janela Session do Minitab, selecione a guia Pesquisar.
  3. Digite "cores padrão", "tipo de símbolo" ou "tipos de linha" dependendo dos códigos que você deseja localizar.
  4. Marque Pesquisar somente títulos.
  5. Clique em Tópicos da lista para ver os tópicos de Cores padrão, Tipos de símbolo ou Tipo de linha que contenham uma tabela do esquema de codificação numérica.

Usando os comandos, como eu posso salvar um gráfico do Minitab como um arquivo JPEG, PNG, TIF ou Windows BMP?

Crie um gráfico usando um comando da janela Session, o subcomando GSAVE, e o subcomando do formato aplicável dos gráficos. Por exemplo, suponha que você deseje criar um histograma da coluna C1 e salvar o gráfico como um JPEG na raiz de sua unidade C: com o nome de arquivo Defeitos. Utilize os comandos a seguir:

HIST C1;
GSAVE "C:\Defeitos";
JPEG.
Observação

Para TIFF (Tagged Image File Format), use o subcomando TIFC. Para PNG (Portable Network Graphics), use PNGC. Para Windows BMP (Windows Bitmap), use BMPC.

Observação

Em uma macro, você pode ver o GSAVE usado em outros comandos como o CALL. O subcomando de formato de gráficos mencionado aqui, como o JPEG, não deve ser inserido nesses casos.

Como eu imprimo um gráfico na macro que eu criei?

Use o comando GPRINT.

Exemplo 1

Este exemplo cria um histograma e um boxplot e imprime o boxplot.

HIST C1;
BOXPLOT C1;
GPRINT.

Exemplo 2

Este exemplo cria um histograma e um boxplot, salva o gráfico como HIST.MGF e BOX.MGF respectivamente, e imprime o boxplot.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

Exemplo 3

Este exemplo cria um histograma e um boxplot, salva os gráficos como HIST.MGF e BOX.MGF respectivamente, e imprime o histograma.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIST.MGF"
Observação

Sem nenhum argumento, como nos Exemplos 1 e 2, GPRINT imprime a janela Gráfico ativa. Com um argumento, GPRINT abrirá o gráfico especificado e o enviará para a impressora padrão do computador.

Como eu posso usar a data de hoje (ou a data e a hora de hoje) como um rodapé no gráfico que estou criando com uma macro local?

Por exemplo, suponha que você deseja colocar a data atual como um rodapé em um histograma de uma coluna chamada YIELD.

Observação

As etapas abaixo supõem que as colunas chamadas YIELD e TMPDATE, e uma constante chamada DATE são listadas na seção declaração da macro local, e que a coluna YIELD contém dados.

  1. Use a função TODAY() para armazenar a data atual em uma coluna:
    LET TMPDATE = TODAY()
    Observação

    Se você deseja a data e a hora atuais no gráfico, use NOW() em vez de TODAY().

  2. Altere o tipo de dados para que a coluna seja formatada como coluna de texto:
    TEXT TMPDATE TMPDATE
  3. Armazene os dados como uma constante:
    LET DATE = TMPDATE
  4. Use a constante no subcomando FOOTNOTE:
    HIST YIELD;
    FOOTNOTE DATE.

Como eu posso criar minha macro de forma a controlar as pausas depois dos gráficos criados?

Para controlar as pausas, inclua uma das formas a seguir do comando GPAUSE em sua macro:

GPAUSE

Este comando ordena que o Minitab faça uma pausa de K segundos (K pode ser qualquer inteiro entre 0 e 1.800) depois de exibir cada gráfico até que você pressione uma tecla ou o botão do mouse.

GPAUSE K

Existe algum comando da janela Session para fechar o último gráfico ou todos os gráficos?

Um comando da janela Session não registrado, GMANAGER, pode ser usado para fechar gráficos.

Observação

Este comando é experimental e não foi rigorosamente testado como os outros comandos documentados na Ajuda. Embora o comando possa ser utilizado, você deve aplicá-lo com cautela -- não assumiremos responsabilidade por resultados inesperados. A forma e a sintaxe deste comando estão sujeiras a alterações.

Para fechar o último gráfico, use o comando a seguir:

GMANAGER;
CLOSE.

Para fechar todos os gráficos, use o comando a seguir:

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

Se você não deseja ser solicitado a salvar o gráfico antes de fechá-lo, faça o seguinte:

  1. Selecione Ferramentas > Opções > Gráficos > Gerenciamento de gráfico.
  2. Selecione Nunca ao lado de Solicitar para salvar um gráfico antes de fechar. Clique em OK.

Observe que as alterações feitas em Ferramentas > Opções serão aplicadas quando fechar todos os gráficos no futuro.

Como usar subcomandos como GSAVE e WTITLE para gráficos que não incluem estes subcomandos

Você pode usar subcomandos como GSAVE e WTITLE, para gráficos que não incluem estes subcomandos, se você também usar o comando LAYOUT.

Uso do GSAVE e WTITLE para GSUMMARY

Stat > Estatísticas Básicas > Resumo gráfico

Suponha que você deseja salvar o Resumo gráfico de C1 como um JPEG com o nome YIELD.JPG em C:\My Statistics, e você deseja que "San Francisco" seja exibido na barra de título do gráfico. Use os comandos a seguir:
LAYOUT;
GSAVE "C:\My Statistics\YIELD.JPG";
JPEG;
WTITLE "San Francisco".
GSUMMARY C1
ENDLAYOUT.

Uso de GSAVE e WTITLE para GageRR

Stat > Ferramentas de qualidade > Estudo de medição > Estudo de medição R&R (Cruzado)

Suponha que você deseja executar o seguinte comando de Estudo de medição R&R (Cruzado):
GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.
Suponha que você deseja salvar o gráfico como um JPEG com o nome GageRR.JPG em Q:\Project, e deseja que "Medição 1" seja exibido na barra de título do gráfico. Use os comandos a seguir:
LAYOUT;
GSAVE "Q:\Project\GageRR.JPG";
JPEG;
WTITLE "Medição 1".

GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.

ENDLAYOUT.
Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política