Criar um arquivo Exec ODBC reutilizável

Se você usa com frequência Arquivo > Banco de dados de consultas (ODBC) para atualizar sua worksheet, é possível automatizar o processo com um arquivo Exec.

Criação de um arquivo Exec

  1. Importe os dados usando Arquivo > Banco de dados de consultas (ODBC). Para obter mais informações, vá para Importar dados de um banco de dados usando ODBC.
  2. Clique no botão Mostrar históricona barra de ferramentas do Project Manager para abrir a janela History.
  3. Selecione os comandos e subcomandos de sessão do ODBC, em seguida, clique com o botão direito do mouse e escolha Salvar como.
  4. Em Salvar como tipo, selecione Exec (*.mtb).
  5. Insira um nome de arquivo (por exemplo, GetData.MTB).
  6. Selecione um local para o arquivo e clique em Salvar.
  7. Para executar o arquivo Exec, faça o seguinte:
    1. Selecione Ferramentas > Executar uma Exec.
    2. Especificar o número de vezes que deseja executar o Exec.
    3. Clique em Selecionar Arquivo.
    4. Selecione o arquivo Exec, em seguida clique em Abrir.

Especifique as colunas de saída do arquivo Exec

Se você quiser atualizar os dados na mesma worksheet do Minitab todas as vezes que executar o arquivo Exec, é necessário editar o arquivo Exec para especificar as colunas a serem usadas na worksheet do Minitab.

Dica

Em uma SQL ODBC ou string de conexão, o número máximo de caracteres que podem ocorrer entre aspas duplas em uma linha é 80. Para usar sequências de texto com mais de 80 caracteres, quebre a cadeia em seções menores em várias linhas usando a tecla "e comercial" (&). Por exemplo, no conteúdo da janela Session a seguir, o "e comercial" continua uma longa cadeia de texto entre aspas duplas abaixo para a linha seguinte.

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. No Minitab, selecione Ferramentas > Notepad.
  2. No Bloco de Notas, selecione Arquivo > Abrir. Altere o tipo de arquivo para Todos (*.*), e abra o arquivo MTB criado.
  3. Para cada comando sessão ODBC e subcomandos correspondentes, faça o seguinte
    1. Substituir o ponto (.) no fim do subcomando final por um ponto e vírgula (;), depois, pressione o a tecla Enter.
    2. Na linha seguinte, especifique as colunas em que você deseja armazenar os dados. Por exemplo, insira Colunas 'Nome' 'Sobrenome' 'Cidade' 'País'.Este exemplo só funciona se as colunas na worksheet do Minitab já estiverem nomeadas para coincidir com o arquivo Exec.

      Você pode especificar um intervalo de IDs de coluna em vez de nomear cada coluna individualmente, por exemplo: Colunas C1-C10. Especificar um intervalo é especialmente útil ao importar um grande número de colunas.

  4. Selecione Arquivo > Salvar, em seguida, feche o Bloco de Notas.

Execute o arquivo Exec

  1. Selecione Ferramentas > Executar uma Exec.
  2. Clique em Selecionar Arquivo.
  3. Selecione o arquivo Exec que você salvou e clique em Abrir.
Observação

Para adicionar um atalho para executar o Exec a partir de um menu ou barra de ferramentas, acesse Adicione um atalho para um menu ou barra de ferramentas para executar uma macro do Minitab ou um arquivo Exec.

Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política