Visão geral

Quando você usa um comando de menu no Minitab, o Minitab preserva as linhas de comando que registram suas ações. Você pode usar estes comandos de sessão para repetir rapidamente uma análise sobre um novo conjunto de dados.

Cada comando do menu corresponde a um comando de sessão. Os comandos de sessão consistem em um comando principal e, geralmente, em um ou mais subcomandos. Tanto os comandos principais quanto os subcomandos podem ser acompanhados de uma série de argumentos, que podem ser colunas, constantes, ou matrizes, strings de texto, ou números. O Minitab fornece três maneiras de usar os comandos de sessão:
  • Digite comandos de sessão na janela Session ou Editor de Linha de Comando.
  • Copie comandos de sessão da pasta Histórico para o Editor de Linha de Comando.
  • Copie e salve comandos de sessão em um arquivo executável.

Quando você mostra as linhas de comando, e depois executa um comando de um menu, os comandos de sessão correspondentes são exibidos no painel Linha de Comando da janela Session. Essa técnica é uma maneira prática de aprender os comandos de sessão.

O centro Oeste coleta e analisa continuamente informações sobre os tempos de envio sempre que há novos dados disponíveis. No Avaliação da qualidade, você conduziu uma análise de capacidade dos dados referentes ao mês de março. Neste capítulo, você usará comandos de sessão para realizar uma análise de capacidade dos dados referentes a abril.

Habilitar e inserir comandos da janela Session

Uma maneira de usar os comandos de sessão é inseri-los no prompt de comando no painel Linha de Comando da janela do Session. O Minitab não exibe o painel por padrão, de forma que você deve habilitá-lo.

Habilitar comandos da janela Session

  1. Caso tenha realizado as tarefas do capítulo anterior, selecione Arquivo > Novo > Projeto. Caso contrário, inicie o Minitab.
  2. Abra os dados das amostras, ComandosSessão.MTW.
  3. Clique na janela Session para ativá-la.
  4. Selecione Editor > Exibir linha de Comandos.

    O prompr MTB> é exibido no painel Linha de Comando da janela Session.

  5. (Opcional) Ative os comandos da janela Session como padrão para todas as sessões do Minitab.
    1. Selecione Ferramentas > Opções. Expanda Janela Session, em seguida, selecione Comandos de Submissão.
    2. Em Linha de comando, clique em Exibir.

Executar uma análise usando comandos da janela Session

Em Avaliação da qualidade, você realiza uma análise de capacidade para determinar se os tempos de entrega estão dentro das especificações (menos de 6 dias para entrega). Para executar essa análise, você usou Estat > Ferramentas da Qualidade > Análise de Capacidade > Normal. Depois, você inseriu a coluna de dados, a coluna de subgrupo e o limite superior de especificação.

Para continuar a avaliar os tempos de entrega do centro de expedição Oeste, você planeja repetir essa análise regularmente. Ao coletar novos dados, é possível repetir essa análise usando alguns comandos de sessão.

  1. No painel Linha de Comando, no prompt MTB >, insira CAPACIDADE 'Dias' 'Data'; O ponto e vírgula indica que você deseja inserir um subcomando.
  2. Pressione Enter. Observe que MTB > se transforma em SUBC>. Use o prompt SUBC> para adicionar subcomandos para as opções da análise da capacidade anterior.
  3. No prompt SUBC>, insira USPEC 6. O ponto indica o fim de uma sequência de comando.
  4. Pressione Enter.
Análise de capacidade para os dados de expedição do mês de abril
Dica

Para abrir um arquivo PDF que relacione os comandos de sessão do Minitab, no prompt de comando, digite Ajuda.

Executar novamente uma série de comandos

O Minitab gera comandos de sessão para a maioria dos comandos de menu e armazena-os na pasta Histórico. Você pode executar novamente esses comandos selecionado-os e escolhendo Editar > Editor de Linha de Comando.

Use a pasta Histórico e o Editor de Linha de Comando para executar novamente a análise de capacidade.

  1. Selecione Janela > Project Manager.
  2. Clique na pasta Histórico.
  3. Clique em CAPABILITY 'Dias' 'Data';, pressione e mantenha pressionada a tecla Shift e depois clique em USPEC 6.
  4. Selecione Editar > Editor de Linha de Comando.
  5. Clique em Enviar Comandos.
Análise de capacidade para os dados de expedição do mês de abril

Você recriou a análise de capacidade em algumas etapas simples.

Repetir análises com arquivos exec

Um arquivo executável é um arquivo de texto que contém uma série de comandos do Minitab. Para repetir uma análise sem usar os comandos do menu ou os comandos de sessão, salve os comandos como um arquivo executável e, depois. execute-o.

Dica

Para obter mais informações sobre arquivos exec e outros macros mais complexos, abra Ajuda de Macros do Minitab.

Criar um arquivo exec a partir da pasta History

Salve os comandos de sessão da análise de capacidade como um arquivo executável.

  1. Selecione Janela > Project Manager.
  2. Clique na pasta Histórico.
  3. Clique em CAPABILITY 'Dias' 'Data';, pressione Shift e depois clique em USPEC 6.
  4. Clique com o botão direito do mouse no texto selecionado e selecione Salvar Como.
  5. Navegue até a pasta em que deseja salvar seus arquivos.
  6. Em Nome do arquivo, insira GráficosEnvio.
  7. Em Salvar como tipo, selecione Exec (*.mtb). Clique em Salvar.

Executar os comandos novamente

Você pode repetir a análise, executando o arquivo exec.

  1. Selecione Ferramentas > Executar uma Exec.
  2. Clique em Selecionar Arquivo.
  3. Selecione o arquivo, GráficosEnvio.MTB e clique em Abrir.
Análise de capacidade para os dados de expedição do mês de abril

O Minitab executa os comandos do arquivo executável para gerar a análise de capacidade.

Você pode executar um arquivo usando qualquer worksheet se o nome das colunas forem iguais. Assim, é possível compartilhar um arquivo exec com outros usuários do Minitab que precisam executar a mesma análise. Por exemplo, o gerente do centro de expedição Ocidente pode compartilhar GráficosEnvio.MTB com os gerentes de outros centros de expedição para que eles possam executar a mesma análise com seus próprios dados. Se desejar usar um arquivo exec com outra worksheet ou outras colunas, edite o arquivo exec usando um editor de texto, como o Bloco de Notas.

Salvar o projeto

Salve todo o seu trabalho em um projeto do Minitab.

  1. Selecione Arquivo > Salvar Projeto Como.
  2. Navegue até a pasta em que deseja salvar seus arquivos.
  3. Em Nome do arquivo, insira MeusComandosSessão.
  4. Clique em Salvar.

No próximo capítulo

Você aprendeu como usar os comandos da janela Session como alternativa aos comandos do menu e como uma maneira rápida de repetir uma análise. No próximo capítulo, você criará um relatório para apresentar aos colegas os resultados de sua análise.

Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política