Preparação de uma worksheet

Visão geral

Frequentemente, você usará worksheets que já foram criadas por você. No entanto, algumas vezes, será necessário inserir ou importar dados na worksheet do Minitab antes de iniciar uma análise.

Você pode inserir dados em uma worksheet do Minitab das seguintes maneiras:
  • Digite os dados diretamente na worksheet.
  • Copie e cole os dados de outros aplicativos.
  • Importe os dados de arquivos Microsoft Excel files ou de arquivos de texto.

Depois de inserir os dados no Minitab, você pode editar as células ou reorganizar as colunas e as linhas para preparar os dados para análise. Algumas das manipulações comuns são empilhamento, subagrupamento, especificação de nomes de colunas e edição de valores de dados.

Neste capítulo, você importará dados no Minitab de diferentes fontes. Você também aprenderá como DadosEnvio.MTW foi preparado para análise.

Obter dados de diferentes fontes

Para a análise inicial do Guia de introdução do Minitab 18, a worksheet DadosEnvio.MTW, que contém dados dos três centros de expedição, já estava configurada. Entretanto, originalmente, os três centros de expedição armazenaram os dados de pedidos de livros das seguintes maneiras:
  • O centro de expedição Oriente armazenou os dados em uma worksheet do Minitab.
  • O centro de expedição Central armazenou os dados em um arquivo do Microsoft Excel.
  • O centro de expedição Ocidente armazenou os dados em um arquivo de texto.

Para analisar todos os dados de expedição, abra cada arquivo no Minitab e empilhe-os em uma worksheet.

Abrir uma worksheet

Comece com os dados do centro de expedição Leste.

  1. Abra os dados das amostras, Oriental.MTW.

Abrir dados de uma planilha Excel

Os dados do centro de expedição central estão armazenados em uma planilha do Excel. É possível abrir arquivos do Excel no Minitab.

  1. Salve os dados de amostra, Central.xlsx.
  2. Selecione Arquivo > Abrir.
  3. Navegue até a pasta onde salvou o conjunto de dados.
  4. Clique duas vezes em Central.xls.
  5. Clique em OK.

Abrir dados de um arquivo de texto (*.txt)

Os dados do centro de expedição Ocidente estavam em um arquivo de texto. Abrir o arquivo de texto.

  1. Salve o conjunto de dados de amostra, Ocidental.txt.
  2. Selecione Arquivo > Abrir.
  3. Navegue até a pasta onde salvou o conjunto de dados.
  4. Clique duas vezes em Ocidental.txt.
  5. Clique em OK.

Combinar os dados em uma worksheet

Observe que as worksheets para os centros de expedição têm os mesmos nomes de coluna. Para facilitar a análise dos dados, é preciso combinar os dados em uma worksheet pelo empilhamento de colunas que tenham os mesmos nomes. É possível mover dados copiando e colar ou usando comandos no menu Dados.

  1. Selecione Dados > Empilhamento de Worksheets.
  2. Em Opção de empilhamento, selecione Empilhamento de Worksheets em uma nova worksheet.
  3. Use os botões de seta para mover as três worksheets de Worksheets disponíveis para Worksheets para empilhar.
  4. Em Nome da nova worksheet, insira MeusDadosEnvio.
  5. Clique em OK.

Mover e nomear uma coluna

A coluna Fonte contém os rótulos que identificam os dados dos centros de expedição. Mova a coluna Fonte para C1 e renomeie a coluna Centro.

  1. Clique na coluna Fonte, em seguida, selecione Editor > Mover Colunas.
  2. Em Mover Colunas Selecionadas, selecione Antes da coluna C1.
  3. Clique em OK.
  4. Clique na célula com o nome da coluna Fonte, digite Centro e pressione Enter.

Preparar uma worksheet para análise

Os dados estão agora em uma única worksheet, mas você ainda precisa manipular os dados das seguintes maneiras:
  • Recodificar dados
  • Adicionar uma nova coluna
  • Criar uma coluna de valores calculados
Dica

Para obter uma lista completa de manipulações de dados disponíveis no Minitab, acesse Visão geral da Ajuda e Como fazer e clique em "Manipular dados em worksheets, colunas e linhas" no menu de navegação à esquerda. Em seguida, clique em "Como fazer".

Recodificar os dados

Os rótulos na coluna Centro não identificam corretamente de que centro os dados provêm. Recodifique os rótulos para remover a extensão do arquivo.

  1. Selecione Dados > Recodificar > Para Texto.
  2. Em Recodificar valores nas seguintes colunas, insira Centro.
  3. Em Método, selecione Recodificar valores individuais.
  4. Sob Valor recodificado, substitua Oriente.MTW por Oriente.
  5. Sob Valor recodificado, substitua Ocidente.txt por Ocidente.
  6. Em Local de armazenamento para as colunas recodificadas selecione Nas colunas originais.
  7. Clique em OK.

Os rótulos na coluna Centro agora são Oriente, Central e Ocidente.

Calcular valores de diferença

Antes de salvar sua nova worksheet e executar as análises, é necessário calcular o número de dias entre a data do pedido e a data de entrega. Você pode usar a Calculadora do Minitab para atribuir uma fórmula a uma coluna, para calcular esses valores. Se você alterar ou acrescentar dados, os valores calculados serão atualizados automaticamente.

Inserir uma coluna

Inserir uma coluna entre Chegada e Status.

  1. Clique em qualquer célula da coluna C4 para ativá-la.
  2. Clique com o botão direito do mouse e, em seguida, selecione Inserir Colunas.
  3. Clique na célula de nome da coluna C4. Digite Dias, em seguida, pressione Enter.

Atribuir uma fórmula a uma coluna

Use a Calculadora do Minitab para realizar operações aritméticas e matemáticas básicas. O Minitab armazena os resultados em uma coluna ou uma constante. Você pode atribuir uma fórmula a uma coluna para que os valores calculados sejam atualizados automaticamente se os dados forem alterados.

Calcule o tempo de entrega e armazene os valores na coluna Dias.

  1. Selecione Calc > Calculadora.
  2. Em Armazenar resultado na variável, insira Dias.
  3. Em Expressão, insira Chegada - Pedido.
  4. Selecione Atribuir como uma fórmula.
  5. Clique em OK.
Observação

Você também pode adicionar uma fórmula a uma coluna selecionando a coluna e escolhendo Editor > Fórmulas > Atribuir Fórmula à Coluna.

Dica

Para obter mais informações sobre fórmulas em colunas, acesse Funções da calculadora. Para obter mais informações sobre a Calculadora do Minitab e as operações e funções disponíveis, acesse Visão geral de Calculadora.

Examinar a worksheet

A coluna Dias contém os novos valores calculados que representam o tempo de entrega. Esses valores estão expressos em número de dias. Quando uma fórmula é atribuída a uma coluna, um indicador de status é exibido no canto superior direito do cabeçalho da coluna na worksheet. O indicador especifica se a fórmula está definida corretamente e se é necessário recalcular os valores para atualizar os dados. Uma marca de verificação verde indica que os dados estão atualizados.

Dica

Pressione e segure o cursor sobre o indicador de status para ver a fórmula atribuída à coluna. Clique duas vezes no indicador para editá-la.

Atualizar a worksheet

Suponhamos que você observe que a data de chegada de um pedido na região de expedição central esteja incorreta. Se você corrigir a data na worksheet, o Minitab atualizará automaticamente a coluna Dias.

Atualize a data de chegada na linha 127.

  1. Na coluna Chegada clique duas vezes na linha 127 para colocá-la no modo de edição. Mude 7/3/2013 9:17 para 8/3/2013 9:17.
  2. Pressione Enter.
O Minitab atualiza automaticamente o valor na coluna Dias de 2,98125 para 3,98125.
Planilha original
Planilha atualizada
Observação

Se preferir atualizar as fórmulas manualmente, selecione Editor > Fórmulas > Calcular Todas as Fórmulas Automaticamente para desmarcar esta opção. Se os valores na worksheet mudarem e fizerem com que a fórmula na coluna fique desatualizada, o indicador de status dessa coluna muda para um triângulo amarelo. Selecione Editor > Fórmulas > Calcular Todas as Fórmulas Agora para atualizar todas as fórmulas no projeto.

Salvar a worksheet

Salve todo o seu trabalho em uma worksheet do Minitab.

  1. Clique na worksheet, em seguida selecione Arquivo > Salvar Worksheet Como.
  2. Navegue até a pasta em que deseja salvar seus arquivos.
  3. Em Nome do arquivo, insira MeusDadosEnvio.
  4. Em Salvar como tipo, selecione Minitab.
  5. Clique em Salvar.

No próximo capítulo

Os dados dos centros de expedição, provenientes de várias fontes, estão no Minitab e estão configurados corretamente para análise. No próximo capítulo, você ajustará as configurações padrão do Minitab para facilitar futuras análises.

Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política