재사용 가능한 ODBC Exec 파일 만들기

워크시트를 업데이트하기 위해 파일 > 데이터베이스(ODBC) 질의을 자주 사용하는 경우 Exec 파일을 사용하여 프로세스를 자동화할 수 있습니다.

Exec 파일 만들기

  1. 파일 > 데이터베이스(ODBC) 질의을 사용하여 데이터를 가져옵니다. 자세한 내용은 ODBC를 사용하여 데이터베이스에서 데이터 가져오기에서 확인하십시오.
  2. Project Manager 도구 모음에서 기록 표시 버튼 을 클릭하여 기록 창을 엽니다.
  3. ODBC 세션 명령과 하위 명령을 선택한 다음 마우스 오른쪽 버튼을 클릭하고 다른 이름으로 저장을 선택합니다.
  4. 파일 형식에서 Exec(*.mtb)을 선택합니다.
  5. 파일 이름(예: GetData.MTB)을 입력합니다.
  6. 파일 위치를 선택한 다음 저장을 클릭합니다.
  7. Exec 파일을 실행하려면 다음 작업을 수행합니다.
    1. 도구 > Exec 실행을 선택합니다.
    2. Exec 파일을 실행할 횟수를 지정합니다.
    3. 파일 선택을 클릭합니다.
    4. Exec 파일을 선택한 다음 열기을 클릭합니다.

Exec 파일에 결과 열 지정

Exec 파일을 실행할 때마다 동일한 Minitab 워크시트의 데이터를 새로 고치려면 Exec 파일을 편집하여 Minitab 워크시트에서 사용할 열을 지정해야 합니다.

ODBC SQL 또는 연결 문자열에서 한 줄에서 큰따옴표 사이에는 최대 80자까지 올 수 있습니다. 80자보다 긴 텍스트 문자열을 사용하려면 앰퍼샌드(&) 키를 사용하여 문자열을 여러 줄에 걸친 더 작은 부분으로 나눕니다. 예를 들어 다음 세션 창 내용의 경우 앰퍼샌드를 사용하여 큰따옴표로 묶은 긴 텍스트 문자열을 다음 줄까지 아래로 계속 잇습니다.

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. Minitab에서 도구 > 메모장을 선택합니다.
  2. 메모장에서 파일 > 열기을 선택합니다. 파일 형식을 모두(*.*)으로 변경한 다음 생성한 MTB 파일을 엽니다.
  3. 각 ODBC 세션 명령과 해당 하위 명령에 대해 다음 작업을 수행합니다.
    1. 마지막 하위 명령 끝에 있는 마침표(.)를 세미콜론(;)으로 바꾼 다음 Enter 키를 누릅니다.
    2. 다음 줄에 데이터를 저장할 열을 지정합니다. 예를 들어 '이름' '성' '시' '국가' 열을 입력합니다.이 예는 Minitab 워크시트의 열에 이미 Exec 파일과 일치하는 이름을 지정한 경우에만 사용할 수 있습니다.

      각 열의 이름을 지정하지 않고 열 ID 범위를 대신 지정할 수 있습니다(예: C1-C10 열). 범위를 지정하면 여러 열을 가져올 때 특히 유용합니다.

  4. 파일 > 저장을 선택한 다음 메모장을 닫습니다.

Exec 파일 실행

  1. 도구 > Exec 실행을 선택합니다.
  2. 파일 선택을 클릭합니다.
  3. 저장한 Exec 파일을 선택한 다음 열기을 클릭합니다.
참고

메뉴 또는 도구 모음에서 Exec 파일을 실행하기 위한 바로 가기를 추가하려면 메뉴 또는 도구 모음에 Minitab 매크로 또는 Exec 파일을 실행하기 위한 바로 가기 추가으로 이동합니다.

이 사이트를 사용하면 분석 및 사용자 개인 컨텐츠에 대한 쿠키 사용에 동의하는 것입니다.  당사의 개인정보 보호정책을 확인하십시오