色/記号/ラインのタイプの番号コード化方式は何ですか。

Minitabヘルプにはさまざまなコードを説明したトピックがあります。これらのトピックは簡単な検索で見つけられます。

  1. [ヘルプ] > [ヘルプ]を選択し、[リファレンス]の下の[セッションコマンド]をクリックします。
  2. [Minitabセッションコマンドヘルプ]ウィンドウで、[検索]タブを選択します。
  3. 探しているコードに応じて「標準色」、「記号タイプ」、または「ラインタイプ」と入力します。
  4. [タイトルのみ検索]にチェックマークを付けます。
  5. [検索開始]をクリックし、標準色、記号タイプ、またはラインタイプに関するトピックを参照すると、そこに番号コード化方式の表が含まれています。

コマンドを使用してMinitabのグラフをJPEG、PNG、TIF、またはWindows BMPファイルとして保存するにはどうすればよいですか。

セッションコマンド、GSAVEサブコマンド、および該当するグラフィックスフォーマットサブコマンドを使用してグラフを作成します。たとえば、列C1のヒストグラムを作成し、グラフをJPEGとしてC:ドライブのルートにDefectsというファイル名で保存する場合、 次のコマンドを使用します。

HIST C1;
GSAVE "C:\Defects";
JPEG.

TIFF(Tagged Image File Format)の場合、サブコマンドTIFCを使用します。PNG(Portable Network Graphics)の場合、PNGCを使用します。Windows BMP(Windows Bitmap)の場合、BMPCを使用します。

マクロでは、GSAVEがCALLなどの他のコマンド内で使用されていることがあります。そのような場合、ここで説明したJPEGなどのグラフィックスフォーマットサブコマンドは挿入しないでください。

記述したマクロからグラフを印刷するにはどうすればよいですか。

GPRINTコマンドを使用します。

例1

この例ではヒストグラムと箱ひげ図を作成し、箱ひげ図を印刷します。

HIST C1;
BOXPLOT C1;
GPRINT.

例2

この例では、ヒストグラムと箱ひげ図を作成し、グラフをそれぞれHIST.MGFおよびBOX.MGFとして保存し、箱ひげ図を印刷します。

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

例3

この例では、ヒストグラムと箱ひげ図を作成し、グラフをそれぞれHIST.MGFおよびBOX.MGFとして保存し、ヒストグラムを印刷します。

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIS.MGF"

例1および例2のように引数がない場合はGPRINTはアクティブなグラフウィンドウを印刷します。引数を付けるとGPRINTは指定されたグラフを開き、コンピュータのデフォルトプリンタに送信します。

ローカルマクロで作成するグラフのフットノートとして今日の日付(または今日の日付と時間)を使用するにはどうすればよいですか。

たとえば、YIELDという列のヒストグラムの脚注として現在の日付を入れるとします。

次の手順では、YIELDおよびTMPDATEという列とDATEという定数がローカルマクロの宣言セクションに記述されていて、列YIELDにデータが含まれていることを前提としています。

  1. TODAY()関数を使用して現在の日付を列に保存します。
    LET TMPDATE = TODAY()

    グラフに現在の日付と時間を使用するには、TODAY()の代わりにNOW()を使用します。

  2. この列がテキスト列としてフォーマットされるようにデータ型を変更します。
    TEXT TMPDATE TMPDATE
  3. 日付を定数として保存します。
    LET DATE = TMPDATE
  4. FOOTNOTEサブコマンド内でこの定数を使用します。
    HIST YIELD;
    FOOTNOTE DATE.

グラフが作成された後の一時停止を制御するには、どのようにマクロを記述しますか。

一時停止を制御するには、マクロ内に次のいずれかの形式でGPAUSEコマンドを含めます。

GPAUSE

このコマンドを使用すると、Minitabは各グラフを表示した後、ユーザーが任意のキーまたはマウスボタンを押すまで、K秒間(Kは0~1800の任意の整数)、一時停止します。

GPAUSE K

最後のグラフまたはすべてのグラフを閉じるセッションコマンドはありますか。

マニュアルに記載されていないセッションコマンドGMANAGERを使用するとグラフを閉じることができます。

このコマンドは実験的なコマンドで、ヘルプに記載されるコマンドほど厳密にテストされていません。このコマンドは使用可能ですが、注意して使用してください。予期しない結果が起きても当社は責任を負いません。このコマンドの形式および構文は変更される場合があります。

最後のグラフを閉じるには、次のコマンドを使用します。

GMANAGER;
CLOSE.

すべてのグラフを閉じるには、次のコマンドを使用します。

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

グラフを閉じる前に保存するよう促すプロンプトが表示されないようにするには、次の操作を行います。

  1. [ツール] > [オプション] > [グラフィックス] > [グラフ管理]を選択します。
  2. [グラフを閉じる前に保存するよう促すプロンプトの表示]の横の[まったく行わない]を選択します。[OK]をクリックします。

[ツール] > [オプション]で行った変更は、今後すべてのグラフを閉じたときに適用されることに注意してください。

GSAVEやWTITLEなどのサブコマンドが含まれないグラフに対してこれらのサブコマンドを使用するにはどうすればよいですか。

GSAVEやWTITLEなどのサブコマンドが含まれないグラフに対して、LAYOUTコマンドと共に使用すれば、これらのサブコマンドを使用できます。

GSUMMARYに対するGSAVEとWTITLEの使用

[統計] > [基本統計] > [記述統計グラフ要約]

C1の記述統計グラフ要約をJPEGとしてYIELD.JPGという名前でC:\My Statisticsに保存し、グラフのタイトルバーに「サンフランシスコ」と表示する場合、 次のコマンドを使用します。
LAYOUT;
GSAVE "C:\My Statistics\YIELD.JPG";
JPEG;
WTITLE "サンフランシスコ".
GSUMMARY C1
ENDLAYOUT.

GageRRに対するGSAVEとWTITLEの使用

[統計] > [品質ツール] > [ゲージの分析] > [ゲージのR&R分析(交差)]

次のゲージR&R(交差)コマンドを実行するとします。
GageRR;
Parts '部品';
Opers '作業者';
Response '測定値';
Studyvar 6.
グラフをJPEGとしてGageRR.JPGという名前でQ:\Projectに保存し、グラフのタイトルバーに「ゲージ1」と表示する場合、 次のコマンドを使用します。
LAYOUT;
GSAVE "Q:\Project\GageRR.JPG";
JPEG;
WTITLE "ゲージ1".

GageRR;
Parts '部品';
Opers '作業者';
Response '測定値';
Studyvar 6.

ENDLAYOUT.
本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください