マクロのエラーメッセージ

マクロのデバッグとエラー処理に役立つのはどのコマンドですか。

  1. [ヘルプ] > [ヘルプ]を選択し、[セッションコマンド]をクリックします。
  2. [コマンド一覧]で、[機能別マクロコマンド一覧]をクリックします。
  3. [デバッグツール]および[エラー処理]までスクロールダウンします。

execを実行しようとするとエラーが発生して実行が停止します。エラーの原因となったコマンドの後もexecが実行を続行するようにするには、どうすればよいですか。

exec内でZERRORコマンドを使用できます。このコマンドはマニュアルには記載されていません。

たとえば、execに次のコマンドが含まれているとします。

RAND 10 C1
DESS C1
RAND 10 C2
DESC C2

このexecを実行しようとすると、セッションウィンドウに次のエラーメッセージが表示されてexecの実行が停止します。

* エラー * 不明のMinitabコマンド: DESS

次のようにexecにZERRORコマンドを追加すると、セッションウィンドウにエラーメッセージは表示されますが、execの実行は続行されます。

RAND 10 C1
DESS C1
ZERROR
RAND 10 C2
DESC C2

マクロを実行しようとするとメッセージ「* エラー * 無効なパスです。 * 注 * コマンドは取り消されました。」が表示されるのはなぜですか。

このエラーは、存在しないパスにグラフを保存するGSAVEサブコマンドが使用されたマクロを実行しようとしたときに表示されます。GSAVEサブコマンドで指定されているパスを修正し、マクロを再保存します。これでマクロが実行できるようになります。

マクロを実行しようとするとメッセージ「* エラー * ファイルが見つかりませんでした。」が表示されます。

2つの可能性があります。

問題1…Minitabがマクロを見つけられない。

この問題を修正するには、いくつかのオプションがあります。

  • マクロをMacrosフォルダに置きます。たとえば、C:\Program Files\Minitab\Minitab 16\English\Macrosなどです。
  • [ツール] > [オプション]を選択します。[マクロの位置]で、適切なフォルダを入力するか、[参照]ボタンをクリックして適切なフォルダに移動します。
  • マクロを呼び出すときのパスを入力します。たとえば、マクロ名がMYMACROで、C:\MACROSに保存されている場合は次のように入力します。
    %'C:\MACROS\MYMACRO'
    .

問題2…マクロが、適切な.MACファイル拡張子がついたテキストファイルとして保存されていない。

マクロが正しいフォルダに保存されていて、マクロを実行しようとしたときに同じエラーメッセージが表示される場合は、次のようにします。

  1. メモ帳でマクロを開きます。
  2. [ファイル] > [名前を付けて保存]を選択します。
  3. [ファイル名]に.MAC拡張子を付けたマクロ名を、全体を二重引用符で囲んで入力します(たとえば、"MYMACRO.MAC")。

    または、[ファイル名]に.MAC拡張子を付けたマクロ名を入力し(たとえば、MYMACRO.MAC)、[ファイルの種類]で[すべてのファイル]を選択します。

  4. [保存]をクリックします。

「* エラー * ファイルが見つかりませんでした。」メッセージの解決

このメッセージは次のいずれかの理由で表示されます。
  • マクロが、Minitabで定義されたMacrosフォルダにありません。
  • マクロがマクロファイル拡張子(.mac)が付いたテキストファイルではありません。
ヒント

マクロがMacrosフォルダにあり、.macファイル拡張子が付いている場合、メッセージが表示されないようにマクロを簡単に実行するには、[コマンドラインエディタ]で次のようにファイルパスを含めたファイル名を入力します。

%'C:\Users\sgarcia\Documents\minitab_documents\MyMacro'

  1. マクロをMacrosフォルダに置きます。
    • Macrosフォルダがどこにあるか分からない場合は、Minitabで、[ツール] > [オプション]を選択します。[マクロの位置]フィールドにフォルダパスが含まれています。
    • [マクロの位置]フィールドが空の場合、パス(たとえば、C:\Program Files\Minitab\Minitab 17\English\Macros)を入力します。
  2. マクロを実行します。
  3. メッセージがまた表示される場合、次の手順に従ってマクロを.mac拡張子が付いたテキストファイルとして保存します。
    1. Microsoftのメモ帳などのテキストエディタでマクロを開きます。
    2. [ファイル] > [名前を付けて保存]を選択します。
    3. [ファイル名]に.macファイル拡張子を付けたマクロ名(たとえば、ProjectMacro.mac)を入力します。
    4. [ファイルの種類]リストで、[すべてのファイル (*.*)]を選択します。

これでマクロを実行してもメッセージが表示されないようになります。

マクロ(Minitabマクロまたは自分で記述または変更したもの)を実行しようとするとメッセージ「* エラー * 無効なファイル名です。」が表示されます。

マクロの記述または変更に使用したアプリケーションが開いていないことを確認します。たとえば、マクロをMicrosoft Wordで記述または変更して、Microsoft Wordがまだ開いている場合、Microsoft Wordを閉じます。

ローカルマクロでWORKSHEETコマンドを使用して特定のワークシートをアクティブにしようとすると、「* エラー * ローカルマクロでは、WORKSHEETコマンドはワークシートの名前変更にしか使用できません。」と表示されます。

回避策として、Execを使用して各ワークシートを呼び出し、次にマクロを呼び出します。たとえば、MyLocalというローカルマクロをWeek1およびWeek2という2つのワークシート上で実行するとします。execの例は次のようになります。

Worksheet "第1週"
%MyLocal
Worksheet "第2週"
%MyLocal

Microsoft Wordで記述されたローカルマクロまたはグローバルマクロを実行しようとすると「** エラー ** マクロヘッダが期待されています。代わりに見つかったもの: ÐÏ à¡±、** エラー ** ファイル内にマクロプログラムがありません。」というメッセージが表示されるのはなぜですか。

これらのエラーは、Microsoft Wordで記述されたローカルマクロまたはグローバルマクロが[テキストのみ (*.txt)]で保存されていない場合に、そのマクロを実行しようとすると表示されます。Microsoft Wordで記述されたマクロファイルを[テキストのみ (*.txt)]フォーマットで保存するには、次の2つの方法があります。

オプション1

  1. マクロをMicrosoft Wordで開きます。
  2. [ファイル] > [名前を付けて保存]を選択します。
  3. [ファイル名]に.MACファイル拡張子を含むマクロ名を、二重引用符で囲んで入力します(たとえば、"MYMACRO.MAC")。
  4. [ファイルの種類]ドロップダウンメニューから、[テキストのみ (*.txt)]を選択します。[保存]をクリックします。

    ファイルに対して「テキストのみの形式では使用できない機能が含まれています。この形式で文書を保存しますか?」というメッセージが表示された場合、[はい]をクリックします。

  5. Microsoft Wordを閉じます。

オプション2

  1. マクロの内容をMicrosoft Wordからメモ帳にコピーして貼り付けます。

    メモ帳を開くには、[スタート]メニューをクリックし、[プログラム] > [アクセサリ] > [メモ帳]を選択します。

  2. [ファイル] > [名前を付けて保存]を選択します。
  3. [ファイル名]に.MACファイル拡張子を含むマクロ名を、二重引用符で囲んで入力します(たとえば、"MYMACRO.MAC")。[保存]をクリックします。

特定のグラフを作成しようとすると「* エラー * サブコマンド___が系列外か、このコマンドでは有効ではありません。* エラー * サブコマンドは無視されました。」が表示されるのはなぜですか。

GSTDコマンドを実行する必要があります。GSTDコマンドを使用すると文字による(標準)グラフィックスが有効になり、高解像度(プロフェッショナル)グラフィックスが無効になります。プロフェッショナルグラフィックスに戻るにはセッションウィンドウのコマンドプロンプト(MTB >)で次のように入力します。

GPRO

コマンドプロンプトを表示するには、セッションウィンドウを有効にし、エディタ > コマンドを有効にするを選択します。

Minitabマクロライブラリからマクロを実行しようとすると「* エラー * 引数は定数または行列ですが、列が必要です。* エラー * マクロを終了しています。」というエラーメッセージが表示されます。

このエラーメッセージは、通常、セッションウィンドウのコマンド言語が無効になっている場合に、ユーザーにセッションウィンドウでの入力を求めるマクロを実行すると発生します。コマンド言語を有効にするには、次の手順を実行します。
  1. セッションウィンドウをクリックしてアクティブにします。
  2. [エディタ] > [コマンドを有効にする]を選択します。

マクロがユーザーに入力を求めるものではなく、このエラーメッセージが表示される場合は、マクロが適切なコマンドおよびサブコマンドを使用して呼び出されていることを確認します。

本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください