カスタムコマンドを作成する

Minitabマクロを実行したり、異なるアプリケーションを開いたり、Webサイトにアクセスしたりするために、カスタムコマンドを作成できます。

たとえば、Quality Companionや異なるMinitab製品を開けるように、Minitabツールメニューにカスタムコマンドを追加することができます。

新しいコマンドを作成するには、まずツールメニューでコマンドを作成します。これで、ツールメニューから、コマンドを異なるメニューやツールバーへ移動することができます。

  1. ツール > カスタマイズを選択します。
  2. ツールタブで[新規(挿入)]ボタンをクリック.
  3. Quality Companionなどの名前を入力します。
  4. コマンドの情報を入力します。
    • コマンドで、ツールの外部アプリケーションまたはWebアドレスのパス(例えば、C:\Program Files (x86)\Minitab\Quality Companion 3\Companion\qc.exe)を入力するかまたは参照します。
    • 必要に応じて、引数で、アプリケーションによって自動的に開かれる特定のファイルなど、リンクを追加するアプリケーションに渡す引数を入力します。
    • 必要に応じて、初期ディレクトリで、リンクを追加するアプリケーションの最初の保存フォルダを作成します。
  5. 閉じるをクリックします。
    新しいコマンドを実行するには、ツールメニューからコマンドを選びます。

メニューやツールバーからコマンドを移動または削除

コマンドをメニューやツールバーの別の場所に移動できます。また、ツールバーをより簡潔にするため、未使用のコマンドをツールバーから削除できます。

  1. ツール > カスタマイズを選択します。
  2. コマンドを削除するには、ダイアログボックスを開いたままで、コマンドをメニューまたはツールバーの外にドラッグします。
  3. コマンドを移動するには、ダイアログボックスを開いたままで、コマンドを元の場所から新しい場所にドラッグします。 ツールメニューの最初のセクションにあるコマンド以外であれば、あらゆるコマンドを移動することができます。
  4. ツールメニューの最初のセクションからカスタムコマンドを移動するには、次の手順に従います。
    1. コマンドタブのカテゴリ (分類)の下で、コマンドが属しているグループを選択します。
    2. コマンドの下で、コマンドを選択し、ダイアログボックスを開いたままでコマンドをメニューまたはツールバーにドラッグします。
  5. 閉じるをクリックします。

カスタムメニューを作成する

特別なタスクまたはプロジェクトに、新しいメニューを作成できます。たとえば、月次レポート用のツールのメニューを作成できます。

  1. ツール > カスタマイズを選択します。
  2. コマンドタブのカテゴリ (分類)の下で、新規メニューを選択します。
  3. コマンドの下で、新規メニューを選択し、Minitabのメインメニューバーにドラッグします。
  4. 新規メニューを右クリックして、名前ボタンを選択します。メニューの名前(月次レポートツールなど)を入力し、OKをクリックします。
  5. カテゴリ (分類)の下で、新しいメニューに追加するコマンドのカテゴリ(グラフなど)を選択します。
  6. コマンドの下で、コマンドを選択し、新しいメニューの下にドラッグします。
  7. メニューに追加するすべてのコマンドでステップ5と6を繰り返します。
  8. 閉じるをクリックします。

カスタムツールバーを作成する

特別なタスクまたはプロジェクトに、新しいツールバーを作成できます。たとえば、よく使用する分析のツールバーを作成できます。

  1. ツール > カスタマイズを選択します。
  2. ツールバータブで、新規作成をクリックします。
  3. ツールバーの名前(マイツールなど)を入力し、OKをクリックします。
  4. 新しいツールバーをMinitabの目的の場所にドラッグします。
  5. コマンドタブで、コマンドのカテゴリ (分類)を選択し、ツールバーに追加するコマンドをドラッグします。
  6. ツールバーに追加するすべてのコマンドでステップ5を繰り返します。
  7. ツールバーのコマンド名を表示するには、ツールバータブで、ボタン名を表示するを選択します。
  8. 閉じるをクリックします。

コンテキストメニューの編集

コンテキストメニューは、特定のウィンドウがアクティブな場合にのみアクティブになるメニューです。ほとんどのコンテキストメニューは、右クリックメニューです。たとえば、グラフを右クリックすると、[グラフビュー]コンテキストメニューが表示されます。

  1. ツール > カスタマイズを選択します。
  2. メニュータブのコンテキストメニューを選択で、変更するコンテキストメニューを選択します。
    コンテキストコマンドが表示されます。
  3. コマンドタブのカテゴリ (分類)の下で、追加するコマンドを含むカテゴリーを選択します。
  4. コマンドの下で、コマンドをコンテキストメニューにドラッグします。
  5. コンテキストメニューからコマンドを削除するには、コマンドを選択し、メニューの外にドラッグします。
  6. 閉じるをクリックします。

ツールバーの表示オプションを変更

ツールバーのツールチップおよびアイコンの表示を変更します。

  1. ツール > カスタマイズを選択します。
  2. オプションタブで、次のいずれかを実行します。
    • ツールバーのツールチップを表示するには、ツールバーの画面とヒントを表示を選択します。
    • ツールバーのツールチップでショートカットキーを表示するには、ヒントと一緒にショートカットキーを表示するを選択します。
    • ツールバーボタンの大きなアイコンを表示するには、大きいアイコンを選択します。
  3. 閉じるをクリックします。

コマンドのキーボードショートカットを追加

ショートカットキーを追加することで、頻繁に使用するコマンドを実行する時間を節約できます。たとえば、2サンプルtダイアログボックスを開くキーボードショートカットを作成できます。

  1. ツール > カスタマイズを選択します。
  2. キーボードタブで、カテゴリ (分類)からコマンドが属しているカテゴリーを選択します(統計など)。
  3. コマンドの下で、コマンド(2サンプルt...[基本統計]など)を選択します。
  4. 新しいショートカットキーの入力フィールド内をクリックし、キーボードショートカット(Ctrl+Qなど)を押します。
    キーボードショートカットがすでに割り当てられている場合、Minitabはメッセージを表示します。
  5. 割り当てをクリックしてウィンドウを閉じます。

ツールバーボタンのイメージを変更

ツールバーボタンのイメージを変更できます。

  1. ツール > カスタマイズを選択します。
  2. 別のボタンからイメージをコピーするには、次の操作を行います。
    1. ボタンイメージを右クリックしてボタンイメージのコピーを選択します。
    2. イメージを貼り付けるボタンを右クリックしてボタンイメージの貼り付けを選択します。
  3. 既存のボタンイメージを編集するには、イメージを右クリックしてボタンイメージの編集を選択します。描画ツールを使用して画像を編集します。
  4. イメージの代わりにボタン名を表示するには、ボタンを右クリックしてテキストを選択します。ボタン名とイメージの両方を表示するには、ボタンを右クリックしてイメージとテキストを選択します。
  5. 閉じるをクリックします。

デフォルト設定を復元

ツールバー、メニュー、およびショートカットキーのデフォルト設定を復元することができます。

ツールバーをリセット

  1. ツール > カスタマイズを選択します。
  2. ツールバータブをクリックします。
  3. 1つのツールバーをリセットするには、ツールバーをクリックして、リセットをクリックします。
  4. すべてのツールバーをリセットするには、すべてリセットをクリックします。
  5. カスタムツールバーを削除するには、ツールバーリストから選択し、削除をクリックします。
  6. 閉じるをクリックします。

メニューをリセット

  1. ツール > カスタマイズを選択します。
  2. メニュータブをクリックします。
  3. すべての非コンテキストメニュー、サブメニュー、およびコマンド(ツールメニュー、編集 メニュー、データ メニューなど)をリセットするには、アプリケーションフレームメニューの下でリセットをクリックします。
  4. コンテキストメニューをリセットするには、コンテキストメニューを選択し、リセットをクリックします。
  5. 閉じるをクリックします。

ショートカットキーのリセット

  1. ツール > カスタマイズを選択します。
  2. キーボードタブをクリックします。
  3. 変更したすべてのキーボードショートカットをリセットするには、すべてリセットをクリックします。
  4. 1つのキーボードショートカットをリセットするには、コマンドを選択して現在のキーをクリックし、次に取り除くをクリックします。
  5. 閉じるをクリックします。

ボタンイメージをリセット

  1. ツール > カスタマイズを選択します。
  2. Minitabで、メニュー項目またはツールバー項目を右クリックし、リセットを選択します。
  3. 閉じるをクリックします。
本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください