再利用可能なODBC Execファイルの作成

ワークシートのアップデートにファイル > データベースを照会 (ODBC)を頻繁に使うのであれば、Execファイルでプロセスを自動化できます。

Execファイルを作成する

  1. ファイル > データベースを照会 (ODBC)を使用してデータをインポートします。 詳細は、ODBCを使用したデータベースからのデータのインポートを参照してください。
  2. Project Managerツールバーの[履歴を表示]ボタンをクリックし、[履歴]ウィンドウを開きます。
  3. ODBCセッションコマンドとサブコマンドを選択し、右クリックして名前を付けて保存するを選択します。
  4. ファイルの種類から、Exec(*.mtb)を選択します。
  5. ファイル名(GetData.MTBなど)を入力します。
  6. ファイルの保存場所を選択し、保存をクリックします。
  7. Execファイルを実行するには、次の手順を実行します。
    1. ツール > Execを実行するを選択します。
    2. Execファイルを実行したい回数を指定します。
    3. ファイルを選択するをクリックします。
    4. Execファイルを選択し、開くをクリックします。

Execファイルの出力列を指定する

Execファイルを実行するたびに同じMinitabワークシートのデータを更新する場合、Execファイルを編集してMinitabワークシートで使用する列を指定する必要があります。

ヒント

ODBC SQLや接続文字列では、1行で二重引用符間に含めることができる最大文字数は80文字です。80文字を超えるテキスト文字列を使用するには、アンパサンド(&)キーを使用して文字列を複数行の小さいセクションに分割します。 たとえば、次のセッションウィンドウの内容では、二重引用符で囲まれた長いテキスト文字列がアンパサンドで次の行につなげられています。

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. Minitabで、ツール > メモ帳を選択します。
  2. メモ帳で、ファイル > 開くを選択します。ファイルの種類をすべて (*.*)に変更し、作成したMTBファイルを開きます。
  3. 各ODBCセッションコマンドおよび対応するサブコマンドで、次の操作を実行します。
    1. 最後のサブコマンドの末尾にあるピリオド(.)をセミコロン(;)に置き換え、Enterキーを押します。
    2. 続く行で、データを保存する列を指定します。 たとえば、Columns 'First Name' 'Last Name' 'City' 'Country'と入力します。この例は、Minitabワークシートの列がすでにExecファイルと一致するように命名されている場合にのみ機能します。

      各列の名前を個別に指定する代わりに、Columns C1-C10のように列IDの範囲を指定できます。範囲の指定は、多数の列をインポートする場合に特に役立ちます。

  4. ファイル > 保存を選択し、メモ帳を閉じます。

Execファイルを実行する

  1. ツール > Execを実行するを選択します。
  2. ファイルを選択するをクリックします。
  3. 保存したExecファイルを選択し、開くをクリックします。

メニューやツールバーからExecを実行するショートカットを追加するには、MinitabマクロまたはExecファイルを実行するショートカットのメニューまたはツールバーへの追加を参照してください。

本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください