概要

Minitabでメニューコマンドを使用する場合、アクションを記録するセッションコマンドが保存されます。これらのセッションコマンドを使用して、新しいデータの分析を迅速に繰り返すことができます。

各メニューコマンドには、対応するセッションコマンドがあります。セッションコマンドは、メインコマンドと、通常1つまたは複数のサブコマンドから構成されます。メインコマンドとサブコマンドの後には、列、定数、行列、テキスト文字列、数字などの一連の引数を指定できます。Minitabでは、次の3つの方法でセッションコマンドを使用できます。
  • セッションコマンドをセッションウィンドウまたはコマンドラインエディタに入力します。
  • 履歴フォルダからコマンドラインエディタにセッションコマンドをコピーします。
  • セッションコマンドをコピーしてexecファイルに保存します。

コマンドラインを表示してメニューからコマンドを実行する場合、対応するセッションコマンドはセッションウィンドウのコマンドラインペインに表示されます。これは、セッションコマンドを習得するための便利な方法です。

西部配送センターでは、新しいデータを入手するたびに、配達時間を継続的に収集し分析しています。品質の評価では、3月のデータについて工程能力分析を実行しました。この章では、セッションコマンドを使用して、4月のデータについて工程能力分析を実行します。

セッションコマンドの有効化と入力を行う

セッションコマンドを使用する方法の1つとして、セッションウィンドウのコマンドラインペインのコマンドプロンプトで入力する方法があります。デフォルトではペインを表示しないので、有効にする必要があります。

セッションコマンドを有効にする

  1. 前の章から継続して作業する場合は、ファイル > 新規作成 > プロジェクトを選択します。そうでない場合は、Minitabを起動します。
  2. サンプルデータを開く、セッションコマンド.MTW.
  3. セッションウィンドウをクリックしてアクティブにします。
  4. エディタ > コマンドプロンプトを表示を選択します。

    MTB>プロンプトはセッションウィンドウのコマンドラインペインに表示されます。

  5. (オプション)すべてのMinitabセッション(デフォルト)のセッションコマンドを有効にします。
    1. ツール > オプションを選択します。セッションウィンドウを展開してコマンドを出すを選択します。
    2. コマンドプロンプトの下の表示をクリックします。

セッションコマンドを使用して分析を実行する

品質の評価では、工程能力分析を実行して配送時間が規格に適合しているかどうか(配達日数が6日未満)を調べました。この分析を実行するために、統計 > 品質ツール > 工程能力分析 > 正規を使用しました。次に、データ列、サブグループ列、上側規格限界を入力しました。

西部配送センターでの配達時間の評価を継続的に行うために、この分析を一定の間隔で繰り返すことにします。新しいデータを収集する場合、いくつかのセッションコマンドを使用してこの分析を繰り返すことができます。

  1. コマンドラインペインのMTB >プロンプトでCAPABILITY「日数」「日付」を入力します。 セミコロンは、続けてサブコマンドを入力することを示します。
  2. Enterキーを押します。 MTB >SUBC>に変わったことに注目してください。SUBC>プロンプトを使用して、これまでの工程能力分析で使用したオプションに対するサブコマンドを追加できます。
  3. SUBC>プロンプトで、「USPEC 6.」と入力します。 ピリオドは、コマンドシーケンスの終わりを示します。
  4. Enterキーを押します。
4月の配送データの工程能力分析
ヒント

セッションコマンドを一覧化したPDFファイルを開くには、コマンドプロンプトにヘルプと入力します。

一連のコマンドを再実行する

Minitabでは、大部分のメニューコマンドのセッションコマンドが作成され、履歴フォルダに保存されます。これらのコマンドを再実行するには、そのコマンドを選択して編集 > コマンドラインエディタを選択します。

履歴フォルダおよびコマンドラインエディタを使用して、工程能力分析を再実行します。

  1. ウィンドウ > Project Managerを選択します。
  2. 履歴フォルダをクリックします。
  3. CAPABILITY '日数' '日付';をクリックし、Shiftキーを押しながら、USPEC 6.をクリックします。
  4. 編集 > コマンドラインエディタを選択します。
  5. コマンドを発行するをクリックします。
4月の配送データの工程能力分析

いくつかの簡単なステップを実行するだけで、工程能力分析を再作成できました。

execファイルを使用して分析を繰り返す

execファイルは、一連のMinitabコマンドを含むテキストファイルです。メニューコマンドやセッションコマンドを使用せずに分析を繰り返すには、コマンドをexecファイルとして保存し、execファイルを実行します。

ヒント

execファイルや他の複雑なマクロの詳細を確認するには、Minitabマクロのヘルプを開きます。

[履歴]フォルダからexecファイルを作成する

工程能力分析のセッションコマンドをexecファイルとして保存します。

  1. ウィンドウ > Project Managerを選択します。
  2. 履歴フォルダをクリックします。
  3. CAPABILITY '日数' '日付';をクリックして、Shiftキーを押しながらUSPEC 6.をクリックします。
  4. 選択されたテキストを右クリックし、名前を付けて保存するをクリックします。
  5. ファイルの保存先のフォルダを参照します。
  6. ファイル名に「配送グラフ」と入力します。
  7. ファイルの種類から、Exec(*.mtb)を選択します。保存をクリックします。

コマンドを再実行する

execファイルを実行することにより、この分析を繰り返すことができます。

  1. ツール > Execを実行するを選択します。
  2. ファイルを選択するをクリックします。
  3. ファイルShippingGraphs.MTBを選択し、開くをクリックします。
4月の配送データの工程能力分析

execファイル内のコマンドが実行され、工程能力分析が作成されます。

列名が一致する限り、どのワークシートを使用してもexecファイルを実行できます。そのため、同じ分析を行う必要のある他のMinitabユーザーとexecファイルを共有することができます。たとえば、西部配送センターの責任者が他の配送センターの責任者と配送グラフ.MTBを共有して、それぞれの配送データについて同じ分析を実行することができます。Execを別のワークシートまたは別の列に使用する場合は、メモ帳などのテキストエディタでExecを編集します。

プロジェクトを保存する

Minitabプロジェクトにすべての作業情報を保存します。

  1. ファイル > プロジェクトに名前を付けて保存するを選択します。
  2. ファイルの保存先のフォルダを参照します。
  3. ファイル名に、マイセッションコマンドと入力します。
  4. 保存をクリックします。

次の章の内容

この章では、メニューコマンドに代わってセッションコマンドを使用し、分析を短時間で繰り返す方法を学びました。次の章では、分析結果を同僚に示すためのレポートを作成します。

本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください