ワークシートの準備

概要

既に作成されているワークシートを使用することは頻繁にあります。ただし、分析を開始する前に、データをMinitabワークシートに入力またはインポートしなければならない場合もあります。

次の方法でデータをMinitabワークシートに入力できます。
  • データを直接ワークシートに入力する。
  • 他のアプリケーションからデータをコピーして貼り付ける。
  • データをMicrosoft Excelファイルまたはテキストファイルからインポートする。

データがMinitabに取り込まれた後、セルを編集したり、列と行を並べ替えたりして、データを分析に使用できるように準備しなければならない場合があります。通常の操作には、積み重ね、サブセット化、列名の指定、データ値の編集などがあります。

この章では、異なるソースからMinitabにデータをインポートします。また、配送データ.MTWを分析に使用できるように準備する方法についても学習します。

異なるソースからデータを取得する

『Minitab 18入門ガイド』の最初の分析では、3つの配送センターからのデータを含むワークシート配送データ.MTWが既に設定されていますが、3つの配送センターでは、配送データが次のように保存されています。
  • 東部配送センターのデータはMinitabワークシートに保存されています。
  • 中央配送センターのデータはMicrosoft Excelファイルに保存されています。
  • 西部配送センターのデータはテキストファイルに保存されています。

すべての配送データを分析するには、各ファイルをMinitabで開いてから、それらのファイルを1つのワークシート内で積み重ねます。

ワークシートを開く

東部配送センターのデータから始めます。

  1. サンプルデータを開く、東部.MTW.

Excelのスプレッドシートからデータを開く

中央配送センターのデータはExcelスプレッドシートに保存されています。Minitabでは、Excelファイルを開くことができます。

  1. サンプルデータを保存し、中央.xlsx.
  2. ファイル > 開くを選択します。
  3. データセットを保存したフォルダに移動します。
  4. Central.xlsxをダブルクリックします。
  5. OKをクリックします。

テキストファイル(*.txt)のデータを開く

西部配送センターのデータはテキストファイルに保存されています。テキストファイルを開きます。

  1. サンプルデータを保存し、西部.txt.
  2. ファイル > 開くを選択します。
  3. データセットを保存したフォルダに移動します。
  4. 西部.txtをダブルクリックします。
  5. OKをクリックします。

1つのワークシートにデータをまとめる

配送センターのワークシートの列名が同じになっています。データを分析しやすくするためには、名前が同じ列を積み上げることで、データを1つのワークシートにまとめる必要があります。ワークシート内でデータを移動するには、データをコピーして貼り付けるか、またはデータメニューのコマンドを使用します。

  1. データ > ワークシートの積み重ねを選択します。
  2. 積み重ねオプションから、新しいワークシートでワークシートを積み重ねを選択します。
  3. 矢印ボタンを使って3つのワークシートを選択可能なワークシートから積み重ねるワークシートに移動します。
  4. 新規ワークシート名に「マイ配送データ」と入力します。
  5. OKをクリックします。

列を移動して名前を変更する

[ソース]列には、配送センターのデータを識別するラベルが含まれています。[ソース]列をC1に移動して、列[センター]の名前を変更します。

  1. [ソース]列をクリックし、エディタ > 列の移動を選択します。
  2. 選択した列を移動させるで、列C1の前を選択します。
  3. OKをクリックします。
  4. 列名セル[ソース]をクリックし、「センター」と入力してEnterキーを押します。

分析用のワークシートを準備する

データは単一ワークシートにありますが、次の方法でデータを操作する必要があります。
  • データを再コード化する
  • 新しい列を追加する
  • 計算結果の列を作成する
ヒント

Minitabで利用できるデータ操作の完全な一覧はヘルプと使用方法の概要を参照して、ナビゲーションメニュー左側の「ワークシート、列、行のデータを操作する」をクリックします。その後、「使用方法」をクリックします。

データを再コード化する

[配送センター]列のラベルは、どの配送センターのデータであるかを適切に表しているとはいえません。ラベルを変更して、ファイル拡張子を削除します。

  1. データ > 再コード化 > テキストへを選択します。
  2. 次の列の値を再コード化に「センター」と入力します。
  3. 方法で、個別値を再コード化を選択します。
  4. 再コード化された値で、Eastern.MTWを東部で置き換えます。
  5. 再コード化された値で、Western.txtを西部で置き換えます。
  6. 再コード化された列の保存場所から、元の列を選択します。
  7. OKをクリックします。

これで、センター列のラベルは、東部中央西部になります。

差を計算する

新しいワークシートを保存し分析を実行する前に、受注から配達までに経過した日数を計算する必要があります。Minitabの計算機を使用すると、これらの値を計算する計算式を列に割り当てることができます。データを変更または追加すると、計算された値も自動的に更新されます。

列を挿入する

到着ステータスの間に列を挿入します。

  1. C4のいずれかのセルをクリックしてその列をアクティブにします。
  2. 右クリックして、列の挿入を選択します。
  3. C4の名前のセルをクリックします。「日数」と入力してEnterキーを押します。

計算式を列に割り当てる

Minitabの計算機を使用して、基本的な算術演算関数または数値演算関数を実行します。結果は列または定数に保存されます。計算式を列に割り当て、データが変更された場合には計算された値も自動的に更新されるようにできます。

配達時間を計算し、日数列に値を保存します。

  1. 計算 > 計算機を選択します。
  2. 結果の保存場所に「日数」と入力します。
  3. に「到着-注文」と入力します。
  4. 計算式として割り当てるを選択します。
  5. OKをクリックします。

列を選択し、エディタ > 計算式 > 計算式を列に割り当てるを選択して、計算式を列に追加することもできます。

ヒント

列の計算式の詳細は、計算機の関数を参照してください。Minitabの計算機と使用できる演算および関数の詳細は、計算機の概要を参照してください。

ワークシートを確認する

日数列には、計算された、配達時間を表す値が格納されます。これらの値の単位は日数です。列に計算式を割り当てると、ワークシートの列見出しの右上にステータスインジケータが表示されます。このインジケータは、計算式が適切に定義されているかどうか、および値を再計算してデータを更新する必要があるかどうかを示します。緑のチェックマーク は、データが最新の状態になっていることを示します。

ヒント

ポインタをステータスインジケータの上にのせ、列に割り当てられている計算式を表示します。計算式を編集するには、ステータスインジケータをダブルクリックします。

ワークシートを更新する

中央配送地域での出荷物の到着日付に誤りがあることに気付いたとします。この場合は、ワークシートの日付を訂正すれば、日数列も自動的に更新されます。

行127の到着日付を更新します。

  1. 到着列で、行127をダブルクリックして編集モードにします。2013/3/7 9:172013/3/8 9:17に変更します。
  2. Enterキーを押します。
日数列の値が、2.98125から3.98125に自動的に更新されます。
元のワークシート
更新されたワークシート

手動で計算式を更新するには、エディタ > 計算式 > すべての計算式を自動的に計算するを選択し、このオプションのチェックマークを外します。ワークシートの値が変更され、列の計算式が期限切れになると、その列のステータスインジケータが黄色の三角に変わります。エディタ > 計算式 > すべての計算式をただちに計算するを選択し、プロジェクトのすべての計算式を更新します。

ワークシートを保存する

Minitabワークシートにすべての作業情報を保存します。

  1. ワークシート内をクリックし、ファイル > ワークシートに名前を付けて保存するを選択します。
  2. ファイルの保存先のフォルダを参照します。
  3. ファイル名に「マイ配送データ」と入力します。
  4. ファイルの種類から、Minitabを選択します。
  5. 保存をクリックします。

次の章の内容

複数のソースからの配送センターのデータはMinitab内にあり、分析用に適切に設定されています。次の章では、今後の分析を簡単に実行できるようにMinitabのデフォルト設定を調整します。

本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください