Minitabのカスタマイズ

概要

Minitabには、デフォルトオプションを変更したり、カスタムツールバーやキーボードショートカットを作成したりするためのツールが用意されています。

ツール > オプションを使用して、次のような多数のMinitab機能のデフォルトオプションを変更します。
  • プログラムの設定(メモリ使用量、初期ディレクトリ、ウィンドウレイアウト、およびダイアログボックスなど)
  • ワークシートおよびセッションウィンドウ
  • 統計コマンド
  • グラフ
次の分析を行うには、ツール > カスタマイズを使用します。
  • メニュー項目にショートカットキーを割り当てる
  • Minitabでのツールバー表示方法のオプションを設定する
  • メニュー項目のカスタムアイコンやツールバーボタンを作成する

最初の分析が完了し、レポートを作成しました。ツール > オプションおよびツール > カスタマイズを使用して、今後の分析を迅速かつ簡単に実行できるようにMinitabインターフェイスをカスタマイズします。

オプションを設定する

Minitabセッション中に、グラフ表示オプションの変更やセッションコマンドプロンプトの有効化など、多くのオプションを変更できます。ただし、Minitabを閉じると、これらのオプションはデフォルト設定に戻ります。

特定のオプションをすべてのMinitabセッションのデフォルトオプションにするには、ツール > オプションを使用します。変更したオプションは、再び変更するまで有効です。

いつでもMinitabのデフォルトオプションを復元できます。詳細は、下記の「Minitabのデフォルトオプションを復元する」を参照してください。

自動フットノートを追加する

今後は同様のデータから同じグラフを作成する予定なので、それぞれの分析結果を見分ける方法が必要です。そこで、グラフに自動フットノートを追加し、ワークシート名と修正日付を含めるようにします。

  1. サンプルデータを開く、配送データ.MTW.
  2. ツール > オプションを選択します。グラフィックスを展開し、さらに注釈を展開してマイフットノートを選択します。
  3. マイフットノートに含める情報で、ワークシート名最後にグラフを修正した日付を選択します。
  4. カスタムテキストに、配送センターの効率と入力します。
  5. OKをクリックします。

これらのオプションを使用することで、グラフを作成するたびにフットノートが追加されます。

フットノートを表示するヒストグラムを作成する

自動フットノートの例を表示するために、ヒストグラムを作成します。

  1. グラフ > ヒストグラムを選択します。
  2. 適合をクリックし、OKをクリックします。
  3. グラフ変数に「日数」と入力します。
  4. 多重グラフをクリックします。
  5. グループ変数タブで、同じグラフウィンドウ内に各グループのグラフを表示に「センター」と入力します。
  6. 各ダイアログボックスでOKをクリックします。

カスタムツールバーを作成する

ツール > カスタマイズを使用して、頻繁に使用するコマンドを含む新しいメニューおよびツールバーを作成します。

ツールバーを作成する

分析によっては、実行時に複数の同じメニュー項目を何度も実行することがあります。これらの項目をカスタムツールバーに追加すれば、今後の分析を簡素化できます。

配送データの分析で使用したコマンドの一部を含むカスタムツールバーを作成します。

  1. ツール > カスタマイズを選択します。
  2. ツールバータブで、新規作成をクリックします。
  3. ツールバー名に、配送データと入力します。
  4. OKをクリックします。

空白のツールバーが作成されて、ツールバーリストに新しいツールバーが表示されます。

ツールバーにコマンドを追加する

配送データの分析で、グラフ > ヒストグラムおよびアシスタント > グラフ分析 > 散布図 (グループ)を使用しました。空白のツールバーにこれらのコマンドを追加します。

  1. 空白のツールバーをドラッグして、既存のMinitabツールバーの横にドッキングします。
  2. コマンドタブで、カテゴリ (分類)の下のグラフを選択します。
  3. コマンドで、ヒストグラムを選択します。
  4. ヒストグラムをクリックし、新しいツールバーにドラッグします。
  5. カテゴリ (分類)で、アシスタントを選択します。
  6. コマンドで、散布図 (グループ)を選択します。
  7. 散布図 (グループ)をクリックし、新しいツールバーにドラッグします。
  8. 閉じるをクリックします。
ヒント

カスタムメニューを作成することもできます。詳細は、メニュー、ツールバー、およびショートカットキーのカスタマイズを参照してください。

ショートカットキーを割り当てる

Minitabには、頻繁に使用される機能の多くのショートカットキーがあります。また、頻繁に使用するコマンドのショートカットキーを割り当てることもできます。ショートカットキーを割り当てるには、ツール > カスタマイズ > キーボードを使用します。

配送データの分析でヒストグラムを頻繁に作成するので、このコマンドにショートカットキーを割り当てます。

  1. ツール > カスタマイズを選択します。
  2. キーボードタブで、カテゴリ (分類)からグラフを選択します。
  3. コマンドで、ヒストグラムを選択します。
  4. 新しいショートカットキーの入力内をクリックします。
  5. Ctrl+Shift+Hキーを押します。
    新しいショートカットキーの入力では、割り当て先のテキストで、選択したキーの組み合わせについて現在のステータスが表示されます。この場合、テキストは[未割り当て]です。既にコマンドに割り当てられているキーまたはキーの組み合わせがあれば、ここに表示されます。選択した組み合わせが既に使用されていた場合は、まずその組み合わせの割り当てを削除してから新しいコマンドに割り当てる必要があります。
  6. 割り当てをクリックします。新しいショートカットキーが現在のキーに表示されます。
  7. 閉じるをクリックします。

これで、Ctrl+Shift+Hキーを押すことによってヒストグラムのギャラリーにアクセスできるようになりました。

ヒント

デフォルトのショートカットキーの一覧はショートカットキーを参照してください。

Minitabのデフォルトオプションを復元する

変更したオプションや、日付/時刻設定および値の順序設定への変更はプロファイルに保存されます。このプロファイルは、ツール > プロファイルの管理を使用して、有効にしたり、無効にしたりできます。また、このプロファイルをエクスポートして、他のユーザーと共有することもできます。

Minitab 18入門ガイド』での作業で調整したすべてのオプションは既にアクティブプロファイルに保存されています。現在のプロファイルを無効にしてMinitabのデフォルトオプションを復元し、以降の配送センターの分析に使用できるようにプロファイルの名前を変更します。

  1. ツール > プロファイルの管理を選択します。
  2. 「マイプロファイル」アクティブなプロファイルから使用可能なプロファイルに移動します。
  3. 使用可能なプロファイルで、[マイプロファイル]をダブルクリックし、「配送センター分析」と入力します。
  4. OKをクリックします。

これでデフォルトオプションが復元されました。Minitabに新しいアクティブプロファイルが作成され、追加で行うすべての変更がこのプロファイルに保存されます。

Minitab 18入門ガイド』のセッションで調整したオプションを有効にするには、現在のアクティブプロファイルを使用可能なプロファイルに移動して、「配送センター分析」アクティブなプロファイルに移動し、OKをクリックします。

ハードディスクドライブにインストールされているメインのMinitab 18フォルダの下のEnglishフォルダにあるRestore Minitab Defaults Englishというショートカットをダブルクリックしても、Minitabのデフォルトオプションをリセットできます。このプログラムを実行する前に、保存しておきたいすべてのプロファイルをエクスポートします。

プロジェクトを保存する

Minitabプロジェクトにすべての作業情報を保存します。

  1. ファイル > プロジェクトに名前を付けて保存するを選択します。
  2. ファイルの保存先のフォルダを参照します。
  3. ファイル名に、マイカスタマイズと入力します。
  4. 保存をクリックします。
本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください