Quel est le schéma de codage numérique pour les couleurs/symboles/types de lignes ?

L'Aide de Minitab contient des rubriques qui répertorient les différents codes. Vous pouvez trouver ces rubriques par une simple recherche.

  1. Sélectionnez Aide > Aide, puis cliquez sur Commandes de session sous Références.
  2. Dans la fenêtre Aide sur les commandes de session Minitab, sélectionnez l'onglet Rechercher.
  3. Saisissez "couleurs standard", "type de symbole" ou "types de lignes" en fonction des codes que vous souhaitez trouver.
  4. Sélectionnez la case Rechercher dans les titres uniquement.
  5. Cliquez sur Répertorier les rubriques pour consulter la rubrique relative aux couleurs standard, au type de symbole ou au type de ligne qui contient un tableau du schéma de codage numérique.

Comment enregistrer un graphique Minitab au format JPEG, PNG, TIF ou Windows BMP à l'aide de commandes ?

Créez le graphique à l'aide de la commande de session, de la sous-commande GSAVE et de la sous-commande de format de graphique applicable. Par exemple, supposons que vous souhaitiez créer un histogramme de la colonne C1 et enregistrer le graphique au format JPEG à la racine du lecteur C: avec le nom de fichier Défauts. Utilisez les commandes suivantes :

HIST C1;
GSAVE "C:\Défauts";
JPEG.
Remarque

Pour le format TIFF (Tagged Image File Format), utilisez la sous-commande TIFC. Pour le format PNG (Portable Network Graphics), utilisez la sous-commande PNGC. Pour le format Windows BMP (Windows Bitmap), utilisez la sous-commande BMPC.

Remarque

Dans une macro, il arrive parfois que la commande GSAVE soit utilisée dans d'autres commandes, comme CALL. La sous-commande de format de graphique mentionnée ici, telle que JPEG, ne doit pas être insérée dans de tels cas.

Comment imprimer un graphique depuis la macro que j'ai écrite ?

Utilisez la commande GPRINT.

Exemple 1

Cet exemple crée un histogramme et une boîte à moustaches, puis imprime la boîte à moustaches.

HIST C1;
BOXPLOT C1;
GPRINT.

Exemple 2

Cet exemple crée un histogramme et une boîte à moustaches, enregistre les graphiques sous le nom HIST.MGF et BOX.MGF, respectivement, puis imprime la boîte à moustaches.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

Exemple 3

Cet exemple crée un histogramme et une boîte à moustaches, enregistre les graphiques sous le nom HIST.MGF et BOX.MGF, respectivement, puis imprime l'histogramme.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIST.MGF"
Remarque

Sans argument, comme dans les exemples 1 et 2, la commande GPRINT imprime la fenêtre Graphiques active. Avec un argument, la commande GPRINT ouvre le graphique indiqué et l'envoie à l'imprimante par défaut de l'ordinateur.

Comment ajouter la date du jour (ou la date et l'heure du jour) comme commentaire dans le graphique que je suis en train de créer avec une macro locale ?

Par exemple, supposons que vous souhaitiez ajouter la date actuelle comme commentaire dans un histogramme ou une colonne nommée YIELD.

Remarque

Les étapes ci-dessous supposent que les colonnes nommées YIELD et TMPDATE, ainsi que la constante nommée DATE, sont répertoriées dans la section de déclaration de la macro locale, et que la colonne YIELD contient des données.

  1. Utilisez la fonction TODAY() pour stocker la date actuelle dans une colonne :
    LET TMPDATE = TODAY()
    Remarque

    Si vous souhaitez ajouter la date et l'heure actuelles sur le graphique, utilisez NOW() au lieu de TODAY().

  2. Modifiez le type de données pour que la colonne soit formatée comme une colonne de texte :
    TEXT TMPDATE TMPDATE
  3. Stockez la date en tant que constante :
    LET DATE = TMPDATE
  4. Utilisez la constante dans la sous-commande FOOTNOTE :
    HIST YIELD;
    FOOTNOTE DATE.

Comment écrire une macro qui permet de contrôler la mise en attente une fois les graphiques créés ?

Pour contrôler la mise en attente, incluez l'une des formes de la commande GPAUSE suivantes dans votre macro :

GPAUSE

Cette commande indique à Minitab d'effectuer une mise en attente pendant K secondes (K peut être n'importe quel nombre entier compris entre 0 et 1800) après l'affichage de chaque graphique jusqu'à ce que vous appuyiez sur une touche ou sur un bouton de la souris.

GPAUSE K

Existe-t-il une commande de session permettant de fermer le dernier graphique ou tous les graphiques ?

Une commande de session non documentée, GMANAGER, peut être utilisée pour fermer les graphiques.

Remarque

Cette commande est encore à l'état d'expérimentation et n'a pas fait l'objet des mêmes tests rigoureux que les commandes référencées dans l'Aide. Bien qu'elle soit disponible, vous devez l'utiliser avec précaution ; nous n'assumerons aucune responsabilité concernant d'éventuels résultats inattendus. La forme et la syntaxe de cette commande peuvent être sujettes à des modifications.

Pour fermer le dernier graphique, utilisez la commande suivante :

GMANAGER;
CLOSE.

Pour fermer tous les graphiques, utilisez la commande suivante :

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

Si vous ne voulez pas être invité à enregistrer le graphique avant sa fermeture, procédez comme suit :

  1. Sélectionnez Outils > Options > Graphiques > Gestion du graphique.
  2. Sélectionnez Jamais en regard de Proposer d'enregistrer un graphique avant de le fermer. Cliquez sur OK.

Notez que les modifications que vous apportez dans Outils > Options s'appliquent à la fermeture de tous les graphiques ultérieurs.

Comment utiliser des sous-commandes telles que GSAVE et WTITLE pour des graphiques qui n'incluent pas ces sous-commandes ?

Vous pouvez utiliser des sous-commandes telles que GSAVE et WTITLE pour des graphiques qui n'incluent pas ces sous-commandes si vous utilisez également la sous-commande LAYOUT.

Utilisation de GSAVE et WTITLE pour GSUMMARY

Stat > Statistiques élémentaires > Récapitulatif graphique

Supposons que vous souhaitiez enregistrer le récapitulatif graphique de la colonne C1 au format JPEG avec le nom YIELD.JPG dans C:\My Statistics, et que vous vouliez que les mots "San Francisco" soient affichés dans la barre de titre du graphique. Utilisez les commandes suivantes :
LAYOUT;
GSAVE "C:\My Statistics\YIELD.JPG";
JPEG;
WTITLE "San Francisco".
GSUMMARY C1
ENDLAYOUT.

Utilisation de GSASVE et WTITLE pour une étude de R&R de l'instrumentation

Stat > Outils de la qualité > Etude de l'instrumentation > Etude de R&R de l'instrumentation (croisée)

Supposons que vous souhaitiez exécuter la commande Etude de R&R de l'instrumentation (croisée) suivante :
GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.
Supposons que vous souhaitiez enregistrer le graphique au format JPEG avec le nom GageRR.JPG dans Q:\Projects, et que vous vouliez que la mention "Instrumentation 1" soit affichée dans la barre de titre du graphique. Utilisez les commandes suivantes :
LAYOUT;
GSAVE "Q:\Project\GageRR.JPG";
JPEG;
WTITLE "Instrumentation 1".

GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.

ENDLAYOUT.
En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique