Créer une commande personnalisée

Vous pouvez créer une commande personnalisée, par exemple pour exécuter une macro Minitab, ouvrir une application différente ou accéder à un site Web.

Par exemple, vous pouvez ajouter une commande personnalisée au menu Outils Minitab pour ouvrir Quality Companion, un autre produit Minitab.

Pour ajouter une nouvelle commande, vous devez d'abord la créer pour le menu Outils. Vous pouvez ensuite déplacer la commande du menu Outils vers un autre menu ou vers une barre d'outils.

  1. Sélectionnez Outils > Personnaliser.
  2. Sous l'onglet Outils, cliquez sur le bouton Nouveau (Inser) .
  3. Entrez un nom, par exemple Quality Companion.
  4. Saisissez les informations de la commande :
    • Dans la zone Commande, saisissez le chemin de l'outil ou recherchez l'application externe ou l'adresse Web correspondantes (par exemple : C:\Program Files (x86)\Minitab\Quality Companion 3\Companion\qc.exe).
    • Si nécessaire, dans Arguments, incluez un argument à transmettre à l'application vers laquelle vous ajoutez un lien (ouverture automatique d'un fichier spécifique par l'application, par exemple).
    • Si nécessaire, dans Répertoire initial, créez un dossier d'enregistrement initial pour l'application vers laquelle vous ajoutez le lien.
  5. Cliquez sur Fermer.
    Pour exécuter la nouvelle commande, sélectionnez-la dans le menu Outils.

Déplacer ou supprimer une commande d'un menu ou d'une barre d'outils

Vous pouvez déplacer les commandes vers un autre emplacement d'un menu ou d'une barre d'outils. Pour alléger les barres d'outils, vous pouvez également supprimer les commandes que vous n'utilisez pas.

  1. Sélectionnez Outils > Personnaliser.
  2. Pour supprimer une commande, faites-la glisser hors du menu ou de la barre d'outils (la boîte de dialogue doit être ouverte).
  3. Pour déplacer une commande, faites-la glisser de son emplacement d'origine vers le nouvel emplacement (la boîte de dialogue doit être ouverte). Vous pouvez déplacer toutes les commandes, sauf celles qui se trouvent dans la première section du menu Outils.
  4. Pour déplacer une commande personnalisée de la première section du menu Outils, effectuez les opérations suivantes :
    1. Dans l'onglet Commandes, sous Catégories, sélectionnez le groupe auquel appartient la commande.
    2. Sous Commandes, sélectionnez la commande et faites-la glisser vers le menu ou la barre d'outils (la boîte de dialogue doit être ouverte).
  5. Cliquez sur Fermer.

Créer un menu personnalisé

Vous pouvez créer un nouveau menu pour une tâche ou un projet spécifique. Par exemple, vous pouvez créer un menu contenant les outils à utiliser pour créer des rapports mensuels.

  1. Sélectionnez Outils > Personnaliser.
  2. Dans l'onglet Commandes, sous Catégories, sélectionnez Nouveau menu.
  3. Sous Commandes, sélectionnez Nouveau menu et faites-le glisser vers la barre de menus principale de Minitab.
  4. Cliquez avec le bouton droit de la souris sur Nouveau menu et sélectionnez Nommer le bouton. Saisissez le nom du menu (par exemple Outils de rapports mensuels) puis cliquez surOK.
  5. Sous Catégories, sélectionnez la catégorie de la commande à ajouter à votre nouveau menu (par exemple Graphique).
  6. Sous Commandes, sélectionnez la commande et faites-la glisser sous le nouveau menu.
  7. Répétez les étapes 5 et 6 pour toutes les commandes à ajouter au menu.
  8. Cliquez sur Fermer.

Créer une barre d'outils personnalisée

Vous pouvez créer une nouvelle barre d'outils pour une tâche ou un projet spécifique. Par exemple, créez une barre d'outils pour les analyses régulièrement utilisées.

  1. Sélectionnez Outils > Personnaliser.
  2. Dans l'onglet Barres d'outils, cliquez sur Nouveau.
  3. Saisissez le nom de la barre d'outils (par exemple Mes outils), puis cliquez sur OK.
  4. Faites glisser la nouvelle barre d'outils vers l'emplacement de votre choix dans Minitab.
  5. Dans l'onglet Commandes, choisissez une valeur Catégories pour les commandes, puis faites glisser la commande à ajouter à la barre d'outils.
  6. Répétez l'étape 5 pour toutes les commandes à ajouter à la barre d'outils.
  7. Dans l'onglet Barres d'outils, sélectionnez Afficher les étiquettes de texte pour afficher le nom de la commande dans la barre d'outils.
  8. Cliquez sur Fermer.

Modifier un menu contextuel

Les menus contextuels sont uniquement activés en cas d'activation d'une fenêtre particulière. La plupart sont des menus qui apparaissent quand vous effectuez un clic droit. Par exemple, lorsque vous cliquez sur un graphique avec le bouton droit de la souris, le menu contextuel Vue de graphique s'affiche.

  1. Sélectionnez Outils > Personnaliser.
  2. Dans l'onglet Menu, dans Sélectionner le menu contextuel, sélectionnez le menu contextuel à modifier.
    La commande contextuelle s'affiche.
  3. Dans l'onglet Commandes, sous Catégories, sélectionnez la catégorie qui contient la commande à ajouter.
  4. Sous Commandes, faites glisser la commande vers le menu contextuel.
  5. Pour supprimer une commande du menu contextuel, sélectionnez-la et faites-la glisser hors du menu.
  6. Cliquez sur Fermer.

Modifier les options d'affichage des barres d'outils

Modifiez l'affichage des info-bulles et des icônes pour les barres d'outils.

  1. Sélectionnez Outils > Personnaliser.
  2. Sous l'onglet Options, effectuez l'une des actions suivantes :
    • Pour afficher des info-bulles pour des barres d'outils, sélectionnez Afficher les écrans de conseils sur les barres d'outils.
    • Pour afficher des touches de raccourci dans les info-bulles de barres d'outils, sélectionnez Afficher les touches de raccourci dans les écrans de conseils.
    • Pour afficher de grandes icônes sur les boutons des barres d'outils, sélectionnez Grandes icônes.
  3. Cliquez sur Fermer.

Ajouter un raccourci clavier pour une commande

Ajoutez des touches de raccourci pour exécuter plus rapidement les commandes que vous utilisez le plus souvent. Par exemple, créez un raccourci clavier pour ouvrir la boîte de dialogue Test t à 2 échantillons.

  1. Sélectionnez Outils > Personnaliser.
  2. Dans l'onglet Clavier, dans Catégorie, sélectionnez la catégorie à laquelle appartient la commande (par exemple, Stat).
  3. Sous Commandes, sélectionnez la commande (par exemple Test t à 2 échantillons [Statistiques élémentaires]).
  4. Cliquez dans le champ Appuyez sur la nouvelle touche de raccourci, puis appuyez sur les touches du raccourci (par exemple Ctrl+Q).
    Minitab affiche un message si le raccourci clavier est déjà attribué.
  5. Cliquez sur Affecter et fermez la fenêtre.

Modifier l'image d'un bouton de barre d'outils

Vous pouvez modifier l'image d'un bouton de barre d'outils.

  1. Sélectionnez Outils > Personnaliser.
  2. Pour copier une image d'un bouton vers un autre, procédez comme suit :
    1. Cliquez avec le bouton droit de la souris sur l'image de bouton à copier, puis sélectionnez Copier l'image de bouton.
    2. Cliquez avec le bouton droit de la souris sur le bouton sur lequel vous souhaitez coller l'image et sélectionnez Coller l'image de bouton.
  3. Pour modifier une image de bouton, cliquez sur l'image avec le bouton droit de la souris et sélectionnez Modifier l'image de bouton. Modifiez l'image à l'aide des outils de dessin.
  4. Pour afficher le nom du bouton au lieu de l'image, cliquez sur le bouton avec le bouton droit de la souris et sélectionnez Texte. Pour afficher le texte et l'image, sélectionnez Image et texte.
  5. Cliquez sur Fermer.

Rétablir les paramètres par défaut.

Vous pouvez rétablir les paramètres par défaut des barres d'outils, des menus et des touches de raccourci.

Restaurer une barre d'outils

  1. Sélectionnez Outils > Personnaliser.
  2. Cliquez sur l'onglet Barres d'outils.
  3. Pour restaurer une barre d'outils, cliquez dessus, puis sur Restaurer.
  4. Pour restaurer toutes les barres d'outils, cliquez sur Tout restaurer.
  5. Pour supprimer une barre d'outils personnalisée, sélectionnez-la dans la liste Barres d'outils et cliquez sur Supprimer.
  6. Cliquez sur Fermer.

Restaurer un menu

  1. Sélectionnez Outils > Personnaliser.
  2. Cliquez sur l'onglet Menu.
  3. Pour restaurer l'ensemble des menus non contextuels, sous-menus et commandes (par exemple, les menus Outils, Edition, Données, etc.), cliquez sur Restaurer, sous Menus de cadre d'application.
  4. Pour restaurer un menu contextuel, sélectionnez-le et cliquez sur Restaurer.
  5. Cliquez sur Fermer.

Restaurer une touche de raccourci

  1. Sélectionnez Outils > Personnaliser.
  2. Cliquez sur l'onglet Clavier.
  3. Pour restaurer tous les raccourcis clavier que vous avez modifiés, cliquez sur Tout restaurer.
  4. Pour restaurer un raccourci clavier, choisissez la commande, cliquez dans Touches actuelles cours, puis sur Supprimer.
  5. Cliquez sur Fermer.

Restaurer l'image d'un bouton

  1. Sélectionnez Outils > Personnaliser.
  2. Dans Minitab, cliquez avec le bouton droit de la souris sur une option de menu ou un élément de barre d'outils et cliquez sur Restaurer.
  3. Cliquez sur Fermer.
En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique