Vous pouvez ouvrir les fichiers Minitab, les fichiers Microsoft Excel et les fichiers texte directement dans Minitab. Minitab peut importer jusqu'à 4000 colonnes. Le nombre de cellules pouvant être importées dans Minitab dépend de votre espace d'adresse mémoire disponible.

Lorsque vous ouvrez un fichier, le contenu du fichier est copié dans le projet. Ainsi, lorsque vous modifiez les données ou les graphiques dans un projet, cela n'affecte pas le fichier d'origine.

Ouvrir un fichier Excel (XLS, XLSX ou XML)

Si le fichier Excel contient plusieurs feuilles, vous pouvez contrôler séparément l'importation de chaque feuille.

  1. Sélectionnez Fichier > Ouvrir.
  2. Accédez au fichier Excel et sélectionnez-le.
  3. Cliquez sur Ouvrir.
    La boîte de dialogue Ouvrir un fichier Excel affiche la première feuille Excel. Chaque feuille dispose de son propre onglet.
  4. Pour chaque feuille, procédez comme suit :
    • Si le fichier Excel contient plusieurs feuilles et que vous ne souhaitez pas importer une feuille, désélectionnez Importer cette feuille.
    • Indiquez l'étendue des lignes à importer dans Première ligne et Dernière ligne.
    • Si la première ligne de données à importer contient les noms de colonnes, sélectionnez Les données comportent des noms de colonnes.
    • Si vous ne souhaitez pas importer une colonne, désélectionnez la case correspondante.
    • Pour modifier le type de données d'une colonne, sélectionnez un autre type de données dans la liste déroulante (Numérique, Texte ou Date/heure).
    • Pour obtenir un aperçu de la feuille de travail Minitab, cliquez sur Aperçu de la feuille de travail Minitab.
  5. Cliquez sur Options pour modifier l'un des paramètres de nettoyage de données suivants pour le fichier en cours d'ouverture :
    • Quelles sont les valeurs qui représentent des données manquantes dans votre fichier ? Minitab utilise le symbole * pour les valeurs numériques et de date/d'heure manquante, ainsi qu'un espace pour les valeurs de texte manquantes. Si votre fichier ne respecte pas ces conventions, précisez les conventions des valeurs manquantes pour Colonnes numériques et Colonnes de texte dans le fichier. Par exemple, si vous entrez 999, Minitab convertit toutes les instances de 999 en symbole de valeur manquante *.
    • Ne pas importer les lignes vides : sélectionnez cette option si vous ne souhaitez pas importer les lignes vides.
    • Ajouter les valeurs manquantes pour que le nombre de lignes soit identique dans toutes les colonnes : sélectionnez cette option pour ajouter des valeurs manquantes aux colonnes plus petites afin que toutes les colonnes contiennent le même nombre de lignes.
    • Supprimer les caractères non imprimables et les espaces en trop : sélectionnez cette option pour supprimer les caractères non imprimables et les espaces supplémentaires des colonnes de texte. Lorsque vous importez du texte à partir de sources externes, des caractères non imprimables risquent de s'imbriquer dans le texte. Les espaces simples entre les mots seront conservés.
    • Corriger les non-correspondances de casse : sélectionnez cette option pour corriger les incohérences de casse dans les colonnes de texte en mettant en majuscules toutes les valeurs correspondantes dans la colonne lorsque la première occurrence d'une valeur texte apparaît en lettres majuscules. Cette option s'applique uniquement aux données dans les colonnes, pas aux noms de colonnes. Par exemple, si les trois premières valeurs d'une colonne sont Rouge rouge ROUGE, et que vous sélectionnez cette option, les valeurs sont importées sous la forme Rouge Rouge Rouge.
  6. Cliquez sur OK dans chaque boîte de dialogue.
Conseil

Pour modifier les paramètres d'importation de fichiers par défaut, sélectionnez Outils > Options > Ouvrir.

Ouvrir un fichier texte (CSV, TXT, DAT)

Minitab peut ouvrir les fichiers au format texte brut (ANSI ou Unicode), qui portent l'extension .txt (pour texte), .dat (pour données) ou .csv (pour Comma-Separated Values, valeurs séparées par des virgules). Si les données à utiliser se trouvent dans un fichier dont l'extension ne figure pas dans la liste déroulante, enregistrez les données sous forme de fichier texte et importez-le. La plupart des applications permettent de créer des fichiers texte.

  1. Sélectionnez Fichier > Ouvrir.
  2. Accédez au fichier texte et sélectionnez-le.
  3. Cliquez sur Ouvrir.
    La boîte de dialogue Ouvrir un fichier texte affiche une représentation du fichier texte.
  4. Indiquez l'étendue des lignes à importer dans Première ligne et Dernière ligne.
  5. Si la première ligne de données à importer contient les noms de colonnes, sélectionnez Les données comportent des noms de colonnes.
  6. Dans Délimiteur de champ , sélectionnez le caractère qui sépare les valeurs du fichier texte. Si vous sélectionnez Personnalisé, entrez un caractère personnalisé. Minitab interprète deux séparateurs successifs comme une valeur manquante.
  7. Dans Identificateur de texte , sélectionnez le caractère qui délimite les valeurs texte. Des identificateurs de texte sont nécessaires uniquement si la valeur texte intègre des délimiteurs de champs. Par exemple, si le délimiteur de champ est un espace et que la valeur texte est John Smith, la valeur texte doit être placée entre des identificateurs de texte.
  8. Dans Séparateur décimal , sélectionnez le caractère utilisé pour séparer la partie entière et la partie décimale d'un nombre. Par défaut, Minitab utilise le séparateur spécifié dans les paramètres régionaux de votre ordinateur.
  9. Si vous ne souhaitez pas importer une colonne, désélectionnez la case correspondante.
  10. Pour modifier le type de données d'une colonne, sélectionnez un autre type de données dans la liste déroulante (Numérique, Texte ou Date/heure).
  11. Pour obtenir un aperçu de la feuille de travail Minitab, cliquez sur Aperçu de la feuille de travail Minitab.
  12. Cliquez sur Options pour modifier l'un des paramètres de nettoyage de données suivants pour le fichier en cours d'ouverture :
    • Quelles sont les valeurs qui représentent des données manquantes dans votre fichier ? Minitab utilise le symbole * pour les valeurs numériques et de date/d'heure manquante, ainsi qu'un espace pour les valeurs de texte manquantes. Si votre fichier ne respecte pas ces conventions, précisez les conventions des valeurs manquantes pour Colonnes numériques et Colonnes de texte dans le fichier. Par exemple, si vous entrez 999, Minitab convertit toutes les instances de 999 en symbole de valeur manquante *.
    • Ne pas importer les lignes vides : sélectionnez cette option si vous ne souhaitez pas importer les lignes vides.
    • Ajouter les valeurs manquantes pour que le nombre de lignes soit identique dans toutes les colonnes : sélectionnez cette option pour ajouter des valeurs manquantes aux colonnes plus petites afin que toutes les colonnes contiennent le même nombre de lignes.
    • Supprimer les caractères non imprimables et les espaces en trop : sélectionnez cette option pour supprimer les caractères non imprimables et les espaces supplémentaires des colonnes de texte. Lorsque vous importez du texte à partir de sources externes, des caractères non imprimables risquent de s'imbriquer dans le texte. Les espaces simples entre les mots seront conservés.
    • Corriger les non-correspondances de casse : sélectionnez cette option pour corriger les incohérences de casse dans les colonnes de texte en mettant en majuscules toutes les valeurs correspondantes dans la colonne lorsque la première occurrence d'une valeur texte apparaît en lettres majuscules. Cette option s'applique uniquement aux données dans les colonnes, pas aux noms de colonnes. Par exemple, si les trois premières valeurs d'une colonne sont Rouge rouge ROUGE, et que vous sélectionnez cette option, les valeurs sont importées sous la forme Rouge Rouge Rouge.
  13. Cliquez sur OK dans chaque boîte de dialogue.
Conseil

Pour modifier les paramètres d'importation de fichiers par défaut, sélectionnez Outils > Options > Ouvrir.

Ouvrir un fichier Minitab (MPJ, MTW, MGF)

Pour ouvrir un fichier de projet (MPJ), une feuille de travail (MTW) ou un fichier graphique Minitab (MGF), choisissez Fichier > Ouvrir, puis accédez au fichier et sélectionnez-le.

Remarque

Pour ouvrir un fichier de données échantillons, sélectionnez Aide > Données échantillons.

Vous pouvez ouvrir des fichiers créés dans des versions antérieures de Minitab en procédant comme suit :
  • Projets (MPJ) créés dans Minitab version 15 et les versions suivantes
  • Feuilles de travail (MTW) créées dans Minitab version 13 et les versions suivantes
  • Graphiques (MGF) créés dans Minitab version 14 et les versions suivantes

Pour ouvrir un fichier créé dans une version de Minitab plus récente que la vôtre, vous devez enregistrer le fichier au format de la version dont vous disposez. Par exemple, si vous voulez qu'un utilisateur de Minitab 17 ouvre un fichier de projet de Minitab 18, ouvrez le projet dans Minitab 18 et enregistrez le fichier sous un projet Minitab 17.

Ouvrir des feuilles de travail stockées dans un projet Minitab

Pour ouvrir des feuilles de travail stockées dans un projet Minitab sans ouvrir le fichier de projet, suivez la procédure ci-dessous.

  1. Sélectionnez Fichier > Ouvrir.
  2. Dans la liste déroulante du type de fichier, sélectionnez Feuilles de travail Minitab.
  3. Accédez au fichier de projet (MPJ) et sélectionnez-le, puis cliquez sur Ouvrir.
  4. Sélectionnez une ou plusieurs feuilles de travail à ouvrir. Pour en savoir plus sur une feuille de travail, vous pouvez effectuer l'une des opérations suivantes :
    • Pour afficher un aperçu de la feuille de travail dans Minitab, cliquez sur Aperçu.
    • Pour afficher la description d'une feuille de travail, cliquez sur Description.
  5. Cliquez sur OK.
En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique