Créer un fichier exécutable ODBC réutilisable

Si vous utilisez fréquemment l'option Fichier > Requête de la base de données (ODBC) pour mettre à jour votre feuille de travail, vous pouvez créer un fichier exécutable pour automatiser le processus.

Créer le fichier exécutable

  1. Importez les données à l'aide de Fichier > Requête de la base de données (ODBC). Pour plus d'informations, reportez-vous à la rubrique Importer des données à partir d'une base de données en utilisant ODBC.
  2. Cliquez sur le bouton Afficher l'historique sur la barre d'outils du Project Manager pour ouvrir la fenêtre Historique.
  3. Sélectionnez les sous-commandes et les commandes de sessions ODBC, puis cliquez avec le bouton droit de la souris et choisissez Enregistrer sous.
  4. Dans Type de fichier, sélectionnez Exécutable (*.mtb).
  5. Saisissez un nom de fichier (par exemple ObtenirDonnées.MTB).
  6. Sélectionnez un emplacement pour le fichier et cliquez sur Enregistrer.
  7. Pour lancer le fichier exécutable, procédez comme suit :
    1. Sélectionnez Outils > Lancer un exécutable.
    2. Indiquez le nombre de fois que vous souhaitez lancer le fichier exécutable.
    3. Cliquez sur Sélectionner un fichier.
    4. Sélectionnez le fichier exécutable, puis cliquez sur Ouvrir.

Spécifier des colonnes de résultats dans le fichier exécutable

Pour actualiser les données de la même feuille de travail Minitab chaque fois que vous lancez le fichier exécutable, vous devez modifier ce dernier en indiquant les colonnes à utiliser dans la feuille de travail Minitab.

Conseil

Dans une chaîne de connexion ou SQL ODBC, le nombre maximal de caractères pouvant être compris entre guillemets doubles sur une même ligne est de 80. Pour utiliser des chaînes de texte dépassant les 80 caractères, divisez la chaîne en fragments plus petits répartis sur plusieurs lignes, en utilisant la touche d'esperluette (&). Par exemple, dans le contenu suivant de la fenêtre Session, des esperluettes poursuivent sur la ligne suivante une longue chaîne de texte placée entre guillemets doubles.

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. Dans Minitab, sélectionnez Outils > Bloc-notes.
  2. Dans le Bloc-notes, sélectionnez Fichier > Ouvrir. Pour le type de fichier, indiquez Tous (*.*) et ouvrez le fichier .MTB que vous avez créé.
  3. Pour chaque commande de session ODBC et chaque sous-commande correspondante, effectuez les opérations suivantes :
    1. Remplacez le point (.) situé à la fin de la sous-commande finale par un point-virgule (;) et appuyez sur la touche Entrée.
    2. Sur la ligne suivante, indiquez les colonnes où stocker les données. Par exemple, entrez Columns 'Prénom' 'Nom' 'Ville' 'Pays'.Cet exemple ne fonctionne que si les colonnes de la feuille de travail Minitab ont déjà été nommées et que leurs noms correspondent à ceux du fichier exécutable.

      Vous pouvez indiquer une plage d'ID de colonne au lieu de toutes les nommer individuellement (en indiquant par exemple Columns C1-C10). Ceci est particulièrement utile lorsque vous importez un grand nombre de colonnes.

  4. Sélectionnez Fichier > Enregistrer et fermez le Bloc-notes.

Lancer le fichier exécutable

  1. Sélectionnez Outils > Lancer un exécutable.
  2. Cliquez sur Sélectionner un fichier.
  3. Sélectionnez le fichier exécutable que vous avez enregistré et cliquez sur Ouvrir.
Remarque

Pour ajouter un raccourci afin de lancer le fichier exécutable à partir d'un menu ou d'une barre d'outils, reportez-vous à la rubrique Ajouter un raccourci à un menu ou à une barre d'outils pour exécuter une macro Minitab ou lancer un fichier exécutable.

En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique