Conception d'un plan d'expériences

Généralités

Les plans d'expériences (DOE) vous permettent d'analyser simultanément les effets de variables d'entrée (facteurs) sur une variable de sortie (réponse). Ces plans d'expériences consistent en une série d'essais (ou tests) au cours desquels les variables d'entrée sont intentionnellement modifiées. Des données sont collectées à chaque essai. Les plans d'expériences permettent d'identifier les conditions des procédés et les composants des produits qui influent sur la qualité, et de déterminer ainsi les paramètres de facteurs offrant des résultats optimaux.

Minitab propose cinq types de plans : les plans de criblage, les plans factoriels, les plans de surface de réponse, les plans de mélange et les plans de Taguchi (également appelés plans robustes de Taguchi). Les étapes de création, d'analyse et de visualisation d'un plan d'expériences dans Minitab sont les mêmes pour tous les types de plans. Une fois que vous avez effectué l'expérience et saisi les résultats, Minitab dispose de plusieurs outils analytiques et graphiques pour vous aider à mieux comprendre ces résultats. Ce chapitre présente l'ensemble des étapes habituelles que vous devez suivre lors de la création et de l'analyse d'un plan factoriel. Vous pouvez appliquer ces étapes à tous les plans que vous créez dans Minitab.

Les commandes relatives aux plans d'expériences (DOE) de Minitab présentent les fonctionnalités suivantes :
  • Des catalogues de plans d'expériences pour vous aider à créer un plan
  • La création et la mémorisation automatiques de votre plan une fois que vous avez défini ses propriétés
  • L'affichage et le stockage des statistiques de diagnostic afin de vous aider à interpréter les résultats
  • Des graphiques vous aidant à interpréter et à présenter les résultats

Dans ce chapitre, vous allez analyser deux facteurs susceptibles de réduire le temps nécessaire pour préparer une commande avant expédition : le système de traitement des commandes et la procédure d'emballage.

La centrale Ouest dispose d'un nouveau système de traitement des commandes. Vous voulez déterminer si ce nouveau système réduit le temps de préparation d'une commande. La centrale emploie également deux procédures d'emballage différentes. Vous voulez déterminer celle qui est la plus efficace. Vous décidez donc de réaliser un plan d'expériences factoriel afin d'identifier la combinaison de facteurs permettant de préparer une commande le plus rapidement possible.

Création d'un plan d'expériences

Pour entrer et analyser les données d'un plan d'expériences (DOE) dans Minitab, vous devez d'abord créer un plan d'expériences dans la feuille de travail. Minitab propose de nombreux plans.

Filtrage
Inclut les plans de Plackett-Burman et de criblage définitifs.
Factoriel
Inclut les plans complets à deux niveaux, les plans fractionnaires à deux niveaux, les plans en parcelles divisées (split-plot) et les plans de Plackett-Burman.
Surface de réponse
Inclut les plans composites centrés et les plans de Box-Behnken.
Mélange
Inclut les plans de mélange centrés, les plans en réseaux et les plans sous contraintes.
Taguchi
Inclut les plans à 2, 3, 4 et 5 niveaux, ainsi que les plans à divers niveaux.

Déterminez le plan le plus adapté à votre expérience. Sélectionnez-le ensuite dans le menu Stat > DOE (plan d'expériences). Vous pouvez aussi ouvrir la barre d'outils correspondante en sélectionnant Outils > Barres d'outils. Une fois que vous avez choisi un plan et ses caractéristiques, Minitab se charge de le créer et de le mémoriser dans la feuille de travail.

Sélection d'un plan

Vous souhaitez créer un plan factoriel pour étudier la relation entre deux facteurs (le système de traitement des commandes et la procédure d'emballage) et le temps nécessaire à la préparation d'une commande.

  1. Sélectionnez Fichier > Nouveau > Projet.
  2. Sélectionnez Stat > DOE (plan d'expériences) > Plan factoriel > Créer un plan factoriel.
    Lorsque vous créez un plan dans Minitab, seuls deux boutons sont activés, à savoir Afficher les plans disponibles et Plans. Les autres boutons deviennent disponibles dès que la sous-boîte de dialogue Plans a été complétée.
  3. Cliquez sur Afficher les plans disponibles.
    Pour la plupart des plans, Minitab affiche tous les plans possibles et le nombre d'essais nécessaires dans la boîte de dialogue Afficher les plans disponibles.
  4. Cliquez sur OK pour revenir à la boîte de dialogue principale.
  5. Sous Type de plan, sélectionnez Factoriel à 2 niveaux (générateurs par défaut).
  6. Dans Nombre de facteurs, sélectionnez 2.
  7. Cliquez sur Plans.
    La zone située dans la partie supérieure de la boîte de dialogue indique les plans disponibles pour ce type de plan et le nombre de facteurs que vous avez choisis. Dans cet exemple, comme vous utilisez un plan factoriel avec deux facteurs, vous n'avez qu'une option : un plan factoriel complet avec quatre essais expérimentaux. Il existe 22 (ou quatre) combinaisons de facteurs possibles pour un plan à deux niveaux avec deux facteurs.
  8. Dans Nombre de répliques pour les points de sommets, sélectionnez 3.
  9. Cliquez sur OK pour revenir à la boîte de dialogue principale. Tous les boutons sont maintenant disponibles.

Saisie des noms de facteurs et définition des niveaux de facteurs

Minitab utilise les noms des facteurs comme étiquettes pour les facteurs dans les graphiques et les résultats d'analyses. Si aucun niveau de facteur n'est défini, Minitab définit le niveau inférieur sur –1 et le niveau supérieur sur 1.

  1. Cliquez sur Facteurs.
  2. Dans la ligne correspondant au facteur A, sous Nom, saisissez Système de commande. Sous Type, sélectionnez Texte. Sous Min, saisissez Nouveau. Sous Max, saisissez Actuel.
  3. Dans la ligne correspondant au facteur B, sous Nom, saisissez Emballage. Sous Type, sélectionnez Texte. Sous Min, saisissez A. Sous Max, saisissez B.
  4. Cliquez sur OK pour revenir à la boîte de dialogue principale.

Randomisation et stockage du plan

Par défaut, Minitab randomise l'ordre des essais de tous les types de plans, à l'exception des plans de Taguchi. La randomisation permet de garantir que le modèle vérifie certaines hypothèses statistiques. Elle permet également de limiter les effets des facteurs qui ne sont pas inclus dans l'étude.

Le paramétrage de la base du générateur de nombres aléatoires permet d'obtenir le même ordre d'essais à chaque création de plan.

  1. Cliquez sur Options.
  2. Dans la zone Base du générateur de nombres aléatoires, saisissez 9.
  3. Vérifiez que l'option Stocker le plan dans la feuille de travail est sélectionnée.
  4. Cliquez sur OK dans chaque boîte de dialogue.

Affichage du plan

A chaque création de plan, Minitab enregistre les informations qui le concernent et les facteurs dans des colonnes de la feuille de travail.

  1. Agrandissez la feuille de travail pour voir la structure d'un plan type.

La colonne OrdEssai (C2) indique l'ordre dans lequel les données sont collectées. Si vous ne randomisez pas le plan, les colonnes OrdreStd et OrdEssai sont identiques.

Dans cet exemple, comme vous n'avez pas ajouté de points centraux ni rassemblé les essais en blocs, Minitab définit toutes les valeurs des colonnes C3 et C4 sur 1. Les facteurs que vous avez saisis sont stockés dans les colonnes C5 (Système de commande) et C6 (Emballage).

Remarque

La commande Stat > DOE (plan d'expériences) > Afficher le plan permet de basculer entre les affichages aléatoire et standard, et entre les affichages codé et non codé. Pour modifier les paramètres ou les noms des facteurs, utilisez la commande Stat > DOE (plan d'expériences) > Modifier le plan. Si vous devez uniquement modifier les noms des facteurs, vous pouvez les entrer directement dans la feuille de travail.

Saisie des données dans la feuille de travail

Une fois que vous avez réalisé l'expérience et recueilli les données, vous pouvez saisir ces dernières dans la feuille de travail.

La caractéristique mesurée est appelée réponse. Dans cet exemple, vous mesurez le nombre d'heures nécessaires à la préparation d'une commande. A la suite de l'expérience, vous obtenez les données suivantes :

14,72 9,62 13,81 7,97 12,52 13,78 14,64 9,41 13,89 13,89 12,57 14,06

  1. Dans la feuille de travail, cliquez sur la cellule de nom de la colonne C7 et saisissez Heures.
  2. Dans la colonne Heures, saisissez les données comme indiqué ci-dessous.
    Vous pouvez saisir des données dans toutes les colonnes, sauf celles qui contiennent des informations sur le plan. Vous pouvez aussi entrer plusieurs réponses pour une seule expérience à raison d'une réponse par colonne.
Remarque

Pour imprimer un formulaire de collecte des données, cliquez sur la feuille de travail et sélectionnez Fichier > Imprimer la feuille de travail. Vérifiez que l'option Imprimer la grille est sélectionnée. Ce formulaire vous permet de consigner les mesures lors de l'expérience.

Analyse du plan

Après avoir créé le plan et saisi les données de réponse, vous pouvez ajuster un modèle aux données et générer des graphiques pour évaluer les effets. Utilisez les résultats du modèle ajusté et des graphiques pour identifier les facteurs clés pouvant réduire le nombre d'heures nécessaires à la préparation d'une commande.

Ajustement d'un modèle

Comme la feuille de travail contient un plan factoriel, Minitab active les commandes de menu DOE (plan d'expériences) > Plan factoriel, Analyser un plan factoriel et Diagrammes factoriels. Dans cet exemple, vous commencez par ajuster le modèle.

  1. Sélectionnez Stat > DOE (plan d'expériences) > Plan factoriel > Analyser un plan factoriel.
  2. Dans la zone Réponses, saisissez Heures.
  3. Cliquez sur Termes. Vérifiez que A:Système de commande, B:Emballage et AB apparaissent dans la zone Termes sélectionnés.
    Lorsque vous analysez un plan, utilisez toujours la sous-boîte de dialogue Termes pour sélectionner les termes à inclure dans le modèle. Vous pouvez ajouter ou supprimer des facteurs et des interactions à l'aide des flèches. Utilisez les cases à cocher pour inclure des blocs et des points centraux dans le modèle.
  4. Cliquez sur OK.
  5. Cliquez sur Graphiques.
  6. Sous Diagrammes des effets, sélectionnez Pareto et Normale.
    Les diagrammes des effets ne sont disponibles que pour les plans factoriels. Les graphiques des valeurs résiduelles, qui permettent de vérifier les hypothèses du modèle, peuvent être affichés pour tous les types de plans.
  7. Cliquez sur OK dans chaque boîte de dialogue.
    Minitab ajuste le modèle indiqué dans la sous-boîte de dialogue Termes, affiche les résultats dans la fenêtre Session et stocke le modèle dans le fichier de feuille de travail. Une fois que vous avez identifié un modèle acceptable, vous pouvez utiliser le modèle stocké pour vos analyses ultérieures.

Identification des effets importants

Vous pouvez utiliser les résultats de la fenêtre Session et les deux diagrammes des effets pour déterminer les effets qui sont importants pour votre procédé. Examinez d'abord les résultats de la fenêtre Session.

Régression factorielle : Heures en fonction de Système de commande; Emballage

Analyse de variance SomCar Valeur Source DL ajust CM ajust Valeur F de p Modèle 3 53,894 17,9646 40,25 0,000 Linéaires 2 44,915 22,4576 50,32 0,000 Système de commande 1 28,768 28,7680 64,46 0,000 Emballage 1 16,147 16,1472 36,18 0,000 Interactions à 2 facteur(s) 1 8,979 8,9787 20,12 0,002 Système de commande*Emballage 1 8,979 8,9787 20,12 0,002 Erreur 8 3,571 0,4463 Total 11 57,464
Récapitulatif du modèle R carré R carré S R carré (ajust) (prév) 0,668069 93,79% 91,46% 86,02%
Coefficients codés Valeur Valeur Terme Effet Coeff Coef ErT de T de p FIV Constante 12,573 0,193 65,20 0,000 Système de commande 3,097 1,548 0,193 8,03 0,000 1,00 Emballage -2,320 -1,160 0,193 -6,01 0,000 1,00 Système de commande*Emballage 1,730 0,865 0,193 4,49 0,002 1,00
Equation de régression en unités non codées Heures = 12,573 + 1,548 Système de commande - 1,160 Emballage + 0,865 Système de commande*Emballage
Structure des alias Facteur Nom A Système de commande B Emballage
Alias I A B AB
Vous procédez à l'ajustement de l'ensemble du modèle, qui comprend les deux effets principaux et l'interaction à deux facteurs. Les effets sont considérés comme significatifs d'un point de vue statistique lorsque leur valeur de p dans le tableau Coefficients codés est inférieures à α. Au niveau d'α par défaut, c'est-à-dire 0,05, les effets suivants sont significatifs :
  • Les effets principaux pour le système de traitement des commandes (Système de commande) et la procédure d'emballage (Emballage)
  • L'effet de l'interaction entre le système de traitement des commandes et la procédure d'emballage (Système de commande*Emballage)

Interprétation des diagrammes des effets

Vous pouvez également évaluer la droite de Henry et le diagramme de Pareto des effets normalisés pour connaître les effets qui influent sur la réponse, Heures.

  1. Pour afficher la droite de Henry, sélectionnez Fenêtre > Diagramme des effets pour Heures.

    Les carrés indiquent les termes significatifs. Les termes Système de commande (A), Emballage (B) et Système de commande*Emballage (AB) sont significatifs parce que leur valeur de p est inférieure au niveau d'α (0,05).

  2. Pour afficher le diagramme de Pareto, sélectionnez Fenêtre > Diagramme de Pareto des effets pour Heures.

    Dans ce diagramme, Minitab affiche la valeur absolue des effets du diagramme de Pareto. Tous les effets allant au-delà de la ligne de référence sont significatifs. Les termes Système de commande (A), Emballage (B) et Système de commande*Emballage (AB) sont tous significatifs.

Utilisation du modèle stocké pour des analyses supplémentaires

Vous avez défini un modèle incluant les effets significatifs et Minitab l'a stocké dans la feuille de travail. Si l'en-tête de la colonne de réponse est marqué d'une coche, cela signifie que le modèle est stocké et à jour. Maintenez le pointeur sur la coche pour visualiser un récapitulatif du modèle.

Vous pouvez utiliser le modèle stocké pour effectuer des analyses supplémentaires, afin de mieux comprendre les résultats. Vous pouvez ensuite générer des diagrammes factoriels pour déterminer les paramètres optimaux, puis utiliser l'analyse Prévoir de Minitab pour prévoir le nombre d'heures obtenu avec ces paramètres.

Créer des diagrammes factoriels

Utilisez le modèle stocké pour créer un graphique des effets principaux et un diagramme des interactions, afin de visualiser les effets.

  1. Sélectionnez Stat > DOE (plan d'expériences) > Plan factoriel > Diagrammes factoriels.
  2. Vérifiez que les variables, Système de commande et Emballage apparaissent dans la zone Sélectionnées.
  3. Cliquez sur OK.

Interprétation des diagrammes factoriels

Les diagrammes factoriels rassemblent les graphiques des effets principaux et les diagrammes des interactions. Un effet principal désigne la variation de la réponse moyenne entre deux niveaux de facteurs. Le graphique des effets principaux montre les moyennes pour la réponse Heures avec les deux systèmes de traitement des commandes, ainsi que les moyennes pour la réponse Heures avec les deux procédures d'emballage. Le diagramme des interactions montre les effets des deux facteurs, à savoir le système de traitement des commandes et la procédure d'emballage, sur la réponse. Il y a interaction lorsque l'effet d'un facteur dépend du niveau de l'autre facteur ; aussi est-il important d'évaluer les interactions.

  1. Pour afficher le graphique des effets principaux, sélectionnez Fenêtre > Graphique des effets principaux pour Heures.

    Chaque point représente la durée de traitement moyenne pour un niveau d'un facteur. La ligne centrale horizontale indique la durée de traitement moyenne pour tous les essais. Le volet gauche du graphique indique que les commandes qui ont été gérées avec le nouveau système ont été plus rapidement préparées que celles traitées avec le système actuel. Le volet droit du graphique indique que les commandes qui ont été gérées avec la procédure d'emballage B ont été plus rapidement préparées que celles traitées avec la procédure d'emballage A.

    S'il n'existait pas d'interaction significative entre les facteurs, un graphique des effets principaux décrirait correctement les relations entre chaque facteur et la réponse. Cependant, l'interaction étant significative, vous devez également étudier le diagramme des interactions. Une interaction significative entre deux facteurs peut modifier l'interprétation des effets principaux.

  2. Sélectionnez Fenêtre > Diagramme des interactions pour Heures pour activer le diagramme des interactions.

    Chaque point du diagramme des interactions représente la durée moyenne de traitement pour une combinaison différente de niveaux de facteurs. Si les lignes ne sont pas parallèles, cela signifie qu'il y a interaction entre les deux facteurs. Le diagramme des interactions indique que les commandes de livres gérées avec le nouveau système de traitement des commandes et la procédure d'emballage B présentent le temps de préparation le plus rapide (9 heures environ). Les commandes gérées avec le système de traitement actuel et la procédure d'emballage A présentent le temps de préparation le plus long (14,5 heures environ). La droite correspondant à la procédure B étant plus inclinée, vous pouvez en conclure que le nouveau système de traitement des commandes a un effet plus grand lorsque la procédure d'emballage B est utilisée au lieu de la procédure A.

    Au vu des résultats de l'expérience, vous recommandez l'utilisation par la centrale d'expédition Ouest du nouveau système de traitement des commandes et de la procédure d'emballage B afin de réduire le délai de livraison des commandes.

Prévision de la réponse

Vous avez identifié les paramètres optimaux, qui sont stockés dans le modèle de plan d'expériences (DOE) de la feuille de travail. Vous pouvez utiliser le modèle stocké pour prévoir les temps de traitement correspondant à ces paramètres.

  1. Sélectionnez Stat > DOE (plan d'expériences) > Plan factoriel > Prévoir.
  2. Sous Système de commande, sélectionnez Nouveau.
  3. Sous Emballage, sélectionnez B.
  4. Cliquez sur OK.

Prévision pour Heures

Equation de régression en unités non codées Heures = 12,573 + 1,548 Système de commande - 1,160 Emballage + 0,865 Système de commande*Emballage
Variable Configuration Système de commande Nouveau Emballage B
Valeur ajustée ErT ajust IC à 95 % IP à 95 % 9 0,385710 (8,11055; 9,88945) (7,22110; 10,7789)

Interprétation des résultats

La fenêtre Session indique l'équation du modèle et les paramètres des variables. La valeur ajustée (également appelée valeur prévue) pour ces paramètres est de 9 heures. Cela étant, toutes les estimations présentent un certain niveau d'incertitude, car elles utilisent des données échantillons. L'intervalle de confiance à 95 % désigne l'étendue des valeurs probables pour le temps de préparation moyen. Si vous utilisez le nouveau système de traitement des commandes et la procédure d'emballage B, vous pouvez être sûr à 95 % que le temps de préparation moyen pour toutes les commandes sera compris entre 8,11 et 9,89 heures.

Enregistrement du projet

  1. Sélectionnez Fichier > Enregistrer le projet sous.
  2. Accédez au dossier dans lequel vous souhaitez enregistrer vos fichiers.
  3. Dans la zone Nom de fichier, saisissez MonPlanExp.
  4. Cliquez sur Enregistrer.

Dans le chapitre suivant

Le plan d'expériences factoriel révèle que vous pouvez réduire la durée nécessaire à la préparation des commandes à la centrale d'expédition Ouest en utilisant le nouveau système de traitement des commandes et la procédure d'emballage B. Dans le chapitre suivant, vous allez apprendre à utiliser le langage de commande, ainsi qu'à créer et à utiliser des fichiers exécutables afin de ré-effectuer rapidement une analyse lorsque vous disposez de nouvelles données.

En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique