¿Cuál es el esquema de codificación de número para colores/símbolos/tipos de línea?

La Ayuda de Minitab contiene temas que documentan los diversos códigos. Se pueden encontrar estos códigos con una búsqueda simple.

  1. Elija Ayuda > Ayuda, a continuación, haga clic en Comandos de sesión debajo de Referencias.
  2. En la ventana Minitab Sesión Comandos Ayuda, seleccione la ficha Búsqueda.
  3. Escriba "colores estándar", "tipo de símbolo" o "tipos de línea", dependiendo de los códigos que desee encontrar.
  4. Marque Buscar únicamente títulos.
  5. Haga clic en Lista de temas para ver los Colores estándar, Tipo de símbolos o tema de tipo de línea que contiene una tabla del esquema de codificación de número.

Al utilizar los comandos, ¿cómo puedo guardar una gráfica de Minitab como un archivo JPEG, PNG, TIF o Windows BMP?

Cree la gráfica utilizando el comando de sesión, el subcomando GSAVE y el subcomando de formato gráfico aplicable. Por ejemplo, supongamos que desea crear un histograma de columna C1 y guarde la gráfica como un archivo JPEG en la raíz de la unidad C: con el nombre de archivo Defectos. Utilice los siguientes comandos:

HIST C1;
GSAVE "C:\Defects";
JPEG.
Nota

Para archivos TIFF (Formato de fichero de  imagen con etiquetas) utilice el subcomando TIFC. Para archivos PNG (Gráficos de redes portátiles), utilice PNGC. Para archivos BMP (Windows Bitmap), utilice BMPC.

Nota

En una macro, puede ver el GSAVE usado en otros comandos, tales como CALL. Los subcomandos de formato gráfico mencionados aquí, tales como JPEG, no deben ser insertados en estos casos.

¿Cómo puedo imprimir una gráfica desde la macro que escribí?

Utilice el comando GPRINT.

Ejemplo 1

Este ejemplo crea un histograma y una gráfica de caja.

HIST C1;
BOXPLOT C1;
GPRINT.

Ejemplo 2

Este ejemplo crea un histograma y una gráfica de caja, guarda las gráficas como HIST.MGF y BOX.MGF respectivamente e imprime la gráfica de caja.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

Ejemplo 3

Este ejemplo crea un histograma y una gráfica de caja, guarda las gráficas como HIST.MGF y BOX.MGF respectivamente, e imprime el histograma.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIST.MGF"
Nota

Sin argumentos, como en el Ejemplo 1 y 2, GPRINT imprime la ventana de gráfica activa. Con un argumento, GPRINT abrirá la gráfica especificada y la enviará a la impresora predeterminada de la computadora.

¿Cómo puedo utilizar la fecha de hoy (o la fecha y la hora de hoy) como una nota a pie de página en la gráfica que estoy creando con una macro local?

Por ejemplo, supongamos que desea colocar la fecha actual como una nota de pie de página en un histograma de una columna llamado YIELD.

Nota

En los pasos que están a continuación se supone que las columnas de nombre YIELD y TMPDATE y una constante llamada DATE, están listadas en la sección de declaración de la macro local y que la columna YIELD contiene datos.

  1. Utilice la función TODAY() para almacenar la fecha actual en una columna:
    LET TMPDATE = TODAY()
    Nota

    Si desea que la fecha y la hora actual estén en la gráfica, utilice NOW() en lugar de TODAY().

  2. Cambie el tipo de datos de manera que la columna sea formateada como una columna de texto:
    TEXT TMPDATE TMPDATE
  3. Almacene la fecha como una constante:
    LET DATE = TMPDATE
  4. Utilice la constante en el subcomando FOOTNOTE:
    HIST YIELD;
    FOOTNOTE DATE.

¿Cómo puedo escribir mi macro de manera que controle las pausas después de que las gráficas hayan sido creadas?

Para controlar las pausas, incluya una de las siguientes formas del comando GPAUSE en su macro:

GPAUSE

Este comando le dice a Minitab hacer pausas por K segundos (K puede ser cualquier entero entre 0 y 1800) después de mostrar cada gráfica hasta que usted presione cualquier tecla o el botón del mouse.

GPAUSE K

¿Hay un comando de Sesión para cerrar la última de todas las gráficas?

GMANAGER, un comando de Sesión no documentado, puede utilizarse para cerrar las gráficas.

Nota

Este comando es experimental y no se ha sometido a prueba tan rigurosamente como los comandos documentados en la ayuda. Aunque el comando se puede usar, debería aplicarlo con precaución (No nos hacemos responsables por resultados inesperados). La forma y la sintaxis de este comando están sujetas a cambio.

Para cerrar la última gráfica, utilice el siguiente comando:

GMANAGER;
CLOSE.

Para cerrar todas las gráficas, utilice el siguiente comando:

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

Si no desea que se le solicite guardar la gráfica antes de cerrar haga lo siguiente:

  1. Elija Herramientas > Opciones > Gráficas > Administración de gráficas.
  2. Elija Nunca al lado de Solicitar guardar una gráfica antes de cerrar . Haga clic en Aceptar.

Tenga en cuenta que los cambios que realice en Herramientas > Opciones se aplicarán cuando cierre todas las gráficas futuras.

Cómo utilizar subcomandos tales como GSAVE y WTITLE para gráficas que no incluyen estos subcomandos

Puede utilizar subcomandos tales como GSAVE y WTITLE para gráficas que no incluyen estos subcomandos si también utiliza el comando LAYOUT.

Uso de GSAVE y WTITLE para GSUMMARY

Estadísticas > Estadísticas básicas > Resumen gráfico

Supongamos que desea guardar el resumen gráfico de C1 como un archivo JPEG con el nombre YIELD.JPG en C:\My Statistics, y desea que "San Francisco" aparezca en la barra de título de la gráfica. Utilice los siguientes comandos:
LAYOUT;
GSAVE "C:\My Statistics\YIELD.JPG";
JPEG;
WTITLE "San Francisco".
GSUMMARY C1
ENDLAYOUT.

Uso de GSAVE y WTITLE para GageRR

Estadísticas > Herramientas de calidad > Estudio de medición > Estudio R&R del sistema de medición (cruzado).

Supongamos que desea ejecutar el siguiente comando Estudio R&R del sistema de medición (cruzado):
GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.
Supongamos que desea guardar la gráfica como un archivo JPEG con el nombre GageRR.JPEG en Q:\Project, y desea que "Gage 1" aparezca en la barra de título de la gráfica. Utilice los siguientes comandos:
LAYOUT;
GSAVE "Q:\Project\GageRR.JPG";
JPEG;
WTITLE "Medidor 1".

GageRR;
Parts 'Part';
Opers 'Operator';
Response 'Measurement';
Studyvar 6.

ENDLAYOUT.
Al utilizar este sitio, usted acepta el uso de cookies para efectos de análisis y contenido personalizado.  Leer nuestra política