Crear un archivo Exec ODBC reutilizable

Si usted utiliza frecuentemente Archivo > Consultar base de datos (ODBC) para actualizar su hoja de trabajo, puede automatizar el proyecto con un archivo Exec.

Crear el archivo Exec

  1. Importe los datos utilizando Archivo > Consultar base de datos (ODBC). Para obtener más información, vaya a Importar datos de una base de datos usando ODBC.
  2. Haga clic en el botón Mostrar historial en la barra de herramientas de Project Manager para abrir la ventana Historial.
  3. Seleccione los comandos y subcomandos de sesión ODBC, luego haga clic con el botón derecho y elija Guardar como.
  4. En Guardar como tipo, seleccione Exec (*.mtb).
  5. Ingrese un nombre de archivo (por ejemplo, ObtenerDatos.MTB).
  6. Seleccione una ubicación para el archivo y luego haga clic en Guardar.
  7. Para ejecutar el archivo Exec, haga lo siguiente:
    1. Elija Herramientas > Ejecutar un Exec.
    2. Especifique el número de veces que desea ejecutar el Exec.
    3. Haga clic en Seleccionar archivo.
    4. Seleccione el archivo Exec, luego haga clic en Abrir.

Especificar las columnas de salida en el archivo Exec

Si desea actualizar los datos en la misma hoja de trabajo de Minitab cada vez que ejecute el archivo Exec, debe editar el archivo Exec para especificar las columnas que se usarán en la hoja de trabajo de Minitab.

Sugerencia

En un ODBC SQL o cadena de conexión, el número máximo de caracteres que puede haber entre comillas dobles en una línea es 80. Para usar cadenas de texto que tienen más de 80 caracteres, divida la cadena en secciones más pequeñas en múltiples líneas usando la tecla et (&). Por ejemplo, en el siguiente contenido de la ventana Sesión, el símbolo et continúa una cadena de texto larga dentro de comillas dobles en la siguiente línea.

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOCUMENTS AND SETTINGS\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. En Minitab, elija Herramientas > Bloc de notas.
  2. En el Bloc de notas, elija Archivo > Abrir. Cambie el tipo de archivo a Todos (*.*), luego abra el archivo MTB que usted creó.
  3. Para cada comando de sesión ODBC y los subcomandos correspondientes, haga lo siguiente:
    1. Reemplace el punto (.) al final del último subcomando por un punto y coma (;), luego presione la tecla Intro.
    2. En la siguiente línea, especifique las columnas donde desea almacenar los datos. Por ejemplo, ingrese Columnas 'Nombre' 'Apellido' 'Ciudad' 'País'.Estos ejemplos funcionan solo si las columnas en la hoja de trabajo de Minitab ya tienen nombres que coincidan con el archivo Exec.

      Puede especificar un rango de IDs de columna en lugar de escribir cada una individualmente (por ejemplo: Columnas C1-C10). Especificar un rango es especialmente útil cuando usted importa un gran número de columnas.

  4. Elija Archivo > Guardar, luego cierre el Bloc de notas.

Ejecutar el archivo Exec

  1. Elija Herramientas > Ejecutar un Exec.
  2. Haga clic en Seleccionar archivo.
  3. Seleccione el archivo Exec que guardó, luego haga clic en Abrir.
Nota

Para agregar un acceso rápido para ejecutar el Exec desde un menú o barra de herramientas, vaya a Agregar un acceso rápido a un menú o barra de herramientas para ejecutar una macro o archivo Exec de Minitab.

Al utilizar este sitio, usted acepta el uso de cookies para efectos de análisis y contenido personalizado.  Leer nuestra política