Revisión general

Cuando usted utiliza un comando del menú en Minitab, Minitab preserva los comandos de sesión que registran sus acciones. Puede usar estos comandos de sesión para repetir rápidamente un análisis a un nuevo conjunto de datos.

Cada comando del menú tiene un comando de sesión correspondiente. Los comandos de sesión constan de un comando principal y, por lo general, uno o más subcomandos. Los comandos principales y los subcomandos pueden ir seguidos de una serie de argumentos, que pueden ser columnas, constantes, matrices, cadenas de texto o números. Minitab ofrece tres maneras de usar los comandos de sesión:
  • Escribir los comandos de sesión en la ventana Sesión o el Editor de línea de comandos.
  • Copiar los comandos de sesión de la carpeta Historial al Editor de línea de comandos.
  • Copiar y guardar los comandos de sesión en un archivo exec.

Cuando usted muestra las líneas de comandos y luego ejecuta un comando de un menú, los comandos de sesión correspondientes se muestran en la sección Línea de comandos de la ventana Sesión. Esta técnica es un modo conveniente de aprender los comandos de sesión.

El centro de envío del Oeste recolecta y analiza continuamente los tiempos de entrega cuando hay nuevos datos disponibles. En Evaluación de la calidad, usted realizó un análisis de capacidad basado en los datos de marzo. En este capítulo, utilizará comandos de sesión para realizar un análisis de capacidad basado en los datos de abril.

Habilitar e ingresar comandos de sesión

Una manera de utilizar los comandos de sesión es ingresándolos en el prompt de comandos en la sección Línea de comandos de la ventana Sesión. Minitab no muestra la sección por opción predeterminada, por lo que usted debe habilitarla.

Habilitar comandos de sesión

  1. Si viene del capítulo anterior, elija Archivo > Nuevo > Proyecto. De lo contrario, inicie Minitab.
  2. Abra los datos de muestra, ComSesión.MTW.
  3. Haga clic en la ventana Sesión para activarla.
  4. Elija Editor > Mostrar línea de comandos.

    El prompt MTB> se muestra en la sección Línea de comandos de la ventana Sesión.

  5. (Opcional) Habilite los comandos de sesión de manera predeterminada para todas las sesiones de Minitab.
    1. Elija Herramientas > Opciones. Expanda Ventana Sesión y luego seleccione Enviar comandos.
    2. En Línea de comandos, haga clic en Mostrar.

Realizar un análisis usando comandos de sesión

En Evaluación de la calidad, usted realizó un análisis de capacidad para determinar si los tiempos de entrega estaban dentro de las especificaciones (menos de 6 días para la entrega). Para llevar a cabo el análisis, utilizó Estadísticas > Herramientas de calidad > Análisis de capacidad > Normal. Posteriormente ingresó la columna de datos, la columna de subgrupos y el límite de especificación superior.

Para continuar evaluando los tiempos de entrega del centro de envío del Oeste, usted planea repetir este análisis a intervalos regulares. Cuando recolecte nuevos datos, podrá repetir este análisis utilizando unos pocos comandos de sesión.

  1. En la sección Línea de comandos, en el prompt MTB >, ingrese CAPABILITY 'Days' 'Date'; El punto y coma indica que usted desea ingresar un subcomando.
  2. Presione Intro. Observe que MTB > se convierte en SUBC>. Utilice el prompt SUBC> para agregar subcomandos para las opciones del análisis de capacidad anterior.
  3. En el prompt SUBC>, ingrese USPEC 6. El punto indica el fin de una secuencia de comandos.
  4. Presione Intro.
Análisis de capacidad para los datos de envío del mes de abril
Sugerencia

Para abrir un archivo PDF que contenga una lista de los comandos de sesión en Minitab, en el prompt de comandos, ingrese Ayuda.

Volver a ejecutar una serie de comandos

Minitab genera comandos de sesión para la mayoría de los comandos de menú y los almacena en la carpeta Historial. Para volver a ejecutar estos comandos, selecciónelos y elija Editar > Editor de línea de comandos.

Utilice la carpeta Historial y el Editor de línea de comandos para volver a ejecutar el análisis de capacidad.

  1. Elija Ventana > Project Manager.
  2. Haga clic en la carpeta Historial.
  3. Haga clic en CAPABILITY 'Días' 'Fecha';, mantenga presionada la tecla Mayús y luego haga clic en USPEC 6.
  4. Elija Editar > Editor de línea de comandos.
  5. Haga clic en Enviar comandos.
Análisis de capacidad para los datos de envío del mes de abril

Solo necesitó unos pocos pasos sencillos para volver a crear el análisis de capacidad.

Repetir análisis con archivos exec

Un archivo exec es un archivo de texto que contiene una serie de comandos de Minitab. Para repetir un análisis sin usar comandos de menú ni comandos de sesión, guarde los comandos como un archivo exec y luego ejecute ese archivo.

Sugerencia

Para obtener más información sobre los archivos exec y otras macros más complejas, abra Ayuda de macros de Minitab.

Crear un archivo exec desde la carpeta Historial

Guarde los comandos de sesión del análisis de capacidad como un archivo exec.

  1. Elija Ventana > Project Manager.
  2. Haga clic en la carpeta Historial.
  3. Haga clic en CAPABILITY 'Días' 'Fecha';, presione Mayús y luego haga clic en USPEC 6.
  4. Haga clic con el botón derecho en el texto seleccionado, luego elija Guardar como.
  5. Navegue hasta la carpeta en la que desea guardar sus archivos.
  6. En Nombre de archivo, ingrese GráficasEnvío.
  7. En Guardar como tipo, seleccione Exec (*.mtb). Haga clic en Guardar.

Volver a ejecutar comandos

Usted puede repetir este análisis al ejecutar el archivo exec.

  1. Elija Herramientas > Ejecutar un Exec.
  2. Haga clic en Seleccionar archivo.
  3. Seleccione el archivo, GráficasEnvío.MTB y luego haga clic en Abrir.
Análisis de capacidad para los datos de envío del mes de abril

Minitab ejecuta los comandos del archivo exec para generar el análisis de capacidad.

Usted puede ejecutar un archivo exec usando cualquier hoja de trabajo si los nombres de las columnas coinciden. Por lo tanto, puede compartir un archivo exec con otros usuarios de Minitab que necesiten realizar el mismo análisis. Por ejemplo, el gerente del centro de envío del Oeste puede compartir GráficasEnvío.MTB con los gerentes de los otros centros de envío para que puedan hacer el mismo análisis con sus propios datos. Si desea utilizar un archivo exec con otra hoja de trabajo o con columnas diferentes, edite el archivo exec utilizando un editor de texto como el Bloc de notas.

Guardar el proyecto

Guarde todo su trabajo en un proyecto de Minitab.

  1. Elija Archivo > Guardar proyecto como.
  2. Navegue hasta la carpeta en la que desea guardar sus archivos.
  3. En Nombre de archivo, ingrese MisComandosSesión.
  4. Haga clic en Guardar.

En el próximo capítulo

Usted aprendió a utilizar comandos de sesión como alternativa a los comandos del menú y como una forma de repetir rápidamente un análisis. En el próximo capítulo, creará un informe para mostrar a sus compañeros los resultados de su análisis.

Al utilizar este sitio, usted acepta el uso de cookies para efectos de análisis y contenido personalizado.  Leer nuestra política