Preparación de una hoja de trabajo

Revisión general

Con frecuencia, usted utiliza hojas de trabajo que ya han sido creadas. Sin embargo, en otras ocasiones debe introducir o importar los datos en una hoja de Minitab antes de iniciar un análisis.

Puede ingresar datos en una hoja de trabajo de Minitab de las siguientes maneras:
  • Escriba los datos directamente en la hoja de trabajo.
  • Copie y pegue los datos desde otras aplicaciones.
  • Importar los datos de archivos de texto o de Microsoft Excel.

Una vez que los datos se encuentren en Minitab, quizá sea necesario editar las celdas o reorganizar columnas y filas para preparar los datos para el análisis. Entre las manipulaciones más comunes se incluyen el apilamiento, la creación de subconjuntos, la especificación de nombres de columna y la edición de los valores de los datos.

En este capítulo, usted importará datos a Minitab desde diferentes fuentes. También verá como se preparó Datosenvío.MTW para el análisis.

Obtener datos de distintas fuentes

Para los análisis iniciales en Introducción a Minitab 18, la hoja de trabajo Datosenvío.MTW, que contiene datos de tres centros de envío, ya está configurada. Sin embargo, los tres centros de envío almacenaron originalmente los datos de envío de las siguientes maneras:
  • El centro de envío del Este almacenó los datos en una hoja de trabajo de Minitab.
  • El centro de envío Central almacenó los datos en un archivo de Microsoft Excel.
  • El centro de envío del Oeste almacenó los datos en un archivo de texto.

Para analizar todos los datos de envío, abra cada archivo en Minitab y después apile los archivos en una hoja de cálculo.

Abrir una hoja de trabajo

Comience con los datos del centro de envío del Este.

  1. Abra los datos de muestra, Este.MTW.

Abrir datos de una hoja de cálculo de Excel

Los datos del centro de envío Central están en una hoja de cálculo de Excel. Minitab permite abrir archivos de Excel.

  1. Guarde los datos de muestra, Central.xlsx.
  2. Elija Archivo > Abrir.
  3. Navegue hasta la carpeta donde usted guardó el conjunto de datos.
  4. Haga doble clic en Central.xlsx.
  5. Haga clic en Aceptar.

Abrir datos de un archivo de texto (*.txt)

Los datos del centro de envío del Oeste estaban en un archivo de texto. Abra el archivo de texto.

  1. Guarde el conjunto de datos de muestra, Oeste.txt.
  2. Elija Archivo > Abrir.
  3. Navegue hasta la carpeta donde usted guardó el conjunto de datos.
  4. Haga doble clic en Oeste.txt.
  5. Haga clic en Aceptar.

Combinar los datos en una hoja de trabajo

Observe que las hojas de trabajo de los centros de envío tienen los mismos nombres de columna. Para facilitar el análisis de los datos, debe combinar los datos en una hoja de trabajo apilando las columnas que tienen el mismo nombre. Puede mover los datos mediante los comandos copiar y pegar o utilizando los comandos del menú Datos.

  1. Elija Datos > Apilar hojas de trabajo.
  2. En Opción de apilar, seleccione Apilar hojas de trabajo en nueva hoja de trabajo.
  3. Utilice los botones de flecha para mover las tres hojas de trabajo de Hojas de trabajo disponibles a Hojas de trabajo que apilar.
  4. En Nombre de nueva hoja de trabajo, ingrese MisDatosEnvío.
  5. Haga clic en Aceptar.

Mover una columna y cambiarle el nombre

La columna Origen contiene las etiquetas que identifican los datos de los centros de envío. Mueva la columna Origen a C1 y cámbiele el nombre a Centro.

  1. Haga clic en en la columna Origen y luego elija Editor > Mover columnas.
  2. En Mover columnas seleccionadas, seleccione Antes de la columna C1.
  3. Haga clic en Aceptar.
  4. Haga clic en la celda de nombre de la columna Origen, escriba Centro y presione Intro.

Preparar la hoja de trabajo para el análisis

Ahora los datos están en una sola hoja de trabajo, pero aún debe manipular los datos de las siguientes maneras:
  • Recodificar datos
  • Agregar una columna nueva
  • Crear una columna de valores calculados
Sugerencia

Para obtener una lista completa de las manipulaciones de datos disponibles en Minitab, vaya a Revisión general sobre Ayuda y procedimiento y haga clic en "Manipular datos en hojas de trabajo, columnas y filas" en el menú de navegación a la izquierda. Luego haga clic en "Procedimiento".

Recodificar los datos

Las etiquetas de la columna Centro no indican adecuadamente de qué centro provienen los datos. Recodifique las etiquetas para eliminar la extensión de archivo.

  1. Elija Datos > Recodificar > A texto.
  2. En Recodificar valores en las siguientes columnas, ingrese Centro.
  3. En Método, seleccione Recodificar valores individuales.
  4. En Valor recodificado, reemplace Este.MTW por Este.
  5. En Valor recodificado, reemplace Oeste.txt por Oeste.
  6. En Ubicación de almacenamiento para las columnas recodificadas seleccione En las columnas originales.
  7. Haga clic en Aceptar.

Ahora las etiquetas de la columna Centro son Oeste, Este y Central.

Calcular valores de diferencia

Antes de guardar su nueva hoja de trabajo y realizar análisis, debe calcular el número de días que transcurrieron entre las fechas de los pedidos y las fechas de entrega. Puede utilizar la Calculadora de Minitab para asignar una fórmula a una columna para calcular estos valores. Si usted modifica o agrega datos, los valores calculados se actualizan automáticamente.

Insertar una columna

Inserte una columna entre Llegada y Estado.

  1. Haga clic en cualquier celda de C4 para activar esa columna.
  2. Haga clic con el botón derecho y luego elija Insertar columnas.
  3. Haga clic en la celda de nombre de C4. Escriba Días y luego presione Intro.

Asignar una fórmula a una columna

Utilice la Calculadora de Minitab para realizar operaciones aritméticas o matemáticas básicas. Minitab almacena los resultados en una columna o una constante. Usted puede asignar una fórmula a una columna de manera que los valores calculados se actualicen automáticamente si se producen cambios en los datos.

Calcule el tiempo de entrega y almacene los valores en la columna Días.

  1. Elija Calc > Calculadora.
  2. En Almacenar resultado en variable, ingrese Días.
  3. En Expresión, ingrese Llegada - Pedido.
  4. Seleccione Asignar como una fórmula.
  5. Haga clic en Aceptar.
Nota

También puede agregar una fórmula a una columna seleccionando la columna y eligiendo Editor > Fórmulas > Asignar fórmula a columna.

Sugerencia

Para obtener más información acerca de las fórmulas en las columnas, vaya a Funciones de la Calculadora. Para obtener más información sobre la Calculadora de Minitab y las operaciones y funciones disponibles, vaya a Revisión general de Calculadora.

Examinar la hoja de trabajo

La columna Días contiene los valores calculados que representan el tiempo de entrega. Estos valores se expresan en número de días. Cuando usted asigna una fórmula a una columna, un indicador de estado aparece en la esquina superior derecha del encabezado de la columna en la hoja de trabajo. Este indicador especifica si la fórmula está definida adecuadamente y si los datos se deben actualizar volviendo a calcular los valores. Una marca de verificación verde indica que los datos están actualizados.

Sugerencia

Mantenga el cursor sobre el indicador de estado para ver la fórmula asignada a la columna. Haga doble clic en el indicador de estado para modificar la fórmula.

Actualizar la hoja de trabajo

Supongamos que usted se entera de que la fecha de llegada de un envío del centro de envío Central es incorrecta. Si corrige la fecha en la hoja de trabajo, Minitab actualiza automáticamente la columna Días.

Actualice la fecha de llegada en la fila 127.

  1. En la columna Llegada, haga doble clic en la fila 127 para colocarla en el modo de edición. Cambie 7/3/2013 9:17 a 8/3/2013 9:17.
  2. Presione Intro.
Minitab actualiza automáticamente el valor de la columna Días de 2.98125 a 3.98125.
Hoja de trabajo original
Hoja de trabajo actualizada
Nota

Si prefiere actualizar las fórmulas manualmente, elija Editor > Fórmulas > Calcular automáticamente todas las fórmulas para desmarcar esta opción. Si los valores de la hoja de trabajo cambian y la fórmula de una columna queda desactualizada, el indicador de estado de esa columna cambia a un triángulo amarillo. Elija Editor > Fórmulas > Calcular todas las fórmulas ya para actualizar todas las fórmulas del proyecto.

Guardar la hoja de trabajo

Guarde todo su trabajo en una hoja de trabajo de Minitab.

  1. Haga clic en la hoja de trabajo y luego elija Archivo > Guardar hoja de trabajo como.
  2. Navegue hasta la carpeta en la que desea guardar sus archivos.
  3. En Nombre de archivo, ingrese MisDatosEnvío.
  4. En Guardar como tipo, seleccione Minitab.
  5. Haga clic en Guardar.

En el próximo capítulo

Los datos de los centros de envío de diversas fuentes se encuentran en Minitab y están configurados correctamente para el análisis. En el próximo capítulo, usted ajustará la configuración predeterminada de Minitab para facilitar futuros análisis.

Al utilizar este sitio, usted acepta el uso de cookies para efectos de análisis y contenido personalizado.  Leer nuestra política