Wie lautet das numerische Kodierungschema für Farben/Symbole/Linientypen?

Die Minitab-Hilfe enthält Themen, in denen die verschiedenen Kodes aufgeführt sind. Diese Themen finden Sie durch eine einfache Suche.

  1. Wählen Sie Hilfe > Hilfe, und klicken Sie dann unter Referenz auf Sessionbefehle.
  2. Wählen Sie im Minitab-Fenster Hilfe zu Sessionbefehlen die Registerkarte Suchen aus.
  3. Geben Sie je nach den gesuchten Kodes „Standardfarben“, „Symboltyp“ oder „Linientypen“ ein.
  4. Aktivieren Sie Nur Titel suchen.
  5. Klicken Sie auf Themenliste, um das Thema zu Standardfarben, Symboltyp oder Linientyp anzuzeigen, das eine Tabelle der Zahlenkodes enthält.

Wie kann eine Minitab-Grafik mit Befehlen als JPEG-, PNG-, TIF- oder Windows-BMP-Datei gespeichert werden?

Erstellen Sie die Grafik mit dem Sessionbefehl, dem Unterbefehl GSAVE und dem zutreffenden Unterbefehl für das Grafikformat. Beispiel: Sie möchten ein Histogramm der Spalte C1 erstellen und diese Grafik als JPEG-Datei im Stammverzeichnis des Laufwerks „C:“ mit dem Dateinamen „Fehler“ speichern. Verwenden Sie folgende Befehle:

HIST C1;
GSAVE "C:\Fehler";
JPEG.
Hinweis

Verwenden Sie für TIFF-Dateien (Tagged Image File Format) den Unterbefehl TIFC. Verwenden Sie für PNG-Dateien (Portable Network Graphics) den Befehl PNGC. Geben Sie für Windows BMP-Dateien (Windows Bitmap) den Befehl BMPC ein.

Hinweis

In einem Makro wird der Befehl GSAVE gelegentlich auch in anderen Befehlen verwendet, zum Beispiel CALL. Der genannte Unterbefehl für das Grafikformat, z. B. JPEG, darf in solchen Fällen nicht verwendet werden.

Wie wird eine Grafik aus einem selbst verfassten Makro gedruckt?

Verwenden Sie den Befehl GPRINT.

Beispiel 1

In diesem Beispiel werden ein Histogramm und ein Boxplot erstellt und das Boxplot gedruckt.

HIST C1;
BOXPLOT C1;
GPRINT.

Beispiel 2

In diesem Beispiel werden ein Histogramm und ein Boxplot erstellt, die Grafiken als HIST.MGF bzw. BOX.MGF gespeichert und das Boxplot gedruckt.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT

Beispiel 3

In diesem Beispiel werden ein Histogramm und ein Boxplot erstellt, die Grafiken als HIST.MGF bzw. BOX.MGF gespeichert und das Histogramm gedruckt.

HIST C1;
GSAVE "HIST.MGF".
BOXPLOT C1;
GSAVE "BOX.MGF".
GPRINT "HIST.MGF"
Hinweis

Ohne Argument, wie in Beispiel 1 und 2, wird mit dem Befehl GPRINT das aktive Grafikfenster gedruckt. Mit einem Argument wird mit dem Befehl GPRINT die angegebene Grafik geöffnet und an den auf dem Computer festgelegten Standarddrucker übermittelt.

Wie kann das aktuelle Datum (bzw. das aktuelle Datum und die aktuelle Uhrzeit) als Fußnote in eine Grafik eingefügt werden, die mit einem lokalen Makro erstellt wird?

Beispiel: Sie möchten das aktuelle Datum als Fußnote in ein Histogramm der Spalte mit dem Namen ERTRAG einfügen.

Hinweis

Bei den nachfolgend beschriebenen Schritten wird angenommen, dass die Spalten mit den Namen ERTRAG und TMPDATUM und eine Konstante mit dem Namen DATUM im Deklarationsabschnitt des lokalen Makros aufgeführt sind und die Spalte ERTRAG Daten enthält.

  1. Verwenden Sie die Funktion TODAY(), um das aktuelle Datum in einer Spalte zu speichern:
    LET TMPDATUM = TODAY()
    Hinweis

    Wenn Sie das aktuelle Datum und die aktuelle Uhrzeit in der Grafik zeigen möchten, verwenden Sie NOW() anstelle von TODAY().

  2. Ändern Sie den Datentyp, damit die Spalte als Textspalte formatiert ist:
    TEXT TMPDATUM TMPDATUM
  3. Speichern Sie das Datum als Konstante:
    LET DATUM = TMPDATUM
  4. Verwenden Sie die Konstante im Unterbefehl FOOTNOTE:
    HIST ERTRAG;
    FOOTNOTE DATUM.

Wie kann in einem Makro festgelegt werden, dass nach der Erstellung von Grafiken eine bestimmte Pause eingehalten wird?

Um das Anhalten nach der Grafikerstellung zu steuern, verwenden Sie eine der folgenden Formen des Befehls GPAUSE in Ihrem Makro:

GPAUSE

Durch diesen Befehl hält Minitab nach der Anzeige jeder Grafik für K Sekunden (K kann eine ganze Zahl zwischen 0 und 1800 sein) an, bis Sie eine Taste oder die Maustaste drücken.

GPAUSE K

Gibt es einen Sessionbefehl, durch den die letzte Grafik oder alle Grafiken geschlossen werden?

Der nicht dokumentierte Sessionbefehl GMANAGER schließt Grafiken.

Hinweis

Dieser Befehl befindet sich noch in der Erprobungsphase und wurde noch nicht so ausführlich getestet wie die in der Hilfe dokumentierten Befehle. Dieser Befehl sollte mit Vorsicht eingesetzt werden, und wir übernehmen keine Verantwortung für unerwartete Ergebnisse. Änderungen der Form und Syntax dieses Befehls sind vorbehalten.

Geben Sie folgenden Befehl ein, um die letzte Grafik zu schließen:

GMANAGER;
CLOSE.

Geben Sie folgenden Befehl ein, um alle Grafiken zu schließen:

GMANAGER;
ALL;
CLOSE;
NOPROMPT.

Wenn Sie vor dem Schließen der Grafik nicht zum Speichern aufgefordert werden möchten, gehen Sie wie folgt vor:

  1. Wählen Sie Extras > Optionen > Grafiken > Grafikverwaltung aus.
  2. Wählen Sie neben Vor dem Schließen einer Grafik zum Speichern auffordern die Option Nie aus. Klicken Sie auf OK.

Beachten Sie, dass die unter Extras > Optionen vorgenommenen Änderungen beim Schließen aller künftig erstellten Grafiken gelten.

Verwenden von Unterbefehlen wie GSAVE und WTITLE für Grafiken, die diese Unterbefehle nicht enthalten

Sie können Unterbefehle wie GSAVE und WTITLE für Grafiken verwenden, die diese Unterbefehle nicht enthalten, wenn Sie zusätzlich den Befehl LAYOUT verwenden.

Verwenden von GSAVE und WTITLE für GSUMMARY

Statistik > Statistische Standardverfahren > Grafische Zusammenfassung

Angenommen, Sie möchten die grafische Zusammenfassung von C1 als JPEG-Datei mit dem Namen ERTRAG.JPG im Ordner „C:\Meine Statistiken“ ablegen. Außerdem soll „San Francisco“ in der Titelleiste der Grafik angezeigt werden. Verwenden Sie folgende Befehle:
LAYOUT;
GSAVE "C:\Meine Statistiken\ERTRAG.JPG";
JPEG;
WTITLE "San Francisco".
GSUMMARY C1
ENDLAYOUT.

Verwenden von GSAVE und WTITLE für GageRR

Statistik > Qualitätswerkzeuge > Messsystemanalyse (MSA) > Messsystemanalyse (gekreuzt)

Angenommen, Sie möchten folgenden Befehl für eine gekreuzte Messsystemanalyse ausführen:
GageRR;
Parts 'Teil';
Opers 'Prüfer';
Response 'Messung';
Studyvar 6.
Sie möchten die Grafik als JPEG-Datei mit dem Namen „MSA.JPG“ im Ordner „Q:\Projekt“ ablegen. Außerdem soll „MSA 1“ in der Titelleiste der Grafik angezeigt werden. Verwenden Sie folgende Befehle:
LAYOUT;
GSAVE "Q:\Projekt\MSA.JPG";
JPEG;
WTITLE "MSA 1".

GageRR;
Parts 'Teil';
Opers 'Prüfer';
Response 'Messung';
Studyvar 6.

ENDLAYOUT.
Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien