Fehlermeldungen in Makros

Welche Befehle sind beim Debuggen von Makros und bei der Fehlerbehandlung in Makros hilfreich?

  1. Wählen Sie Hilfe > Hilfe aus, und klicken Sie anschließend auf Sessionbefehle.
  2. Klicken Sie unter Befehlslisten auf Makrobefehle nach Funktion.
  3. Blättern Sie nach unten zu Debugtools und Fehlerbehandlung.

Beim Ausführen einer Exec-Datei wird ein Fehler ausgegeben, und die Ausführung wird angehalten. Wie kann ich die Ausführung der Exec-Datei nach dem Befehl, der den Fehler auslöst, fortsetzen lassen?

Sie können den nicht dokumentierten Befehl ZERROR in der Exec-Datei verwenden.

Beispiel: Angenommen, die Exec-Datei enthält die folgenden Befehle:

RAND 10 C1
DESS C1
RAND 10 C2
DESC C2

Bei dem Versuch, diese Exec-Datei auszuführen, wird im Sessionfenster folgende Fehlermeldung ausgegeben, und die Ausführung der Exec-Datei wird angehalten:

* FEHLER * Unbekannter Minitab-Befehl: DESS

Wenn Sie den Befehl ZERROR wie nachfolgend gezeigt in die Exec-Datei einfügen, wird nach wie vor eine Fehlermeldung im Sessionfenster ausgegeben, die Exec-Datei wird jedoch weiterhin ausgeführt.

RAND 10 C1
DESS C1
ZERROR
RAND 10 C2
DESC C2

Warum wird beim Aufrufen eines Makros die Fehlermeldung „* FEHLER * Ungültiger Pfad * HINWEIS * Der Befehl wurde abgebrochen“ angezeigt?

Diese Fehlermeldung wird angezeigt, wenn Sie ein Makro aufrufen, in dem ein Diagramm mit dem Unterbefehl GSAVE in einem nicht vorhandenen Verzeichnis gespeichert werden soll. Korrigieren Sie den im Unterbefehl GSAVE angegebenen Pfad, und speichern Sie das Makro anschließend erneut. Nun sollte das Makro ungehindert ausgeführt werden können.

Beim Aufrufen eines Makros wird die Fehlermeldung „* FEHLER * Datei wurde nicht gefunden:“ angezeigt.

Hier finden Sie zwei mögliche Erklärungen.

Problem 1: Minitab kann das Makro nicht finden.

Sie haben mehrere Möglichkeiten, dieses Problem zu beheben.

  • Legen Sie das Makro im Ordner „Makros“ ab. Beispiel: C:\Programme\Minitab\Minitab 16\Deutsch\Makros.
  • Wählen Sie Extras > Optionen aus. Geben Sie im Feld „Speicherort für Makros“ den gewünschten Ordner ein, oder klicken Sie auf „Durchsuchen“, um zum gewünschten Ordner zu navigieren.
  • Geben Sie beim Aufruf des Makros den Pfad ein. Beispiel: Wenn das Makro den Namen „MEINMAKRO“ trägt und unter „C:\MAKROS“ abgelegt ist, geben Sie folgendes ein:
    %'C:\MAKROS\MEINMAKRO'
    .

Problem 2: Das Makro wurde nicht als Textdatei mit der entsprechenden Dateinamenerweiterung „.MAC“ gespeichert.

Falls das Makro im korrekten Ordner abgelegt wurde und beim Aufrufen des Makros weiterhin die gleiche Fehlermeldung ausgegeben wird, gehen Sie wie folgt vor:

  1. Öffnen Sie die Makrodatei im Windows-Editor.
  2. Wählen Sie Datei > Speichern unter aus.
  3. Geben Sie im Feld „Dateiname“ den Namen des Makros mit der Dateinamenerweiterung „.MAC“ in geraden Anführungszeichen ein (z. B., "MEINMAKRO.MAC").

    Alternativ können Sie auch im Feld „Dateiname“ den Namen des Makros mit der Dateinamenerweiterung „.MAC“ eingeben (z. B. MEINMAKRO.MAC) und als Dateityp „Alle Dateien“ festlegen.

  4. Klicken Sie auf Speichern.

Beheben der Fehlermeldung „* FEHLER * Datei wurde nicht gefunden:“

Diese Meldung wird aus einem der folgenden Gründe angezeigt:
  • Das Makro befindet sich nicht im Ordner Makros, der in Minitab festgelegt ist.
  • Das Makro ist keine Textdatei mit der Dateinamenerweiterung für Makros („.mac“).
Tipp

Wenn sich das Makro im Ordner Makros befindet und die Dateinamenerweiterung „.mac“ lautet, lässt sich das Makro auf schnelle Weise ohne Ausgabe der Fehlermeldung ausführen, indem Sie im Befehlszeilen-Editor wie folgt den Dateipfad mit dem Dateinamen eingeben:

%'C:\Benutzer\sgarcia\Dokumente\Minitab_Dokumente\MeinMakro'

  1. Legen Sie das Makro im Ordner Makros ab.
    • Wenn Ihnen nicht bekannt ist, wo sich der Ordner Makros befindet, wählen Sie in Minitab Extras > Optionen aus. Das Feld Speicherort für Makros enthält den Verzeichnispfad.
    • Wenn das Feld Speicherort für Makros leer ist, geben Sie einen Pfad ein (z. B. C:\Programme\Minitab\Minitab 17\Deutsch\Makros).
  2. Führen Sie das Makro aus.
  3. Wenn die Fehlermeldung erneut angezeigt wird, gehen Sie wie folgt vor, um das Makro als Textdatei mit der Dateinamenerweiterung „.mac“ zu speichern:
    1. Öffnen Sie das Makro in einem Texteditor, beispielsweise dem Windows-Editor.
    2. Wählen Sie Datei > Speichern unter aus.
    3. Geben Sie im Feld Dateiname den Namen des Makros mit der Dateinamenerweiterung „.mac“ ein (z. B. ProjektMakro.mac).
    4. Wählen Sie in der Liste Dateityp die Option Alle Dateien (*.*) aus.

Nun können Sie das Makro ausführen, ohne dass die Fehlermeldung angezeigt wird.

Beim Aufrufen eines Makros (entweder ein Minitab-Makro oder ein selbst verfasstes bzw. bearbeitetes Makro) wird die Meldung „* FEHLER * Der Dateiname ist ungültig.“ ausgegeben.

Stellen Sie sicher, dass Sie die Anwendung, in der Sie das Makro verfasst bzw. bearbeitet haben, geschlossen haben. Wenn Sie das Makro beispielsweise in Microsoft Word verfasst oder bearbeitet haben und Microsoft Word noch geöffnet ist, schließen Sie das Programm.

Ich möchte den Befehl WORKSHEET in einem lokalen Makro verwenden, um ein bestimmtes Arbeitsblatt zu aktivieren, es wird jedoch die Meldung „* FEHLER * In einem lokalen Makro kann der Befehl WORKSHEET nur zum Umbenennen eines Arbeitsblatts verwendet werden.“ angezeigt.

Sie können behelfsweise eine Exec-Datei verwenden, um jeweils ein Arbeitsblatt zu aktivieren und dann das Makro aufzurufen. Angenommen, Sie möchten das lokale Makro „MeinLokalesMakro“ für die beiden Arbeitsblätter „Woche1“ und „Woche2“ aufrufen. Das folgende Beispiel zeigt, wie diese Exec-Datei aussehen könnte:

Worksheet "Woche1"
%MeinLokalesMakro
Worksheet "Woche2"
%MeinLokalesMakro

Warum wird die Fehlermeldung „** FEHLER ** Es wird eine Makrokopfzeile erwartet. Stattdessen gefunden: ÐÏ à¡±, ** FEHLER ** Kein Makroprogramm in der Datei.“ angezeigt, wenn ich ein lokales oder globales Makro ausführen möchte, das in Microsoft Word geschrieben wurde?

Diese Fehler treten auf, wenn Sie ein in Microsoft Word verfasstes lokales oder globales Makro aufrufen, das nicht als „Nur Text (*.txt)“ gespeichert wurde. Im Folgenden werden zwei Verfahren erläutert, wie Sie ein in Microsoft Word verfasstes Makro als „Nur Text (*.txt)“ speichern:

Option 1

  1. Öffnen Sie das Makro in Microsoft Word.
  2. Wählen Sie Datei > Speichern unter aus.
  3. Geben Sie im Feld „Dateiname“ den Namen des Makros mit der Dateinamenerweiterung „.MAC“ in geraden Anführungszeichen ein (z. B., "MEINMAKRO.MAC").
  4. Wählen Sie im Dropdownfeld Dateityp die Option Nur Text (*.txt) aus. Klicken Sie auf Speichern.
    Hinweis

    Wenn die Meldung „[Dateiname] enthält möglicherweise Features, die mit dem Format 'Nur Text' nicht kompatibel sind. Möchten Sie das Dokument in diesem Format speichern?“ angezeigt wird, klicken Sie auf „Ja“.

  5. Schließen Sie Microsoft Word.

Option 2

  1. Kopieren Sie die Inhalte des Makros in Microsoft Word, und fügen Sie diese im Windows-Editor ein.
    Hinweis

    Um den Windows-Editor zu öffnen, klicken Sie auf das Menü Start, und wählen Sie die Optionen Alle Programme > Zubehör > Editor aus.

  2. Wählen Sie Datei > Speichern unter aus.
  3. Geben Sie im Feld Dateiname den Namen des Makros mit der Dateinamenerweiterung „.MAC“ in geraden Anführungszeichen ein (z. B., "MEINMAKRO.MAC"). Klicken Sie auf Speichern.

Warum wird beim Versuch, bestimmte Diagramme zu erstellen, die Fehlermeldung „* FEHLER * Unterbefehl ___ liegt außerhalb der Sequenz, oder er ist mit diesem Befehl nicht gültig. * FEHLER * Der Unterbefehl wird ignoriert.“ angezeigt?

Der Befehl GSTD muss verwendet worden sein. Durch den Befehl GSTD werden Grafiken mit Schriftzeichen (Standard) aktiviert und Grafiken mit hoher Auflösung (professionell) deaktiviert. Um wieder zur Einstellung für professionelle Grafiken zurückzukehren, geben Sie an der Eingabeaufforderung (MTB >) im Sessionfenster Folgendes ein:

GPRO
Hinweis

Um die Eingabeaufforderung anzuzeigen, aktivieren Sie das Sessionfenster, und wählen Sie Editor > Befehle aktivieren aus.

Beim Aufrufen eines Makros aus der Makrobibliothek von Minitab werden folgende Fehlermeldungen angezeigt: „* FEHLER * Das Argument ist eine Konstante oder Matrix, es wurde jedoch eine Spalte erwartet. * FEHLER * Makro wird beendet“

Diese Fehlermeldung wird häufig beim Aufrufen von Makros ausgegeben, die den Benutzer zu einer Eingabe im Sessionfenster auffordern, während die Befehlssprache im Sessionfenster deaktiviert ist. So aktivieren Sie die Befehlssprache:
  1. Klicken Sie auf das Sessionfenster, um es zu aktivieren.
  2. Wählen Sie Editor > Befehle aktivieren aus.

Wenn diese Fehlermeldung angezeigt wird, obwohl das Makro nicht zu einer Benutzereingabe auffordert, überprüfen Sie, ob das Makro durch die richtigen Befehle und Unterbefehle aufgerufen wird.

Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien