Methode des steilsten Anstiegs

Dieses Makro berechnet eine angegebene Anzahl von Durchläufen entlang dem Pfad des steilsten Anstiegs oder Abstiegs. Das Makro ist hinreichend flexibel, um verschiedene Basisfaktoren, Schrittgrößen und Anzahlen von Durchläufen verarbeiten zu können.

Herunterladen des Makros

Vergewissern Sie sich, dass Sie in Minitab den Speicherort des heruntergeladenen Makros angegeben haben. Wählen Sie Extras > Optionen > Allgemein aus. Navigieren Sie im Feld Speicherort für Makros zu dem Speicherort, an dem Sie Makrodateien ablegen.

Wichtig

Wenn Sie einen älteren Webbrowser verwenden und auf die Schaltfläche Herunterladen klicken, wird die Datei möglicherweise in Quicktime geöffnet; für dieses Programm wird dieselbe Dateinamenerweiterung „.mac“ wie für Minitab-Makros verwendet. Um das Makro zu speichern, klicken Sie mit der rechten Maustaste auf die Schaltfläche Herunterladen, und wählen Sie Ziel speichern unter aus.

Erforderliche Eingaben

  • Eine Spalte mit Daten der Antwortvariablen
  • Entsprechende Spalten mit den nicht kodierten Stufen der Faktoren

Optionale Eingaben

STORE C-C
Speichert den Pfad des steilsten Anstiegs/Abstiegs im Arbeitsblatt. Die Eingaben geben die Spalten im Arbeitsblatt an, in denen der Pfad gespeichert wird. Geben Sie pro Faktor eine Speicherspalte an. Wenn dieser Unterbefehl nicht angegeben ist, zeigt Minitab den Pfad in der Ausgabe im Sessionfenster an, der Pfad wird jedoch nicht im Arbeitsblatt gespeichert.
STEP K
Legt die Schrittgröße bzw. das Intervall der Prozessvariablen ( ) in kodierten Einheiten fest. Standardmäßig ist das Intervall gleich 1.
BASE C
Legt die Schrittgröße im Pfad des steilsten Anstiegs/Abstiegs fest. Die Eingabe b ist die Spalte mit dem Koeffizienten, der die Schrittgröße angibt. Standardmäßig ist die Schrittgröße der Faktorkoeffizient mit dem größten absoluten Wert.
DESCENT
Geben Sie dies an, um den Pfad des steilsten Abstiegs anstelle des steilsten Anstiegs (Standardeinstellung) zu berechnen.
RUNS K
Gibt die Anzahl der zu generierenden Durchläufe an. Die Eingabe r ist eine Konstante. Standardmäßig beträgt die Anzahl der Durchläufe 5.

Ausführen des Makros

Angenommen, Sie verfügen über einen Versuchsplan mit zwei Faktoren, die Faktoren sind in C5 und C6 gespeichert, und die Antwortvariablen sind in C7 enthalten. Sie möchten einen Pfad bestimmen, der potenziell den Wert der Antwortvariablen maximiert. Darüber hinaus soll dieser Pfad im Arbeitsblatt in den Spalten C9-C10 gespeichert werden; die Schrittgröße zwischen den Durchläufen soll 2 (in kodierten Einheiten) betragen, und der Faktor in C5 soll der Basisfaktor sein. Schließlich möchten Sie acht Durchläufe entlang dem Pfad des steilsten Anstiegs berechnen.

Um das Makro auszuführen, wählen Sie Bearbeiten > Befehlszeilen-Editor aus, und geben Sie Folgendes ein:
%ASCENT C7 C5-C6;
STORE C9-C10;
STEP 2;
BASE C5;
RUNS 8.

Klicken Sie auf Befehle übermitteln.

Weitere Informationen

Überblick über Analysemethoden für Wirkungsflächen

Mit Hilfe von Analysemethoden für Wirkungsflächen können Sie eine Antwortvariable von Interesse optimieren, indem Sie die besten Einstellungen für die steuerbaren Faktoren bestimmen. Damit besteht das grundlegende Ziel in der Analyse für Wirkungsflächen im Ermitteln der optimalen Einstellungen .

Dies können Sie mit einem sequenziellen Experimentablauf erreichen. Im Allgemeinen beginnen Sie mit einem faktoriellen oder teilfaktoriellen Versuchsplan, um irrelevante Faktoren herauszufiltern. Wenn Ihnen ein Regressionsmodell für die Antwortvariable vorliegt, extrapolieren und experimentieren Sie entlang des Pfads des steilsten Anstiegs, um den Wert der Antwortvariablen zu maximieren. Wählen Sie schließlich einen Wirkungsflächenversuchsplan aus, um die Krümmung zu modellieren und den optimalen Wert der Antwortvariablen zu ermitteln.

Dies sind die drei grundlegenden Schritte bei der Analyse einer Wirkungsfläche:

  1. Führen Sie Screening-Experimente zur Faktorauswahl durch.
  2. Folgen Sie dem Pfad des steilsten Anstiegs/Abstiegs.
  3. Passen Sie ein quadratisches Regressionsmodell an, und optimieren Sie es.

In den folgenden Abschnitten wird der Pfad des steilsten Anstiegs beschrieben. Zudem wird seine Berechnung erläutert, und es wird ein Minitab-Makro zum Durchführen dieser Aufgabe vorgestellt. Dies wird anhand von zwei Beispielen veranschaulicht.

Was ist der Pfad des steilsten Anstiegs/Abstiegs?

Nachdem Sie ein Screening-Experiment durchgeführt und ein lineares Modell der Antwortvariablen (das nur Haupteffekte enthält) erhalten haben, möchten Sie nun die Antwortvariable schnell verbessern. Folgen Sie zum Maximieren des Werts der Antwortvariablen dem Pfad des steilsten Anstiegs. Folgen Sie zum Minimieren des Werts der Antwortvariablen dem Pfad des steilsten Abstiegs.

Berechnen des Pfads des steilsten Anstiegs/Abstiegs

Zum Berechnen des Pfads des steilsten Anstiegs müssen Sie zunächst ein Modell anpassen. Angenommen, ein Experiment umfasst zwei Faktoren, und die Wechselwirkung zwischen Faktor x1 und Faktor x2 ist nicht signifikant. Die Modellgleichung für dieses Experiment lautet wie folgt:

wobei der geschätzte Schnittpunkt mit der y-Achse ist und , die Koeffizienten für die Faktoren und sind.

Wenn die Modellgleichung vorliegt, gehen Sie wie folgt vor:

  1. Wählen Sie eine Prozessvariable als „Basisfaktor“ aus, und geben Sie die Schrittgröße bzw. das Intervall () i für den Basisfaktor an.
    Hinweis

    Standardmäßig gilt Folgendes: Wenn der Basisfaktor nicht angegeben ist, wählt das Makro die Variable aus, die den größten absoluten Regressionskoeffizienten aufweist, .

  2. Bestimmen Sie das Intervall in den anderen Prozessvariablen anhand der folgenden Gleichung:
  3. Transformieren Sie die Intervalle aus kodierten Einheiten in nicht kodierte Einheiten.

Formular für den steilsten Anstieg im Quality Companion

Sie können den Pfad des steilsten Anstiegs/Abstiegs auch mit Hilfe eines Standardformulars im Quality Companion 2 berechnen. Geben Sie einfach die Eingabeparameter ein, indem Sie die Basisvariable, die nicht kodierten Stufen der Faktoren sowie das Intervall angeben und so viele Durchläufe wie gewünscht hinzufügen.

Beispiel 1: Maximieren der Ätzrate

Das folgende Beispiel ist eine Variante eines Beispiels aus „Response Surface Methodology: Process and Product Optimization Using Designed Experiments“ von Myers und Montgomery.

Bei der Herstellung von Halbleitern besteht das Ziel im Maximieren der Plasma-Ätzrate (der Antwortvariablen) durch Variieren der Stufen der Faktoren Abstand zwischen Anode und Kathode (Abstand) und der Stromstärke zur Kathode (Strom). Angenommen, nach Durchführung des Experiments liegt das folgende Modell vor:

Hierbei sind der Abstand und die Stromstärke.

Zum Berechnen des Pfads des steilsten Anstiegs mit Hilfe des Makros bestimmen Sie zuerst die Spalten im Arbeitsblatt, die der Antwortvariablen und den Haupteffekten ( und ) in nicht kodierten Einheiten entsprechen. Für dieses Beispiel ist die Antwortvariable (Ätzrate) in C7 enthalten, während die Haupteffekte (Abstand und Strom) in C5 und C6 enthalten sind.

Um das Makro auszuführen, wählen Sie Bearbeiten > Befehlszeilen-Editor aus, und geben Sie Folgendes ein:

%ASCENT C7 C5-C6;
 STORE C9-C10.
Hinweis

Wenn Sie die Version „ASCENT17.mac“ des Makros verwenden, geben Sie %ASCENT17 anstelle von %ASCENT ein.

Klicken Sie auf Befehle übermitteln.

Auf der Grundlage der Daten aus dem Arbeitsblatt erstellt Minitab fünf Durchläufe im Pfad des steilsten Anstiegs und speichert den Pfad in den Spalten C9 und C10. Wenn das endgültige Modell nur zwei Faktoren aufweist, können Sie ein Streudiagramm erstellen, um den Pfad des steilsten Anstiegs/Abstiegs darzustellen.

Beispiel 2: Minimieren der Ausbeute einer Reaktion

Dieses Beispiel ist eine Variante eines von Myers und Montgomery veröffentlichten Beispiels, so dass anstelle des Pfads des steilsten Anstiegs der Pfad des steilsten Abstiegs verwendet wird.

Angenommen, das Ziel eines Experiments besteht darin, die Ausbeute einer Reaktion zu minimieren, indem bessere Einstellungen für vier steuerbare Faktoren ermittelt werden: A (Menge von Reaktant A), B (Reaktionszeit), C (Menge von Reaktant C) und D (Temperatur). Die nicht kodierten (natürlichen) Stufen der vier Faktoren lauten: 10, 15 Gramm für Faktor A; 1, 2 Minuten für Faktor B; 25, 35 Gramm für Faktor C und 75, 85 °C für Faktor D. Darüber hinaus entspricht der Basiskoeffizient Reaktant A und die Schrittgröße beträgt 1 Gramm in nicht kodierten Einheiten. Das angepasste Modell sieht wie folgt aus:

.

Geben Sie den Unterbefehl DESCENT an, um mit dem Makro den Pfad des steilsten Abstiegs zu berechnen. Da Reaktant A Spalte C5 entspricht, ist die Eingabe für BASE C5. Die Angabe für STEP in kodierten Einheiten ist 1/2,5 = 0,4, da eine kodierte Einheit von Faktor A 2,5 Gramm entspricht. Um das Makro auszuführen, wählen Sie Bearbeiten > Befehlszeilen-Editor aus, und geben Sie Folgendes ein:

%ASCENT C9 C5-C8;
STORE C11-C14;
STEP 0,4;
BASE C5;
DESCENT;
RUNS 10.
Hinweis

Wenn Sie die Version „ASCENT17.mac“ des Makros verwenden, geben Sie %ASCENT17 anstelle von %ASCENT ein.

Hinweis

Um die Ausgabe für das ursprüngliche Beispiel aus dem Lehrbuch zu erhalten, berechnen Sie anhand des Pfads des steilsten Anstiegs die Richtung der Verbesserung. Verwenden Sie den Block von Befehlen ohne den Unterbefehl DESCENT, wie im Folgenden veranschaulicht:

%ASCENT C9 C5-C8;
STORE C11-C14;
STEP 0,4;
BASE C5;
RUNS 10.

Literaturhinweis

R. Myers und D. Montgomery (2002). „Response Surface Methodology – Process and Product Optimization Using Designed Experiments“, Second Edition. John Wiley & Sons, Inc.

Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien