Dieses Makro berechnet benutzerspezifische Perzentile für eine Datenspalte. Sie können außerdem Perzentile für Gruppen anhand einer Gruppierungsvariablen berechnen.

Ein Teil dieser Funktion ist in Minitab 16 vorhanden. Wählen Sie Berechnen > Rechner und die Funktion „Perzentile“ aus, um Perzentile für eine ganze Spalte zu berechnen.

Herunterladen des Makros

Vergewissern Sie sich, dass Sie in Minitab den Speicherort des heruntergeladenen Makros angegeben haben. Wählen Sie Extras > Optionen > Allgemein aus. Navigieren Sie im Feld Speicherort für Makros zu dem Speicherort, an dem Sie Makrodateien ablegen.

Wichtig

Wenn Sie einen älteren Webbrowser verwenden und auf die Schaltfläche Herunterladen klicken, wird die Datei möglicherweise in Quicktime geöffnet; für dieses Programm wird dieselbe Dateinamenerweiterung „.mac“ wie für Minitab-Makros verwendet. Um das Makro zu speichern, klicken Sie mit der rechten Maustaste auf die Schaltfläche Herunterladen, und wählen Sie Ziel speichern unter aus.

Erforderliche Eingaben

  • Eine Spalte mit numerischen Daten. Sie können auch eine Spalte mit Gruppierungswerten angeben, um Perzentile für jede Gruppenstufe zu berechnen.
  • Eine Spalte mit Prozentsätzen oder ein einzelner konstanter Prozentsatz
  • Eine leere Spalte zum Speichern der Ergebnisse

Ausführen des Makros

Angenommen, die Daten befinden sich in C1 und die Prozentsätze in C2, und die Perzentile sollen in C10 gespeichert werden. Um das Makro auszuführen, wählen Sie Bearbeiten > Befehlszeilen-Editor aus, und geben Sie Folgendes ein:

%PERCENTILE C1 C2 C10

Klicken Sie auf Befehle übermitteln.

Hinweis

Um einen konstanten Wert für einen Prozentsatz anzugeben, geben Sie einfach den betreffenden Wert anstelle einer Spalte ein.

Angenommen, die Daten sind in C1 enthalten, die Spalte mit Prozentsätzen ist in C2 gespeichert, und die Gruppierungsvariable befindet sich in C3. Da die Gruppierungsvariable drei Stufen aufweist, müssen Sie drei Spalten zum Speichern der Perzentile angeben, beispielsweise C10, C11 und C12. Um das Makro auszuführen, wählen Sie Bearbeiten > Befehlszeilen-Editor aus, und geben Sie Folgendes ein:

%PERCENTILE C1 C2 C10-C12;
BY C3.

Klicken Sie auf Befehle übermitteln.

Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien