Erstellen einer wiederverwendbaren ODBC-Exec-Datei

Wenn Sie Ihr Arbeitsblatt häufig mittels Datei > Datenbank abfragen (ODBC) aktualisieren, können Sie den Vorgang mit einer Exec-Datei automatisieren.

Erstellen der Exec-Datei

  1. Importieren Sie die Daten mit Datei > Datenbank abfragen (ODBC). Weitere Informationen finden Sie unter Importieren von Daten aus einer Datenbank mit ODBC.
  2. Klicken Sie auf die Schaltfläche „Verlauf anzeigen“ auf der Symbolleiste „Project Manager“, um das Fenster „Verlauf“ zu öffnen.
  3. Wählen Sie die ODBC-Sessionbefehle und -unterbefehle aus, klicken Sie mit der rechten Maustaste, und wählen Sie Speichern unter... aus.
  4. Wählen Sie in Dateityp die Option Exec (*.mtb) aus.
  5. Geben Sie einen Dateinamen ein (z. B. Datenabruf.MTB).
  6. Wählen Sie einen Speicherort für die Datei aus, und klicken Sie dann auf Speichern.
  7. Führen Sie folgende Schritte aus, um die Exec-Datei auszuführen:
    1. Wählen Sie Extras > Exec ausführen aus.
    2. Geben Sie an, wie häufig die Exec-Datei ausgeführt werden soll.
    3. Klicken Sie auf Datei auswählen.
    4. Wählen Sie die Exec-Datei aus, und klicken Sie auf Öffnen.

Angeben von Ausgabespalten in der Exec-Datei

Wenn bei jeder Ausführung der Exec-Datei Daten im selben Minitab-Arbeitsblatt aktualisiert werden sollen, müssen Sie in der Exec-Datei angeben, welche Spalten im Minitab-Arbeitsblatt verwendet werden sollen.

Tipp

In einer ODBC SQL-Zeichenfolge oder Verbindungszeichenfolge dürfen pro Zeile höchstens 80 Zeichen zwischen doppelten Anführungszeichen stehen. Um Textzeichenfolgen mit mehr als 80 Zeichen verwenden zu können, unterteilen Sie die Zeichenfolge mit dem Zeichen & (kaufmännisches Und) in kleinere Abschnitte auf mehreren Zeilen. Im folgenden Beispiel für den Inhalt des Sessionfensters wird mit dem kaufmännischen Und eine lange Textzeichenfolge in doppelten Anführungszeichen in der nächsten Zeile fortgesetzt.

MTB > ODBC;
SUBC> Connect "DSN=Excel Files;DBQ=C:\DOKUMENTE UND EINSTELLUNGEN\JSABARA\DESKTOP\jon" &
CONT> "athon.xls;DefaultDir=C:\DOKUMENTE UND EINSTELLUNGEN\JSABARA\DESKTOP;DriverId=345" &
CONT> ";MaxBufferSize=2048;PageTimeout=5;";

  1. Wählen Sie in Minitab Extras > Editor aus.
  2. Wählen Sie im Windows-Editor Datei > Öffnen aus. Ändern Sie den Dateityp in Alle (*.*), und öffnen Sie die erstellte MTB-Datei.
  3. Führen Sie für jeden ODBC-Sessionbefehl und die entsprechenden Unterbefehle folgende Schritte aus:
    1. Ersetzen Sie den Punkt (.) am Ende des letzten Unterbefehls durch ein Semikolon (;), und drücken Sie dann die Eingabetaste.
    2. Geben Sie in der darauffolgenden Zeile die Spalten an, in denen die Daten gespeichert werden sollen. Geben Sie beispielsweise Columns 'Vorname' 'Nachname' 'Ort' 'Land' ein.Dieses Beispiel funktioniert nur, wenn die Spalten im Minitab-Arbeitsblatt bereits übereinstimmend mit der Exec-Datei benannt sind.

      Sie können anstelle der einzelnen Spalten einen Bereich von Spalten-IDs angeben (z. B. Columns C1-C10). Die Angabe eines Bereichs ist insbesondere dann nützlich, wenn Sie eine große Anzahl von Spalten importieren möchten.

  4. Wählen Sie Datei > Speichern aus, und schließen Sie dann den Windows-Editor.

Ausführen der Exec-Datei

  1. Wählen Sie Extras > Exec ausführen aus.
  2. Klicken Sie auf Datei auswählen.
  3. Wählen Sie die gespeicherte Exec-Datei aus, und klicken Sie auf Öffnen.
Hinweis

Wenn Sie eine Verknüpfung zum Ausführen der Exec-Datei aus einem Menü oder über eine Symbolleiste hinzufügen möchten, wechseln Sie zu Hinzufügen einer Verknüpfung zu einem Menü oder einer Symbolleiste zum Ausführen einer Minitab-Makro- oder Exec-Datei.

Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien