创建自定义菜单

可以为特殊任务或项目创建新菜单。例如,为每月报告创建工具菜单。

  1. 选择查看 > 自定义。
  2. 在命令选项卡上,从类别列表中选择新建菜单,然后从命令列表中选择新建菜单。
  3. 在自定义对话框处于打开状态时,将新建菜单拖到 Minitab 界面上的所需位置。当插入点出现时,松开鼠标按钮。
  4. 从 Minitab 界面中的新菜单位置,右键单击新建菜单并选择指定按钮名称。输入自定义菜单的名称(例如,每月报告工具),然后单击确定。
  5. 向自定义菜单中添加命令。
    1. 在自定义对话框中,单击命令选项卡。
    2. 在命令选项卡上,从类别列表中选择一个类别,然后从命令列表中,选择要添加的命令。
    3. 在自定义对话框处于打开状态时,将选定的命令拖到 Minitab 界面中的自定义菜单上。
  6. 重复步骤 5,直到添加了您要添加到自定义菜单中的所有命令。
  7. 单击关闭。

创建自定义工具栏

您可以为特殊任务或项目创建新工具栏。例如,创建一个常用分析的工具栏,其中显示已添加的命令的名称。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击工具栏选项卡。
  3. 在工具栏选项卡上,单击新建按钮。
  4. 输入工具栏名称(例如,我的工具),然后单击确定。 自定义工具栏在主监视器的中心创建。
  5. 在自定义对话框处于打开状态时,将自定义工具栏拖到 Minitab 界面上的所需位置,当插入点出现时,松开鼠标按钮。 将出现工具栏指示符, 以显示自定义工具栏的位置。
  6. 向自定义工具栏中添加命令。
    1. 在自定义对话框中,单击命令选项卡。
    2. 在命令选项卡上,从类别列表中选择一个类别,然后从命令列表中,选择要添加的命令。
    3. 在自定义对话框处于打开状态时,将所选命令拖到 Minitab 界面上的所需位置,当插入点出现时,松开鼠标按钮。
  7. 重复步骤 5,直到添加了您要添加到自定义工具栏中的所有命令。
  8. 单击关闭。

在工具栏上显示命令的名称

可以在工具栏上显示所有按钮的名称,也可以仅显示一个按钮的名称

显示所有按钮的名称

下列步骤说明如何在工具栏上显示所有按钮的名称。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击工具栏选项卡。
  3. 从工具栏列表中,选择 Minitab 界面中已经显示的工具栏的名称,也就是说,处于选中和突出显示状态的工具栏的名称。
  4. 选择显示文本标签。 将在所选工具栏上显示所有按钮的名称。

显示一个按钮的名称

下列步骤说明如何在工具栏上仅显示一个按钮的名称。

  1. 选择查看 > 自定义。
  2. 在自定义对话框处于打开状态时,在 Minitab 界面中的所需工具栏上右键单击该按钮,然后选择下列任一选项:
    • 选择文本将仅显示所选按钮的名称。
    • 选择图像和文本将显示所选按钮的图像和名称。

更改工具栏按钮上的图像

您可以更改工具栏按钮上的图像。

  1. 选择查看 > 自定义。
  2. 当自定义对话框处于打开状态时,完成以下任务之一:
    • 要将一个按钮的图像复制到另一个按钮,请右键单击该按钮进行复制并选择复制按钮图像,然后右键单击该按钮进行更改并选择粘贴按钮图像。
    • 要编辑现有按钮的图像,请右键单击该按钮,选择编辑按钮图像,使用调色板和编辑工具编辑按钮图像,然后单击确定。
    • 要显示按钮名称,而不显示图像,请右键单击该按钮并选择文本。要同时显示按钮名称和图像,请右键单击该按钮并选择图像和文本。
  3. 单击关闭。

在菜单或工具栏中移动或删除命令

可以将命令移动到菜单或工具栏上的不同的位置。您还可以删除任何不使用的命令。

  1. 选择查看 > 自定义。
  2. 当自定义对话框处于打开状态时,打开 Minitab 菜单或显示要自定义的 Minitab 工具栏,然后执行以下任务之一:
    • 要将某个命令移到菜单或工具栏上的其他位置,请将该命令拖到新位置。
    • 要删除某个命令,请将该命令拖出菜单或工具栏。
  3. 单击关闭。

创建自定义命令

例如,您可以创建自定义命令来打开其他应用程序、访问网站或运行 Minitab 宏。

要创建新命令,必须首先在工具选项卡上创建它,然后可以从命令选项卡上,将新命令移到现有的菜单或工具栏上。

创建用来打开其他应用程序或访问网站的自定义命令

您可以创建用来打开 Companion(另一个 Minitab 产品)的自定义命令。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击工具选项卡。
  3. 在工具选项卡上,单击新建 (插入)按钮 .
  4. 输入名称,如 Companion。
  5. 输入该命令的信息:
    • 在命令中,输入路径或者浏览到该工具的外部应用程序或 Web 地址,例如:C:\Program Files (x86)\Minitab\Companion\Companion\Companion.exe。
    • 必要时,在变元中,输入要传递至为其添加链接的应用程序的变元,例如,要让应用程序自动打开的特定文件。
    • 必要时,在初始目录中,创建为其添加链接的应用程序的初始保存文件夹。
  6. 单击关闭。
  7. 选择查看 > 自定义以再次打开自定义对话框。
  8. 在类别选项卡的命令下,选择工具。
  9. 在自定义对话框处于打开状态时,将新命令拖到 Minitab 菜单或工具栏上的所需位置。
  10. 单击关闭。

创建用来运行 Minitab 宏或可执行文件的命令

如果您经常使用某个 Minitab 宏或可执行文件(例如用来更新数据库中的数据),则可以创建用来运行该宏或可执行文件的命令。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击工具选项卡。
  3. 在工具选项卡上,单击新建 (插入)按钮 .
  4. 键入命令的名称,然后按 Enter 键。
  5. 单击打开按钮 .
  6. 从文件类型下拉列表中,选择全部 (*.*)。
  7. 浏览并选择所需的宏或可执行文件。
  8. 如果宏在运行时需要用户的输入,则通过在变元后面输入列、常量或矩阵来指定该宏所需的变元。
    注意

    您只能指定一组变元。如果您希望使用另一组变元运行该宏,则必须修改快捷键的变元,或者使用其他变元创建另一个快捷键。

    例如,假设您一次运行一个宏,并指定第 95 个百分位数作为一个变元(例如,C1 95 C10)。然后,再次运行宏,并指定第 90 个百分位数(例如,C1 90 C11)。您可以使用 95 作为变元来创建一个名为 95th Percentile 的快捷方式,然后使用 90 作为变元来创建另一个名为 90th percentile 的快捷方式。

  9. 单击关闭。
  10. 选择查看 > 自定义以再次打开自定义对话框。
  11. 在类别选项卡的命令下,选择工具。
  12. 在自定义对话框处于打开状态时,将新命令拖到 Minitab 菜单或工具栏上的所需位置。
  13. 单击关闭。

为命令添加键盘快捷键

添加快捷键,以节省执行最常用命令所需的时间。例如,创建一个用于打开双样本 t对话框的键盘快捷键。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击键盘选项卡。
  3. 在键盘选项卡上,从类别中选择命令所属的类别,例如统计。
  4. 在命令下面,选择所需的命令,例如 2-Sample t...[Basic Statistics]。
  5. 在按下新建快捷键字段中单击,然后按键盘快捷键,例如 Ctrl+B。
    如果已经分配了键盘快捷键,Minitab 将显示一条消息。
  6. 单击指定并关闭该窗口。

编辑上下文菜单

上下文菜单是指仅在特定组件(如图形、表或工作表)处于活动状态时才为活动状态的菜单。大多数上下文菜单都是右键单击菜单。例如,在您右键单击某个图形时,会看到图形视图上下文菜单。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击菜单选项卡。
  3. 在菜单选项卡上的上下文菜单下,从选择上下文菜单中,选择要编辑的上下文菜单。
  4. 单击命令选项卡。
  5. 在命令选项卡上,从类别列表中选择一个类别,然后从命令列表中,选择要添加的命令。
  6. 当自定义对话框处于打开状态时,将所选命令拖到 Minitab 界面中的上下文菜单上。 要将某个命令从上下文菜单删除,请单击该命令并将其拖出菜单。
  7. 单击关闭。

更改工具栏显示选项

您可以更改工具栏的工具提示和图标的显示方式。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击选项选项卡。
  3. 在选项选项卡上,执行以下操作之一:
    • 要显示工具栏的工具提示,请选择显示关于工具栏的屏幕提示。
    • 要在工具栏的工具提示中显示快捷键,请选择在屏幕提示中显示快捷键。
    • 要在工具栏按钮上显示大图标,请选择大图标。
  4. 单击关闭。

恢复默认设置

您可以恢复菜单、工具栏和快捷键的默认设置。

重置菜单

这些步骤重置所有菜单并删除所有的自定义菜单。在完成这些步骤之后,只有最初安装的 Minitab 中的菜单可见。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击菜单选项卡。
  3. 要重置所有的非上下文菜单、子菜单和命令(例如,文件菜单、编辑菜单、数据菜单等),请在应用程序框架菜单下,单击重置。
  4. 要重置上下文菜单,请选择上下文菜单并单击重置。
  5. 单击关闭。

重置工具栏

这些步骤重置非自定义工具栏的按钮和显示设置。这些步骤不影响自定义工具栏。这些步骤不影响哪些工具栏可见。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击工具栏选项卡。
  3. 要重置一个工具栏,请单击该工具栏,然后单击重置。
  4. 要重置所有的工具栏,请单击全部重置。
  5. 要删除某个自定义工具栏,请从工具栏列表选择该工具栏,并单击删除。
  6. 单击关闭。

重置快捷键

这些步骤删除新快捷键并将修改后的快捷键恢复为其最初的功能。

  1. 选择查看 > 自定义。
  2. 在自定义对话框中,单击键盘选项卡。
  3. 要重置已更改的所有键盘快捷键,请单击全部重置。
  4. 要重置一个键盘快捷键,请选择相应的命令,在当前键中单击,然后单击删除。
  5. 单击关闭。

重置按钮图像

这些步骤影响最初安装的 Minitab 中的按钮的图像。这些步骤不影响新的自定义按钮。

  1. 选择查看 > 自定义。
  2. 当自定义对话框处于打开状态时,右键单击 Minitab 界面中的菜单项或工具栏项,然后选择重置。
  3. 单击关闭。