工作表中的每一列都包含一个变量的数据。您可以按照各种方式自定义列。您可以为列命名、编写列的说明、更改字体、调整列的大小、隐藏未使用的列,等等。

插入列

  • 要插入一列,请在工作表中要插入列的位置单击,然后选择编辑器 > 插入列
  • 要插入多列,请在多个列(列数等于要插入的列数)中选择一个或多个单元格,然后选择编辑器 > 插入列
列将插入到所选列的左侧。

为列命名

要输入或更改列名,请在列名单元格(位于列号单元格下方)中单击,然后键入列名称。列名必须遵循以下规则:
  • 它不能大于 31 个字符。
  • 它不能以星号 (*) 开头。
  • 它不能包含 ' 或 # 符号。
  • 它与同一个工作表中的其他列不能同名。

输入列说明

带有说明的列在列名单元格的右上角中有一个红色三角形。

  • 要输入列说明,请在列中单击,然后选择编辑器 > 列属性 > 说明
  • 要查看列的说明,请将鼠标指针放在列名单元格右上角中的红色三角形上。
  • 要查看所有列的说明,请选择窗口 > Project Manager,然后单击文件夹。

移动列

要将列移动到工作表中的其他位置,请完成以下步骤。

  1. 选择一个或多个要移动的列,然后选择编辑器 > 移动列
  2. 选择以下选项之一:
    • 在 C1 列之前:将所选列放在 C1 列之前(将其他列向右推)。
    • 在使用中的最后一列之后:将所选列放在最后一个非空列之后。
    • 在列之前:将所选列放在您选择的列之前。
  3. 单击确定

将列复制到列

要将活动工作表中的列复制到指定工作表中的列,请完成以下步骤。

  1. 选择数据 > 复制 > 列到列
  2. 从列复制中,输入要复制的列。
  3. 将复制的数据存储在列中中,选择一个存储选项:
    • 在新工作表中:输入新工作表的名称(可选)。
    • 在以下工作表中,在最后使用的列之后:输入要将列复制到其中的已打开工作表的名称。
    • 在当前工作表中,在列中:输入一个或多个目标列。
  4. 要包括列名,选择命名包含复制数据的列
  5. 要指定想要在新列中包括或排除的行,单击划分数据子集并执行以下操作:
    1. 包括或不包括下,指定是要包括复制列中的行,还是要排除复制列中的行。
    2. 指定要包括的行/指定要排除的行中,选择以下选项之一:
      • 所有行/没有行:包括所有行或者不排除任何行。
      • 匹配的行:包括或排除与条件相匹配的行。单击条件可输入条件表达式。
      • 被刷行:包括或排除与图形上被刷点相对应的行。
      • 行号:包括或排除指定的行。输入单个行号和行号范围。使用冒号 (:) 表示包含范围。例如,输入 1 4 6:10 来表示集合 1、4、6、7、8、9、10。
  6. 在每个对话框中单击确定

更改列宽

可通过多种方式更改列宽。

手动更改一列或多列的宽度

  • 要调整列的大小,请将鼠标指针放在列号单元格的右边缘上。然后将双侧箭头拖动至所需的宽度。
  • 要同时调整多个相邻列的大小,请在每个列中选择一个或多个单元格,然后将鼠标指针放在任何列号单元格的右边缘上。将双侧箭头拖动至所需的宽度。当您松开鼠标按钮时,列的大小将改变。

设置活动工作表中所有列的宽度

  1. 在工作表中单击,然后选择编辑器 > 列属性 > 标准宽度
  2. 标准列宽中,输入要显示的字符数(介于 1 和 80 之间)。
  3. 要包括其宽度已手动更改的列,选择更改单独设置的宽度
  4. 单击确定

指定自动加宽或为所选列设置固定列宽

  1. 通过拖动选择所需的列,然后选择编辑器 > 列属性 > 宽度
  2. 选择以下选项之一:
    • 自动加宽:Minitab 根据列中数据的宽度和格式来确定列宽。
    • 固定宽度:输入您希望列达到的确切宽度(最多 80 个字符)。要隐藏列,输入 0
  3. 单击确定

更改 Minitab 的默认列宽

要更改所有新工作表的标准列宽,请完成以下步骤。

  1. 选择工具 > 选项 > 数据窗口 > 常规
  2. 列宽中,输入要显示的字符数(介于 1 和 80 之间)。
  3. 单击确定

隐藏和取消隐藏列

可通过多种方式隐藏或取消隐藏活动工作表中的列。

隐藏所选列

执行以下操作之一:

  • 在要隐藏的列中选择一个或多个单元格,然后选择编辑器 > 列属性 > 隐藏所选列
  • 将鼠标指针放在列号单元格的右边缘上,然后向左拖动双侧箭头,直到该列消失。

取消隐藏所选列

选择围绕隐藏列的两列,然后选择编辑器 > 列属性 > 取消隐藏所选列

隐藏/取消隐藏列

您可以管理工作表中所有列的显示方式。

提示

要显示或隐藏对话框中的隐藏列,选择编辑器 > 列属性 > 在对话框中使用隐藏列

  1. 在工作表中单击,然后选择编辑器 > 列属性 > 隐藏/取消隐藏列
  2. 在列表框中显示的列中,选择要隐藏或取消隐藏的列。
    • 所有列:显示工作表中包含数据的所有列(包括以前隐藏的列,以及介于数据列之间的任何空白列)。
    • 数据列:仅显示包含数据的列。
    • 空白列:仅显示包含数据的列之间的空白列。
  3. 使用箭头按钮在未隐藏的列隐藏的列之间移动列。
  4. 单击确定

对列排序

  • 要按所选列(如日期列)中的值对整个工作表排序,请在该列中单击,然后选择编辑器 > 排序列 > 整个工作表
  • 要按多列排序或仅按指定列排序,请选择编辑器 > 排序列 > 自定义排序
使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策