您可以直接在 Minitab 中打开 Minitab 文件、Microsoft Excel 文件和文本文件。Minitab 最多可导入 4000 个列。Minitab 可导入的单元格数目会受到可用内存地址空间的限制。

打开文件时,文件的内容将复制到项目中。因此,如果您更改项目中的数据或图形内容,则原始文件不会受到影响。

打开 Excel 文件(XLS、XLSX、XML)

如果 Excel 文件包含多个工作表,则可以单独控制每个工作表的导入。

  1. 选择文件 > 打开
  2. 浏览并选择所需的 Excel 文件。
  3. 单击打开
    打开 Excel 文件对话框显示第一个 Excel 表。每个表都具有自己的标签。
  4. 对于每个表,请执行下列步骤:
    • 如果 Excel 文件中包含多个表,并且您不需要导入表,则取消选择导入此表
    • 要导入的第一行要导入的最后一行中指定要导入的行范围。
    • 如果要导入的第一行数据中包含列名称,则选择数据具有列名称
    • 如果不需要导入列,则取消选中列复选框。
    • 要更改列数据类型,请从下拉列表(数字文本日期时间)中选择不同的数据类型。
    • 要查看 Minitab 工作表的预览,请单击预览 Minitab 工作表
  5. 单击选项为您打开的文件更改以下任何数据清理设置:
    • 在您的文件中哪些值代表缺失数据?Minitab 用 * 表示缺失数字值和日期/时间值,用空格表示缺失文本值。如果您的文件不遵循这些惯例,请为文件中的数字列文本列指定缺失值惯例。例如,如果您输入 999,Minitab 会将 999 的所有实例转换为缺失值符号 *。
    • 不要输入空白行:如果您不希望导入空行,则选择此选项。
    • 添加缺失值以使所有列中的行数相同:选择此选项可将缺失值添加到较短的列,使得所有列具有相同数量的行。
    • 去除不可打印的字符和多余的空格:选中此选项会删除文本列中的不可打印字符和额外空格。当您从外部源导入文本时,不可打印的字符可能会嵌入到文本中。将保留单词之间的单个空格。
    • 纠正案例不匹配问题:选中此选项会通过将第一个出现的文本值的大写应用于列中的所有匹配值,更正文本列中的字母大小写不匹配问题。此选项仅适用于列中的数据,而不适用于列名称。例如,如果列中的前三个值为 Red red RED,而且您选中此选项,则这三个值将以 Red Red Red 形式导入。
  6. 单击每个对话框中的确定
提示

要更改用于导入文件的默认设置,请选择工具 > 选项 > 打开

打开文本文件(CSV、TXT、DAT)

Minitab 可以打开纯文本(ANSI 或 Unicode)文件,它们通常具有 .txt(文本)、.dat(数据)或 .csv(逗号分隔值)扩展名。如果要使用的数据所在文件的扩展名不在下拉列表中,请尝试将数据另存为文本文件,然后导入它。大多数应用程序都可以创建文本文件。

  1. 选择文件 > 打开
  2. 浏览并选择所需的文本文件。
  3. 单击打开
    打开文本文件对话框中显示了文本文件的表示形式。
  4. 要导入的第一行要导入的最后一行中指定要导入的行范围。
  5. 如果要导入的第一行数据中包含列名称,则选择数据具有列名称
  6. 字段定界符中,选择用来分隔文本文件中值的字符。如果您选择自定义,请输入自定义字符。Minitab 会将两个连续分隔符解释为缺失数据。
  7. 文本识别符中,选择用来描述文本值的字符。只有当文本值包括嵌入式字段分隔符时,才有必要使用文本限定符。例如,如果字段分隔符是空格,文本值为 John Smith,则需要用文本限定符将文本值围起来。
  8. 小数分隔符中,选择用于分隔数值的整数部分和小数部分的字符。 默认情况下,Minitab 使用您计算机的区域设置中指定的分隔符。
  9. 如果不需要导入列,则取消选中列复选框。
  10. 要更改列的数据类型,请从下拉列表(数字文本日期时间)中选择不同的数据类型。
  11. 要查看 Minitab 工作表的预览,请单击预览 Minitab 工作表
  12. 单击选项为您打开的文件更改以下任何数据清理设置:
    • 在您的文件中哪些值代表缺失数据?Minitab 用 * 表示缺失数字值和日期/时间值,用空格表示缺失文本值。如果您的文件不遵循这些惯例,请为文件中的数字列文本列指定缺失值惯例。例如,如果您输入 999,Minitab 会将 999 的所有实例转换为缺失值符号 *。
    • 不要输入空白行:如果您不希望导入空行,则选择此选项。
    • 添加缺失值以使所有列中的行数相同:选择此选项可将缺失值添加到较短的列,使得所有列具有相同数量的行。
    • 去除不可打印的字符和多余的空格:选中此选项会删除文本列中的不可打印字符和额外空格。当您从外部源导入文本时,不可打印的字符可能会嵌入到文本中。将保留单词之间的单个空格。
    • 纠正案例不匹配问题:选中此选项会通过将第一个出现的文本值的大写应用于列中的所有匹配值,更正文本列中的字母大小写不匹配问题。此选项仅适用于列中的数据,而不适用于列名称。例如,如果列中的前三个值为 Red red RED,而且您选中此选项,则这三个值将以 Red Red Red 形式导入。
  13. 单击每个对话框中的确定
提示

要更改用于导入文件的默认设置,请选择工具 > 选项 > 打开

打开 Minitab 文件(MPJ、MTW、MGF)

要打开 Minitab 项目文件 (MPJ)、工作表文件 (MTW) 或图形文件 (MGF),请选择文件 > 打开,然后浏览并选择文件。

注意

要打开 Minitab 样本数据集,请选择帮助 > 样本数据

您可以打开在早期 Minitab 版本中创建的文件,如下所示:
  • Minitab 版本 15 及之前版本中的项目 (MPJ)
  • Minitab 版本 13 及之前版本中的工作表 (MTW)
  • Minitab 版本 14 及之前版本中的图形 (MGF)

要在您拥有的 Minitab 版本中打开在更高版本中创建的文件,必须用您拥有的版本的格式保存该文件。例如,如果您希望 Minitab 17 用户打开 Minitab 18 项目文件,请在 Minitab 18 中打开该项目并将该文件另存为 Minitab 17 项目。

打开 Minitab 项目中存储的工作表

要打开存储在 Minitab 项目中的工作表而不打开项目文件,请完成以下步骤。

  1. 选择文件 > 打开
  2. 从文件类型下拉列表中,选择Minitab Worksheets
  3. 浏览并选择项目文件 (MPJ),然后单击打开
  4. 选择一个或多个要打开的工作表。 可执行以下操作来详细了解工作表:
    • 单击预览以查看工作表在 Minitab 中的显示。
    • 如果工作表具有说明信息,请单击说明查看它。
  5. 单击确定
使用此网站,即表示您同意对数据分析和个性化内容使用 Cookie。  请阅读我们的政策