Gráfico de correlação

Esta macro produz um gráfico de correlação para avaliar a ortogonalidade de um experimento planejado. Os gráficos de correlação são usados tipicamente em filtragem de experimentos para avaliar a estrutura de alias, mas também podem ser usados para outros experimentos.

Download da macro

Certifique-se de que o Minitab sabe onde encontrar a macro baixada. Selecione Ferramentas > Opções > Geral. Em Local da macro navegue até o local em que você salva os arquivos de macro.

Importante

Se você usar um navegador mais antigo, quando clicar no botão Download, o arquivo pode abrir no Quicktime, que compartilha a extensão de arquivo .mac com macros do Minitab. Para salvar a macro, clique com o botão direito do mouse no botão Download e selecione Salvar arquivo como.

Entradas obrigatórias

Pelo menos duas colunas de dados que representem os fatores de um experimento planejado ou que representam colunas de preditores contínuos.

Entradas opcionais

SQUARES
Use para criar as correlações pareadas para um modelo que inclui os efeitos principais e os termos quadrados.
INTERACTS
Use para criar as correlações pareadas para um modelo que inclui os efeitos principais e as interações de 2 fatores.
FULL
Use para criar as correlações pareadas para um modelo que inclui os efeitos principais, as interações de 2 fatores e os termos quadrados.
EXPAND
Use para expandir a legenda de cores para mostrar correlações de -1 para 1 em vez dos valores absolutos das correlações de 0 para 1.
Observação

Use apenas uma das opções: SQUARES, INTERACTS ou FULL.

Execução da macro

Suponha que você tenha um experimento de 6 fatores e as colunas que representam os fatores estão em C5, C6, C7, C8, C9 e C10. Para criar um gráfico de correlação apenas para os efeitos principais, selecione Edit > Editor de Linha de Comando e digite:
%CORRPLOT C5-C10.

Clique em Enviar Comandos.

Para criar o gráfico de correlação que mostra as correlações para o modelo que contém os efeitos principais e os termos quadrados, selecione Editar > Editor de Linha de Comando e digite:
%CORRPLOT C5-C10;
SQUARES;
EXPAND.

Clique em Enviar Comandos.

Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política