Abrir o arquivo de texto

É possível abrir arquivos do Minitab, arquivos do Microsoft Excel e arquivos de texto diretamente no Minitab. O Minitab pode importar até 4000 colunas. O número de células que Minitab pode importar é limitado pelo seu espaço de endereço de memória disponível.

Quando você abre um arquivo, o conteúdo do arquivo é copiado para o projeto. Portanto, se você alterar os dados ou conteúdos de gráficos dentro de um projeto, o arquivo original não é afetado.

Abra um arquivo Excel (XLS, XLSX, XML)

Se o arquivo Excel contiver múltiplas planilhas, você pode controlar a importação de cada planilha separadamente.

  1. Selecione Arquivo > Abrir.
  2. Navegue para e selecione o arquivo Excel.
  3. Clique em Abrir.
    A caixa de diálogo Abrir arquivo Excel apresenta a primeira planilha do Excel. Cada planilha tem sua própria guia.
  4. Para cada planilha, siga estas etapas:
    • Se o arquivo Excel contiver mais de uma planilha e você não quiser importar uma delas, desmarque Importar esta planilha.
    • Especifique o intervalo de linhas a serem importadas em Primeira linha a ser importada e Última linha a ser importada.
    • Se a primeira linha de dados a serem importados contiver os nomes das colunas, selecione Dados com nomes de colunas.
    • Se você não deseja importar uma coluna, desmarque a caixa de seleção da coluna.
    • Para alterar o tipo de dados de uma coluna, selecione um tipo de dados diferente na lista suspensa (Numérico, Texto ou Data/Hora).
    • Para ver uma visualização da worksheet do Minitab, clique em Visualizar worksheet do Minitab.
  5. Clique em Opções para alterar qualquer uma das configurações de limpeza de dados a seguir para o arquivo que você está abrindo:
    • Quais valores representam dados faltantes em seu arquivo? O Minitab usa * para numéricos e valores de data/hora faltantes, e um espaço em branco para valores de texto faltantes. Se o arquivo não segue essas convenções, especifique as convenções de valor faltante para o Colunas numéricas e para o Colunas de texto no arquivo. Por exemplo, se você inserir 999, o Minitab converte todas as instâncias do 999 para o símbolo de valor faltante *.
    • Não importar linhas em branco: Selecione esta opção se não deseja importar linhas em branco.
    • Adicionar valores faltantes para deixar o número de linhas igual em todas as colunas: Selecione esta opção para adicionar os valores em falta às colunas mais curtas, para que todas as colunas tenham o mesmo número de linhas.
    • Remover caracteres não imprimíveis e espaços extra: Selecione esta opção para remover caracteres não imprimíveis e espaços extras de colunas de texto. Os caracteres não imprimíveis podem ser incorporados ao texto quando você importá-lo a partir de fontes externas. Os espaços simples entre as palavras serão mantidos.
    • Corrigir diferenças entre maiúsculas e minúsculas: Selecione esta opção para corrigir falta de correspondência entre maiúsculas e minúsculas em colunas de texto, aplicando o tipo da primeira ocorrência, se maiúscula ou minúscula, de um valor de texto a todos os valores correspondentes na coluna. Esta opção aplica-se apenas aos dados nas colunas, não aos nomes das colunas. Por exemplo, se os três primeiros valores de uma coluna são Red red RED, e você selecionar esta opção, os valores são importados como Red Red Red.
  6. Clique em OK em cada caixa de diálogo.
Dica

Para alterar as configurações padrão para a importação de arquivos, escolha Ferramentas > Opções > Abrir.

Abra um arquivo de texto (CSV, TXT, DAT)

O Minitab pode abrir arquivos de texto simples (ANSI ou Unicode), que têm uma extensão .txt (texto), .dat (dados) ou .csv (valores separados por vírgula). Se os dados que você deseja usar estiverem em um arquivo com uma extensão que não está na lista suspensa, tente salvar os dados como um arquivo de texto e, em seguida, importá-los. A maioria dos aplicativos pode criar arquivos de texto.

  1. Selecione Arquivo > Abrir.
  2. Navegue e selecione o arquivo de texto.
  3. Clique em Abrir.
    A caixa de diálogo Abrir arquivo de texto apresenta uma representação do arquivo de texto.
  4. Especifique o intervalo de linhas a serem importadas em Primeira linha a ser importada e Última linha a ser importada.
  5. Se a primeira linha de dados a serem importados contiver os nomes das colunas, selecione Dados com nomes de colunas.
  6. Em Delimitador de campo, selecione o caractere que separa os valores no arquivo de texto. Se você selecionar Personalizado, insira um caractere personalizado. O Minitab interpreta dois separadores consecutivos como dados faltantes.
  7. Em Qualificador de texto, selecione o caractere que delimita valores de texto. Os qualificadores de texto são necessários somente se o valor de texto incluir delimitadores de campo incorporados. Por exemplo, se o delimitador de campo for um espaço e o valor de texto for John Smith, o valor de texto precisa ser incluído em qualificadores de texto.
  8. Em Separador decimal, selecione o caractere que é usado para separar a parte inteira e parte decimal de um número. Por padrão, o Minitab usa o separador que é especificado nas definições regionais do computador.
  9. Se você não deseja importar uma coluna, desmarque a caixa de seleção da coluna.
  10. Para alterar o tipo de dados de uma coluna, selecione um tipo de dados diferente na lista suspensa (Numérico, Texto ou Data/Hora).
  11. Para ver uma visualização da worksheet do Minitab, clique em Visualizar worksheet do Minitab.
  12. Clique em Opções para alterar qualquer uma das configurações de limpeza de dados a seguir para o arquivo que você está abrindo:
    • Quais valores representam dados faltantes em seu arquivo? O Minitab usa * para numéricos e valores de data/hora faltantes, e um espaço em branco para valores de texto faltantes. Se o arquivo não segue essas convenções, especifique as convenções de valor faltante para o Colunas numéricas e para o Colunas de texto no arquivo. Por exemplo, se você inserir 999, o Minitab converte todas as instâncias do 999 para o símbolo de valor faltante *.
    • Não importar linhas em branco: Selecione esta opção se não deseja importar linhas em branco.
    • Adicionar valores faltantes para deixar o número de linhas igual em todas as colunas: Selecione esta opção para adicionar os valores em falta às colunas mais curtas, para que todas as colunas tenham o mesmo número de linhas.
    • Remover caracteres não imprimíveis e espaços extra: Selecione esta opção para remover caracteres não imprimíveis e espaços extras de colunas de texto. Os caracteres não imprimíveis podem ser incorporados ao texto quando você importá-lo a partir de fontes externas. Os espaços simples entre as palavras serão mantidos.
    • Corrigir diferenças entre maiúsculas e minúsculas: Selecione esta opção para corrigir falta de correspondência entre maiúsculas e minúsculas em colunas de texto, aplicando o tipo da primeira ocorrência, se maiúscula ou minúscula, de um valor de texto a todos os valores correspondentes na coluna. Esta opção aplica-se apenas aos dados nas colunas, não aos nomes das colunas. Por exemplo, se os três primeiros valores de uma coluna são Red red RED, e você selecionar esta opção, os valores são importados como Red Red Red.
  13. Clique em OK em cada caixa de diálogo.
Dica

Para alterar as configurações padrão para a importação de arquivos, escolha Ferramentas > Opções > Abrir.

Abra um arquivo Minitab (MPJ, MTW, MGF)

Para abrir um arquivo de projeto Minitab (MPJ), arquivo de worksheet (MTW), ou arquivo de gráfico (MGF), escolha Arquivo > Abrir e navegue e selecione o arquivo.

Observação

Para abrir um conjunto de dados de amostra do Minitab, selecione Ajuda > Dados da amostra.

Você pode abrir arquivos que foram criados em versões anteriores do Minitab como a seguir:
  • Projetos (MPJ) do Minitab Release 15 em diante
  • Worksheets (MTW) do Minitab Release 13 em diante
  • Gráficos (MGF) do Minitab Release 14 em diante

Para abrir um arquivo que foi criado em uma versão mais recente do Minitab do que a que você tem, salve o arquivo no formato da versão que você tem. Por exemplo, se você quiser que um usuário do Minitab 17 abra um arquivo de projeto do Minitab 18, abra o projeto no Minitab 18 e salve o arquivo como um projeto do Minitab 17.

Abra worksheets que são armazenados em um projeto do Minitab

Para abrir worksheets que estão armazenadas em um projeto do Minitab sem abrir o arquivo de projeto, conclua as etapas a seguir.

  1. Selecione Arquivo > Abrir.
  2. Na lista suspensa com tipos de arquivo, selecione Worksheets do Minitab.
  3. Navegue e selecione o arquivo de projeto (MPJ), em seguida, clique em Abrir.
  4. Selecione uma ou mais worksheets a serem abertas. Você pode fazer o seguinte para saber mais sobre uma worksheet:
    • Clique em Visualização para ver como a worksheet se parecerá no Minitab.
    • Se a worksheet tem uma descrição, clique em Descrição para visualizá-la.
  5. Clique em OK.
Ao usar esse site, você concorda com a utilização de cookies para análises e conteúdo personalizado.  Leia nossa política