このマクロを使用すると、計画された実験の直交性を評価する相関プロットが作成されます。相関プロットは、通常、スクリーニング計画で別名構造を評価するために使用しますが、他の計画に使用することもできます。

マクロをダウンロードする

ダウンロードしたマクロの場所をMinitabが見つけられるようにします。[ツール] > [オプション] > [一般]を選択し、[マクロの位置]でマクロファイルを保存する場所を参照します。[マクロの位置]でマクロファイルを保存する場所を参照します。

重要

古いWebブラウザを使用している場合、[ダウンロード]ボタンをクリックしたときに、Minitabマクロと同じ.mac拡張子を使用するQuicktimeでファイルが開く場合があります。マクロを保存するには、[ダウンロード]ボタンを右クリックして[対象をファイルに保存]を選択します。

必須入力項目

計画された実験からの因子または予測変数の連続する列を表す少なくとも2列のデータ

オプション入力

SQUARES
主効果および2次項を含むモデルのペアワイズ相関を作成するために使用します。
INTERACTS
主効果および二元相互作用を含むモデルのペアワイズ相関を作成するために使用します。
FULL
主効果、二元相互作用、2次項を含むモデルのペアワイズ相関を作成するために使用します。
EXPAND
色の凡例を拡張して、0~1の相関の絶対値ではなく、-1~1の相関を表示するために使用します。

SQUARES、INTERACTS、FULLのいずれか1つのみを使用します。

マクロの実行

6因子計画があり、因子を表す列がC5、C6、C7、C8、C9、C10であるとします。主効果の相関プロットのみを作成するには、[編集] > [コマンドラインエディタ]を選択し、次のコマンドを入力します。
%CORRPLOT C5-C10.

コマンドを発行するをクリックします。

主効果および2乗項を含むモデルの相関を示す相関プロットを作成するには、[編集] > [コマンドラインエディタ]を選択し、次のコマンドを入力します。
%CORRPLOT C5-C10;
SQUARES;
EXPAND.

コマンドを発行するをクリックします。

本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください