ワークシートの操作

ワークシートには、特定のデータセットに関連するすべてのデータが含まれます。ワークシートの説明を入力したり、ワークシート内を移動するためにショートカットキーを使用したり、定数を特定したりするなど、さまざまな操作が行えます。

ワークシートの記述を入力する

コメントが入力されているワークシートは、行番号の上のセルに赤い三角形が表示されます。

  1. ワークシート内をクリックし、エディタ > ワークシートのプロパティ > 説明またはファイル > 説明 > ワークシートを選択します。
  2. ワークシート情報を入力します。たとえば、コメントには、ワークシートの説明や、データの分析で使用したコマンドなどを入力できます。
  3. OKをクリックします。
  4. ワークシートの説明を見るには、次のいずれかを実行します。
    • 行番号の上のセルの、赤い三角形にカーソルを合わせます。
    • ウィンドウ > Project Managerを選択し、ワークシートのフォルダをクリックします。

ワークシートの名前を変更する

ワークシート名を変更するには、次のいずれかの方法を使用します。

  • タイトルバーのワークシート名の横にあるワークシートアイコンを右クリックして、ワークシートの名前を変更するを選択します。
  • Project Managerでワークシートフォルダを右クリックして、名前を変更するを選択します。
  • Project Managerでワークシートを選択し、F2キーを押します。
  • ワークシート内でクリックしてファイル > Save Worksheet Asを選択し、ワークシートの名前を入力します。
    ワークシートを事前に保存している場合は、元のファイルは変更されず、現在の変更は新しいファイルに保存されます。

ワークシート内を移動する

セルをクリックすると、そのセルはアクティブになります。また、エディタメニューやキーボードを使ってカーソルを移動し、他のセルをアクティブにすることもできます。

アクティブなワークシート内で移動する方法を以下の表で説明します。

位置 操作
特定のセル エディタ > 検索と置換 > ジャンプを選択します。
上下左右に1セル移動 矢印キーを押します。
下または右のセルに移動(データ入力方向矢印により異なる) Enterキーを押します。
次の行または列の最初にあるセル(データ入力方向矢印により異なる) エディタ > 検索と置換 > ジャンプ > 次の列またはエディタ > 検索と置換 > ジャンプ > アクティブセルを選択するか、Ctrl+Enterを押す。
データウィンドウに表示されている部分の一番端にあるセル Ctrlキーと矢印キーを押す。
ワークシートの先頭のセル Ctrl+Homeを押します。
ワークシート内の入力済み範囲で一番最後にあるセル Ctrl+Endを押す。
ブラシで選択された次・前の行(グラフでブラシを使用した場合) エディタ > 検索と置換 > ジャンプ > ブラシで選択された次の行またはエディタ > 検索と置換 > ジャンプ > ブラシで選択された1つ前の行を選択する。
次・前のフォーマットされたセル(フォーマットした場合) エディタ > 検索と置換 > ジャンプ > 次のフォーマットされたセルまたはエディタ > 検索と置換 > ジャンプ > 前のフォーマットされたセルを選択する。

現在のワークシートのデータ入力方向を変更する

データ入力方向は、ワークシートの左上隅にある矢印によって決まります。この矢印の方向によって、HomeキーとEndキーの動作も決まります。

矢印の方向 操作
Enterキーを押すと、アクティブなセルが下に移動します。
Enterキーを押すと、アクティブなセルが右に移動します。

方向を変更するには、矢印をクリックするか、ワークシート内をクリックしてエディタ > ワークシートのプロパティ > 入力方向を変更するを選択します。

すべての新規ワークシートのデフォルトのデータ入力方向を変更する

デフォルトでは、データ入力方向は下向きの列方向です。新規のワークシートに適用されるデフォルトの入力方向を行方向に変更するには、次の手順を実行します。

  1. ツール > オプション > データウィンドウ > 一般を選択します。
  2. 入力方向から、Enterで列間を移動するを選択します。
  3. OKをクリックします。

ワークシートをコピーする

アクティブなワークシートの内容をすべて、別のワークシートにコピーするには、次の手順を実行します。

  1. コピーするワークシートのタイトルバーをクリックし、ウィンドウをアクティブにします。
  2. データ > コピー > ワークシートからワークシートにを選択します。
  3. コピーされたデータを保存から、新しいワークシートを作成するか、既存のワークシートを使用するかを選択します。
  4. 列、定数、行列の内容と一緒に名前もコピーする場合は、コピーされた列、定数、および行列に名前を付けるを選択します。
  5. OKをクリックします。

ワークシートのテキストサイズを変更する

ワークシートでテキストのサイズを拡大または縮小する場合は、次のいずれかを実行します。

  • ワークシートがアクティブな状態で、Ctrlキーを押しながらマウスをスクロールする。
  • 開いているワークシートと新しいワークシートのデフォルトのテキストサイズを変更するには、ツール > オプション > データウィンドウ > データフォントを選択します。
  • 開いているワークシートと新しいワークシートの列番号、行番号、列名のデフォルトのテキストサイズを変更するには、ツール > オプション > データウィンドウ > ラベルフォントを選択します。
テキストサイズの調整が終わったら、必要に応じて列の幅を調整します。次のいずれかを実行します。
  • 新しいワークシートのデフォルトの列幅を変更するには、ツール > オプション > データウィンドウ > 一般を選択します。
  • 選択した列の幅を変更するには、エディタ > 列プロパティ > を選択する。

保存された定数を定義する

保存された定数は、ワークシートと保存されている単一の数値またはテキスト値です。保存された定数は計算式や計算、セッションコマンド、マクロ、Execファイルに使用することができます。保存された定数にはすべて、Kで始まる独自のID(K1、K2など)が振られていますが、名前をつけることもできます(K1を「調整」、K2を「目標」など)。

文字列に対応しているダイアログボックスのコントロールでは、保存された定数は認識されません。たとえば、K1に文字列「散布図」と記載されていて、グラフ > 散布図のラベルオプションでタイトルK1と入力した場合、グラフのタイトルは「K1」となります。

次の手順を実行して、保存された定数を定義します。

  1. 計算 > 計算機を選択します。
  2. 結果の保存場所に、保存された定数名(K1など)を入力します。
  3. に、定数の値を入力します。テキスト値は、二重引用符で囲みます("Green"など)。
  4. OKをクリックします。

保存された定数は、ワークシートに表示されません。セッションウィンドウに保存された定数を表示するには、データ > データの表示を選択します。

定数を列にコピー

次の手順を実行して、保存された定数のデータを現在のワークシートの新しい列にコピーします。

  1. データ > コピー > 定数から列にを選択します。
  2. 定数からコピーに、コピーする保存された定数を入力します(K1 K2 K3など)。
  3. 現在のワークシートで、列で:に目標列を入力します。
  4. OKをクリックします。

定数を定数にコピー

次の手順を実行して、保存された定数のデータを、新しく保存された定数にコピーします。

  1. データ > コピー > 定数から定数にを選択します。
  2. 定数からコピーに、コピーする保存された定数を入力します(K1 K2 K3など)。
  3. コピーされたデータを定数に保存から、保存場所を選択します。
    • 新規ワークシートで:定数のコピー先となる新しいワークシートの名前を入力できます。
    • 次のワークシートで、最後に使用した定数の後に:定数のコピー先となる、開かれているワークシートの名前を入力します。
    • 現在のワークシートで、定数で:コピー先の定数を入力します。
  4. OKをクリックします。

列を定数にコピー

次の手順を実行して、列のデータを保存された定数にコピーします。

  1. データ > コピー > 列から定数にを選択します。
  2. 列からコピーに、コピーする列を入力します。
  3. 現在のワークシートで、定数で:に、目的の定数を入力します(K1 K2 K3など)。 入力する定数の数は、列に含まれる値の数と等しくする必要があります。たとえば、列に含まれる値の数が20個の場合は、入力する定数も20個でなければなりません。範囲はハイフンで表記します。たとえば、K1-K20のように入力します。
  4. 定数の名前を含めるには、コピーされたデータを含む定数に名前を付けるを選択します。
  5. 含めるまたは除外する行を指定するには、データをサブセット化をクリックし、次の手順を実行します。
    1. 包含または除外で、コピーした列に行を含めるか除外するかを指定します。
    2. 含める行を指定/除外する行を指定から次のいずれかを選択します。
      • すべての行/行なし:全ての行を含める、またはどの行も除外しません。
      • 一致する行:条件に一致する行を含めるか除外します。条件をクリックして条件式を入力します。
      • ブラシで選択された行:グラフ上のブラシで選択された点に対応する行を含めるか除外します。
      • 行番号:指定した行を含めるか除外します。個々の行番号や行番号の範囲を入力します。行範囲の指定には、コロン(:)を使います。たとえば、1 4 6:10と入力すると、1、4、6、7、8、9、10を指定したことになります。
  6. 各ダイアログボックスでOKをクリックします。
本サイトを使用すると、分析およびコンテンツのカスタマイズのためにクッキーが使用されることに同意したことになります。  当社のプライバシーポリシーをご確認ください