Graphique de corrélation

Cette macro crée un graphique de corrélation permettant d'évaluer l'orthogonalité d'un plan d'expériences. Les graphiques de corrélation sont généralement utilisés dans les expériences de criblage destinées à évaluer la structure des alias, mais ils peuvent être utilisés dans d'autres types de plans.

Télécharger la macro

Assurez-vous que Minitab connaît l'emplacement de la macro que vous avez téléchargée. Sélectionnez Outils > Options > Général. Sous Emplacement de la macro, accédez à l'emplacement où vous avez enregistré les fichiers de macro.

Important

Si vous utilisez un ancien navigateur Web, lorsque vous cliquez sur le bouton Télécharger, il est possible que le fichier s'ouvre dans Quicktime, qui partage l'extension de fichier .mac avec les macros de Minitab. Pour enregistrer la macro, cliquez avec le bouton droit de la souris sur le bouton Télécharger, puis sélectionnez Enregistrer la cible sous.

Entrées requises

Au moins deux colonnes de données représentant les facteurs d'un plan d'expériences ou des prédicteurs continus.

Entrées facultatives

SQUARES
Utilisez cette commande pour créer les corrélations deux à deux dans un modèle incluant les effets principaux et les termes quadratiques.
INTERACTS
Utilisez cette commande pour créer les corrélations deux à deux dans un modèle incluant les effets principaux et les interactions à deux facteurs.
FULL
Utilisez cette commande pour créer les corrélations deux à deux dans un modèle incluant les effets principaux, les interactions à deux facteurs et les termes quadratiques.
EXPAND
Utilisez cette commande pour élargir la légende en couleur de manière à présenter les corrélations de -1 à 1 au lieu d'utiliser leur valeur absolue, de 0 à 1.
Remarque

N'utilisez qu'une seule des commandes SQUARES, INTERACTS et FULL.

Exécution de la macro

Supposons que vous ayez un plan à six facteurs et que les colonnes représentant ces facteurs soient C5, C6, C7, C8, C9 et C10. Pour créer une graphique de corrélation uniquement pour les effets principaux, sélectionnez Edition > Editeur de ligne de commande et entrez :
%CORRPLOT C5-C10.

Cliquez sur Soumettre les commandes.

Pour créer le graphique de corrélation du modèle incluant les effets principaux et les termes quadratiques, sélectionnez Edition > Editeur de ligne de commande et entrez :
%CORRPLOT C5-C10;
SQUARES;
EXPAND.

Cliquez sur Soumettre les commandes.

En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique