Cette macro calcule les percentiles spécifiés par l'utilisateur pour une colonne de données. Vous pouvez aussi utiliser une variable de répartition pour calculer les percentiles de groupes.

Cette fonctionnalité est partiellement disponible dans Minitab 16. Sélectionnez Calc > Calculatrice et la fonction Percentiles pour calculer les percentiles d'une colonne toute entière.

Télécharger la macro

Assurez-vous que Minitab connaît l'emplacement de la macro que vous avez téléchargée. Sélectionnez Outils > Options > Général. Sous Emplacement de la macro, accédez à l'emplacement où vous avez enregistré les fichiers de macro.

Important

Si vous utilisez un ancien navigateur Web, lorsque vous cliquez sur le bouton Télécharger, il est possible que le fichier s'ouvre dans Quicktime, qui partage l'extension de fichier .mac avec les macros de Minitab. Pour enregistrer la macro, cliquez avec le bouton droit de la souris sur le bouton Télécharger, puis sélectionnez Enregistrer la cible sous.

Entrées requises

  • Une colonne de données numériques. Vous pouvez également indiquer une colonne de valeurs de regroupement pour calculer les percentiles de chaque niveau de groupe.
  • Une colonne de pourcentages ou une valeur de pourcentage constante
  • Une colonne vide où stocker les résultats

Exécution de la macro

Supposons que les données se trouvent en C1, les pourcentages en C2 et que vous souhaitez que les percentiles soient stockés en C10. Pour exécuter la macro, sélectionnez Edition > Editeur de ligne de commande et saisissez :

%PERCENTILE C1 C2 C10

Cliquez sur Soumettre les commandes.

Remarque

Pour spécifier une valeur de pourcentage constante, saisissez simplement cette valeur à la place d'une colonne.

Supposons que les données se trouvent en C1, que la colonne de pourcentages est stockée en C2 et que la variable de répartition (ou variable de regroupement) se trouve en C3. Etant donné que la variable de regroupement a trois niveaux, vous devez spécifier trois colonnes pour stocker les percentiles, par exemple C10, C11 et C12. Pour exécuter la macro, sélectionnez Edition > Editeur de ligne de commande et saisissez :

%PERCENTILE C1 C2 C10-C12;
BY C3.

Cliquez sur Soumettre les commandes.

En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique