Répéter une analyse

Généralités

Lorsque vous utilisez une commande de menu dans Minitab, l'outil conserve les commandes de session qui enregistrent vos actions. Vous pouvez utiliser ces commandes de session pour répéter rapidement une analyse sur un nouvel ensemble de données.

A chaque commande de menu correspond une commande de session. Les commandes de session se composent d'une commande principale et, généralement, d'une ou de plusieurs sous-commandes. Les commandes principales et les sous-commandes peuvent être suivies d'une série d'arguments qui peuvent être des colonnes, des constantes, des matrices, des chaînes de texte ou des chiffres. Vous pouvez utiliser les commandes de session de trois façons dans Minitab :
  • En saisissant les commandes de session dans la fenêtre Session ou dans l'Editeur de ligne de commande
  • En copiant les commandes de session du dossier Historique vers l'Editeur de ligne de commande
  • En copiant et en enregistrant les commandes de session dans un fichier exécutable

Lorsque vous affichez les lignes de commande et que vous exécutez une commande de menu, les commandes de session correspondantes sont affichées dans le volet Ligne de commande de la fenêtre Session. Il s'agit d'un moyen pratique pour apprendre les commandes de session.

La centrale d'expédition Ouest recueille et analyse en continu les délais de livraison lorsque de nouvelles données sont disponibles. Au chapitre Evaluation de la qualité, vous avez réalisé une analyse de capabilité à partir des données du mois de mars. Dans ce chapitre, vous allez utiliser les commandes de session pour réaliser une analyse de capabilité sur les données du mois d'avril.

Activer et saisir des commandes de session

L'une des façons d'utiliser les commandes de session est de les saisir dans le volet Ligne de commande de la fenêtre Session. Minitab n'affiche pas ce volet par défaut, vous devez l'activer.

Activation des commandes de session

  1. Si vous n'avez pas fermé Minitab depuis le chapitre précédent, sélectionnez Fichier > Nouveau > Projet. Sinon, démarrez Minitab.
  2. Ouvrez le fichier de données échantillons, CommandesSession.MTW.
  3. Cliquez sur la fenêtre Session pour l'activer.
  4. Sélectionnez Editeur > Afficher la ligne de commande.

    L'invite MTB> est affichée dans le volet Ligne de commande de la fenêtre Session.

  5. (Facultatif) Activez les commandes de session par défaut pour toutes les sessions Minitab.
    1. Sélectionnez Outils > Options. Développez Fenêtre Session, puis sélectionnez Soumission de commandes.
    2. Sous Ligne de commande, cliquez sur Afficher.

Effectuer une analyse à l'aide des commandes de session

Au chapitre Evaluation de la qualité, vous avez effectué une analyse de capabilité pour déterminer si les délais de livraison respectaient les spécifications énoncées (moins de 6 jours). Pour cela, vous avez utilisé la commande Stat > Outils de la qualité > Analyse de capabilité > Normale. Vous avez ensuite rempli la colonne de données, la colonne de sous-groupe et indiqué la limite de spécification supérieure.

Pour continuer à évaluer les délais de livraison de la centrale d'expédition Ouest, vous prévoyez de répéter cette analyse régulièrement. Lorsque vous disposez de nouvelles données, vous pouvez répéter cette analyse à l'aide de quelques commandes de session.

  1. Dans le volet Ligne de commande, à l'invite MTB >, entrez CAPABILITY 'Jours' 'Date'; Le point-virgule indique que vous souhaitez entrer une sous-commande.
  2. Appuyez sur Entrée. Vous remarquerez que MTB > devient SUBC>. Utilisez l'invite SUBC> pour ajouter des sous-commandes pour les options utilisées lors de l'analyse de capabilité précédente.
  3. A l'invite SUBC>, saisissez USPEC 6. Le point indique la fin d'une séquence de commandes.
  4. Appuyez sur Entrée.
Analyse de capabilité pour les données d'expédition du mois d'avril
Conseil

Pour ouvrir un fichier PDF regroupant les commandes de session de Minitab, à l'invite de commande, entrez Aide.

Ré-exécution d'une série de commandes

Minitab génère des commandes de session pour la plupart des commandes de menu et les stocke dans le dossier Historique. Vous pouvez ré-exécuter ces commandes en les sélectionnant et en choisissant Edition > Editeur de ligne de commande.

Ré-exécutez l'analyse de capabilité à l'aide du dossier Historique et de l'Editeur de ligne de commande.

  1. Sélectionnez Fenêtre > Project Manager.
  2. Cliquez sur le dossier Historique.
  3. Cliquez sur CAPABILITY 'Jours' 'Date';, maintenez la touche Maj enfoncée et cliquez sur USPEC 6.
  4. Sélectionnez Edition > Editeur de ligne de commande.
  5. Cliquez sur Soumettre les commandes.
Analyse de capabilité pour les données d'expédition du mois d'avril

Vous venez de recréer l'analyse de capabilité en quelques étapes simples seulement.

Répétition d'analyses avec des fichiers exécutables

Un fichier exécutable est un fichier texte qui contient une série de commandes Minitab. Pour répéter une analyse sans utiliser les commandes de menu ni les commandes de session, vous pouvez enregistrer les commandes sous la forme d'un fichier exécutable, puis exécutez ce fichier.

Conseil

Pour plus d'informations sur les fichiers exécutables et autres macros plus complexes, ouvrez Aide sur les macros Minitab.

Création d'un fichier exécutable à partir du dossier Historique

Enregistrez les commandes de session de l'analyse de capabilité sous la forme d'un fichier exécutable.

  1. Sélectionnez Fenêtre > Project Manager.
  2. Cliquez sur le dossier Historique.
  3. Cliquez sur CAPABILITY 'Jours' 'Date';, appuyez sur la touche Maj, puis cliquez sur USPEC 6.
  4. Cliquez avec le bouton droit de la souris sur le texte sélectionné, puis choisissez Enregistrer sous.
  5. Accédez au dossier dans lequel vous souhaitez enregistrer vos fichiers.
  6. Dans la zone Nom de fichier, saisissez GraphiquesExpéd.
  7. Dans la fonction Type de fichier, sélectionnez Exécutable (*.mtb). Cliquez sur Enregistrer.

Ré-exécution de commandes

Vous pouvez répéter cette analyse en exécutant le fichier exécutable.

  1. Sélectionnez Outils > Lancer un exécutable.
  2. Cliquez sur Sélectionner un fichier.
  3. Sélectionnez le fichier GraphiquesExpéd.MTB, puis cliquez sur Ouvrir.
Analyse de capabilité pour les données d'expédition du mois d'avril

Minitab exécute les commandes du fichier exécutable pour générer l'analyse de capabilité.

Vous pouvez lancer un fichier exécutable à l'aide de n'importe quelle feuille de travail, si les noms de colonne correspondent. Vous pouvez ainsi partager un fichier exécutable avec d'autres utilisateurs Minitab devant effectuer la même analyse. Par exemple, il peut être intéressant pour le directeur de la centrale d'expédition Ouest de partager le fichier GraphiquesExpéd.MTB avec les directeurs des autres centrales, afin qu'ils puissent réaliser la même analyse avec leurs propres données. Si vous souhaitez utiliser un fichier exécutable avec une autre feuille de travail ou des colonnes différentes, modifiez le fichier exécutable à l'aide d'un éditeur de texte tel que le Bloc-notes.

Enregistrement du projet

Enregistrez tout votre travail dans un projet Minitab.

  1. Sélectionnez Fichier > Enregistrer le projet sous.
  2. Accédez au dossier dans lequel vous souhaitez enregistrer vos fichiers.
  3. Dans la zone Nom de fichier, saisissez MesCommandesSession.
  4. Cliquez sur Enregistrer.

Dans le chapitre suivant

Vous avez appris à utiliser les commandes de session à la place des commandes de menu, et pour répéter rapidement une analyse. Dans le chapitre suivant, vous allez créer un rapport pour présenter les résultats de vos analyses à vos collègues.

En utilisant ce site, vous acceptez l'utilisation de cookies à des fins d'analyse et de personnalisation du contenu.  Lisez notre politique