Gráfica de correlación

Esta macro produce una gráfica de correlación para evaluar la ortogonalidad de un experimento diseñado. Las gráficas de correlación generalmente se usan para experimentos de cribado para evaluar la estructura de alias, pero también se pueden usar para otros diseños.

Descargar la macro

Asegúrese de que Minitab sepa dónde buscar la macro descargada. Elija Herramientas > Opciones > General. En Ubicación de la macro, navegue hasta la ubicación donde guarda los archivos de macro.

Important

Si utiliza un explorador web más antiguo, cuando haga clic en el botón Descargar, el archivo podría abrirse en Quicktime, que comparte la extensión de archivos .mac con las macros de Minitab. Para guardar la macro, haga clic con el botón derecho en el botón Descargar y elija Guardar destino como.

Entradas requeridas

Por lo menos 2 columnas de datos que representen los factores de un experimento diseñado o que representen columnas de predictores continuos.

Entradas opcionales

SQUARES
Utilice para crear las correlaciones en parejas para un modelo que incluye los efectos principales y los términos cuadrados.
INTERACTS
Utilice para crear las correlaciones en parejas para un modelo que incluya los efectos principales y las interacciones de 2 factores.
FULL
Utilice para crear las correlaciones en parejas para un modelo que incluya los efectos principales, las interacciones de 2 factores y los términos cuadrados.
EXPAND
Utilice para expandir la leyenda de colores para mostrar correlaciones de -1 a 1, en lugar de los valores absolutos de las correlaciones de 0 a 1.
Nota

Utilice solo uno de SQUARES, INTERACTS o FULL.

Ejecución de la macro

Supongamos que usted tiene un diseño de 6 factores y las columnas que representan los factores se encuentran en C5, C6, C7, C8, C9 y C10. Para crear una gráfica de correlación solo para los efectos principales, elija Editar > Editor de línea de comandos y escriba:
%CORRPLOT C5-C10.

Haga clic en Enviar comandos.

Para crear la gráfica de correlación que muestra las correlaciones del modelo que contiene los efectos principales y los términos cuadrados, elija Editar > Editor de línea de comandos y escriba:
%CORRPLOT C5-C10;
SQUARES;
EXPAND.

Haga clic en Enviar comandos.

Al utilizar este sitio, usted acepta el uso de cookies para efectos de análisis y contenido personalizado.  Leer nuestra política