Create a custom menu

You can create a new menu for a special task or project. For example, create a menu of tools for monthly reports.

  1. Choose View > Customize.
  2. On the Commands tab, from the Categories list , select New Menu, then from the Commands list, select New Menu.
  3. While the Customize dialog box is open, drag New Menu to where you want it to appear in the Minitab interface. When the insertion point appears, release the mouse button.
  4. From the new menu's location in the Minitab interface, right-click New Menu and choose Name Button. Enter a name for your custom menu, for example, Monthly Report Tools, and click OK.
  5. Add commands to your custom menu.
    1. In the Customize dialog box, click the Commands tab.
    2. On the Commands tab, from the Categories list, select a category, then from the Commands list, select the command to add.
    3. While the Customize dialog box is open, drag the selected command to your custom menu in the Minitab interface.
  6. Repeat step 5 until you add all the commands that you want to add to your custom menu.
  7. Click Close.

Create a custom toolbar

You can create a new toolbar for a special task or project. For example, create a toolbar of frequently used analyses where the names of the commands that you added are shown.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Toolbars tab.
  3. On the Toolbars tab, click the New button.
  4. Enter a toolbar name, for example, My Tools, and click OK. Your custom toolbar is created in the center of your primary monitor.
  5. While the Customize dialog box is open, drag your custom toolbar to where you want it to appear in the Minitab interface, and when the insertion point appears, release the mouse button. The toolbar indicator appears to show the location of your custom toolbar.
  6. Add commands to your custom toolbar.
    1. In the Customize dialog box, click the Commands tab.
    2. On the Commands tab, from the Categories list , select a category, then from the Commands list, select the command to add.
    3. While the Customize dialog box is open, drag the selected command to your custom toolbar in the Minitab interface, and when the insertion point appears, release the mouse button.
  7. Repeat step 5 until you add all the commands that you want to add to your custom toolbar.
  8. Click Close.

Display the names of commands on a toolbar

You can show names for all the buttons on a toolbar or show the name for only one button.

Display names for all buttons

The following steps show how to display the names for all the buttons on a toolbar.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Toolbars tab.
  3. From the Toolbars list, select the name of a toolbar that is already shown in the Minitab interface, that is, the toolbar name should be checked and highlighted.
  4. Select Show text labels. The names for all the buttons on the selected toolbar are displayed.

Display the name for one button

The following steps show how to display the name for only one button on a toolbar.

  1. Choose View > Customize.
  2. While the Customize dialog box is open, right-click the button on the toolbar in the Minitab interface and choose either of the following options:
    • Choose Text to show only the name of the selected button.
    • Choose Image and Text to show the image and the name of the selected button.

Change the image on a toolbar button

You can change the image on a toolbar button.

  1. Choose View > Customize.
  2. While the Customize dialog box is open, complete any of the following tasks:
    • To copy an image from one button to a different button, right-click the button to copy and choose Copy Button Image, then right-click the button to change and choose Paste Button Image.
    • To edit the image on an existing button, right-click the button and choose Edit Button Image, use the color palette and the editing tools to edit the button image, then click OK.
    • To display the button name instead of the image, right-click the button and choose Text. To display both button name and image, right-click the button and choose Image and Text.
  3. Click Close.

Move or remove a command from a menu or toolbar

You can move commands to a different location on a menu or toolbar. You can also remove any unused commands.

  1. Choose View > Customize.
  2. While the Customize dialog box is open, open the Minitab menu or show the Minitab toolbar to customize, then do either of the following tasks:
    • To move a command to a different location on the menu or the toolbar, drag the command to its new location.
    • To remove a command, drag the command off of the menu or the toolbar.
  3. Click Close.

Create a custom command

You can create a custom command, for example, to open a different application or a website, or to run a Minitab macro.

To create a new command, you must first create it on the Tools tab, then from the Commands tab, you can move the new command to an existing menu or toolbar.

Create a command to open a different application or a website

You can create a custom command to open Companion, a different Minitab product.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Tools tab.
  3. On the Tools tab, click the New (Insert) button .
  4. Enter a name, such as Companion.
  5. Enter the information for the command:
    • In Command, enter the path or browse to the external application or web address for the tool (for example: C:\Program Files (x86)\Minitab\Companion\Companion\Companion.exe).
    • If necessary, in Arguments, enter an argument to pass to the application that you are adding the link for, such as a specific file to be opened automatically by the application.
    • If necessary, in Initial Directory, create an initial save folder for the application for which you are adding the link.
  6. Click Close.
  7. Choose View > Customize to open the Customize dialog box again.
  8. On the Commands tab, under Categories, select Tools.
  9. While the Customize dialog box is open, drag the new command to where you want it to appear on the Minitab menu or toolbar.
  10. Click Close.

Create a command to run a Minitab macro or an Exec file

If you frequently use a Minitab macro or an Exec file, for example, to update data from a database, you can create a command to run the macro or the Exec file.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Tools tab.
  3. On the Tools tab, click the New (Insert) button .
  4. Type a name for the command, then press the Enter key.
  5. Click the Open button .
  6. From the file type drop-down list, select All (*.*).
  7. Browse to and select the macro or the Exec file.
  8. If the macro requires user's input when it is run, specify the arguments that are required by the macro by entering columns, constants, or matrices after Arguments.
    Note

    You can specify only one set of arguments. If you want the macro to run with a different set of arguments, you must either modify the arguments for the shortcut or create a different shortcut with the other arguments.

    For example, suppose you run a macro one time, and specify the 95th percentile as an argument, for example, C1 95 C10. Then, you run the macro again, and specify the 90th percentile, for example, C1 90 C11. Instead, you could create one shortcut named 95th Percentile using 95 as an argument, and another shortcut named 90th percentile using 90 as an argument.

  9. Click Close.
  10. Choose View > Customize to open the Customize dialog box again.
  11. On the Commands tab, under Categories, select Tools.
  12. While the Customize dialog box is open, drag the new command to where you want it to appear on the Minitab menu or toolbar.
  13. Click Close.

Add a keyboard shortcut for a command

Add shortcut keys to save time executing the commands that you use most often. For example, create a keyboard shortcut to open the 2-Sample t dialog box.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Keyboard tab.
  3. On the Keyboard tab, from Category, select the category that the command belongs to, for example, Stat.
  4. Under Commands, select a command, for example, 2-Sample t...[Basic Statistics].
  5. Click in the Press New Shortcut Key field, then press the keyboard shortcut, for example, Ctrl+B.
    If the keyboard shortcut is already assigned, Minitab displays a message.
  6. Click Assign and close the window.

Edit a context menu

Context menus are menus that are active only when a specific component, such as a graph, a table, or a worksheet, is active. Most context menus are right-click menus. For example, when you right-click a graph, you see the Graph View context menu.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Menu tab.
  3. On the Menu tab, under Context Menus, from Select context menu, select the context menu that you want to edit.
  4. Click the Commands tab.
  5. On the Commands tab, from the Categories list, select a category, then from the Commands list, select the command to add.
  6. While the Customize dialog box is open, drag the selected command to the context menu in the Minitab interface. To remove a command from the context menu, click it and drag it off the menu.
  7. Click Close.

Change toolbar display options

You can change how tooltips and icons for toolbars are displayed.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Options tab.
  3. On the Options tab, do any of the following:
    • To display tooltips for toolbars, select Show ScreenTips on toolbars.
    • To show shortcut keys in tooltips for toolbars, select Show shortcut keys in ScreenTips.
    • To display large icons on toolbar buttons, select Large Icons.
  4. Click Close.

Restore the default settings

You can restore the default settings for menus, toolbars, and shortcut keys.

Reset a menu

These steps reset all the menus and remove any custom menus. After you complete these steps, only the menus in the original installation of Minitab are visible.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Menu tab.
  3. To reset all the non-context menus, submenus, and commands—for example, the File menu, Edit menu, Data menu and so on—under Application Frame Menus, click Reset.
  4. To reset a context menu, select the context menu and click Reset.
  5. Click Close.

Reset a toolbar

These steps reset the buttons and display settings for non-custom toolbars. These steps do not affect custom toolbars. These steps do not affect which toolbars are visible.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Toolbars tab.
  3. To reset one toolbar, click the toolbar, then click Reset.
  4. To reset all the toolbars, click Reset All.
  5. To remove a custom toolbar, select it from the Toolbars list and click Delete.
  6. Click Close.

Reset shortcut a key

These steps remove new shortcut keys and restore modified shortcut keys to their original function.

  1. Choose View > Customize.
  2. In the Customize dialog box, click the Keyboard tab.
  3. To reset all the keyboard shortcuts that you changed, click Reset All.
  4. To reset one keyboard shortcut, select the command, click in Current Keys, and then click Remove.
  5. Click Close.

Reset a button image

These steps affect images for buttons that are in the original installation of Minitab. These steps do not affect new custom buttons.

  1. Choose View > Customize.
  2. While the Customize dialog box is open, right-click a menu item or a toolbar item in the Minitab interface and select Reset.
  3. Click Close.
By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy