This macro produces a correlation plot for evaluating the orthogonality of a designed experiment. Correlation plots are typically used for screening experiments to evaluate the alias structure, but can also be used for other designs.

Download the Macro

Be sure that Minitab knows where to find your downloaded macro. Choose Tools > Options > General. Under Macro location browse to the location where you save macro files.

Important

If you use an older web browser, when you click the Download button, the file may open in Quicktime, which shares the .mac file extension with Minitab macros. To save the macro, right-click the Download button and choose Save target as.

Required inputs

At least 2 columns of data that represent the factors from a designed experiment or that represent continuous predictor columns.

Optional inputs

SQUARES
Use to create the pairwise correlations for a model that includes the main effects and the squared terms.
INTERACTS
Use to create the pairwise correlations for a model that includes the main effects and the 2-way interactions.
FULL
Use to create the pairwise correlations for a model that includes the main effects, the 2-way interactions, and the squared terms.
EXPAND
Use to expand the color legend to show correlations from -1 to 1 instead of the absolute values of the correlations from 0 to 1.
Note

Use only one of SQUARES, INTERACTS, or FULL.

Running the macro

Suppose you have a 6-factor design and the columns that represent the factors are in C5, C6, C7, C8, C9, and C10. To create a correlation plot for the main effects only, choose Edit > Command Line Editor and type:
%CORRPLOT C5-C10.

Click Submit Commands.

To create the correlation plot that shows the correlations for the model that contains the main effects and the squared terms, choose Edit > Command Line Editor and type:
%CORRPLOT C5-C10;
SQUARES;
EXPAND.

Click Submit Commands.

By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy