Create a custom command

You can create a custom command, for example, to run a Minitab macro, to open a different application, or to access a website.

For example, you can add a custom command to the Minitab Tools menu to open Quality Companion, a different Minitab product.

To create a new command, you must first create it for the Tools menu. Then, you can move the command from the Tools menu to a different menu or to a toolbar.

  1. Choose Tools > Customize.
  2. On the Tools tab, click the New (Insert) button .
  3. Enter a name, such as Quality Companion.
  4. Enter the information for the command:
    • In Command, enter the path or browse to the external application or web address for the tool (for example: C:\Program Files (x86)\Minitab\Quality Companion 3\Companion\qc.exe).
    • If necessary, in Arguments, enter an argument to pass to the application that you are adding the link for, such as a specific file to be opened automatically by the application.
    • If necessary, in Initial directory, create an initial save folder for the application for which you are adding the link.
  5. Click Close.
    To run the new command, choose it from the Tools menu.

Move or remove a command from a menu or toolbar

You can move commands to a different location on a menu or toolbar. To make your toolbars more concise, you can remove unused commands from toolbars.

  1. Choose Tools > Customize.
  2. To remove a command, while the dialog box is open, drag the command off of the menu or toolbar.
  3. To move a command, while the dialog box is open, drag the command from the original location to the new location. You can move any command, except commands that are in the first section of the Tools menu.
  4. To move a custom command from the first section of the Tools menu, do the following:
    1. On the Commands tab, under Categories, select the group that the command belongs to.
    2. Under Commands, select the command and, while the dialog box is open, drag the command to the menu or toolbar.
  5. Click Close.

Create a custom menu

You can create a new menu for a special task or project. For example, create a menu of tools for monthly reports.

  1. Choose Tools > Customize.
  2. On the Commands tab, under Categories, select New Menu.
  3. Under Commands, select New Menu and drag it onto the main menu bar of Minitab.
  4. Right-click New Menu and choose Name Button. Enter a name for the menu (for example, Monthly Report Tools), then click OK.
  5. Under Categories, select the category of a command that you want to add to your new menu (for example, Graph).
  6. Under Commands, select the command and drag it under the new menu.
  7. Repeat steps 5 and 6 for all the commands that you want to add to the menu.
  8. Click Close.

Create a custom toolbar

You can create a new toolbar for a special task or project. For example, create a toolbar of frequently used analyses.

  1. Choose Tools > Customize.
  2. On the Toolbars tab, click New.
  3. Enter a toolbar name (for example, My Tools), then click OK.
  4. Drag the new toolbar to where you want it in Minitab.
  5. On the Commands tab, select the Categories of commands, then drag the command that you want to add to the toolbar.
  6. Repeat step 5 for all the commands you want to add to the toolbar.
  7. To show the name of the command on the toolbar, on the Toolbars tab, select Show text labels.
  8. Click Close.

Edit a context menu

Context menus are menus that are active only when a particular window is active. Most context menus are right-click menus. For example, when you right-click a graph, you see the Graph View context menu.

  1. Choose Tools > Customize.
  2. On the Menu tab, in Select context menu, select the context menu that you want to change.
    The context command appears.
  3. On the Commands tab, under Categories, select the category that contains the command that you want to add.
  4. Under Commands, drag the command to the context menu.
  5. To remove a command from the context menu, select it and drag it off the menu.
  6. Click Close.

Change toolbar display options

Change how tooltips and icons for toolbars are displayed.

  1. Choose Tools > Customize.
  2. On the Options tab, do any of the following:
    • To display tooltips for toolbars, select Show ScreenTips on toolbars.
    • To show shortcut keys in tooltips for toolbars, select Show shortcut keys in ScreenTips.
    • To display large icons on toolbar buttons, select Large Icons.
  3. Click Close.

Add a keyboard shortcut for a command

Add shortcut keys to save time executing the commands that you use most often. For example, create a keyboard shortcut to open the 2-Sample t dialog box.

  1. Choose Tools > Customize.
  2. On the Keyboard tab, from Category, select the category that the command belongs to (for example, Stat).
  3. Under Commands, select command (for example, 2-Sample t...[Basic Statistics]).
  4. Click in the Press New Shortcut Key field, then press the keyboard shortcut (for example, Ctrl+Q).
    If the keyboard shortcut is already assigned, Minitab displays a message.
  5. Click Assign and close the window.

Change the image on a toolbar button

You can change the image on a toolbar button.

  1. Choose Tools > Customize.
  2. To copy an image from one button to a different button, complete the following steps:
    1. Right-click the button image to copy and choose Copy Button Image.
    2. Right-click the button where you want to paste the image and choose Paste Button Image.
  3. To edit an existing button image, right-click the image and choose Edit Button Image. Edit the picture with the drawing tools.
  4. To display the button name instead of the image, right-click the button and choose Text. To display both button name and image, right-click the button and choose Image and Text.
  5. Click Close.

Restore the default settings

You can restore the default settings for toolbars, menus, and shortcut keys.

Reset a toolbar

  1. Choose Tools > Customize.
  2. Click the Toolbars tab.
  3. To reset one toolbar, click the toolbar, then click Reset.
  4. To reset all the toolbars, click Reset All.
  5. To remove a custom toolbar, select it from the Toolbars list and click Delete.
  6. Click Close.

Reset a menu

  1. Choose Tools > Customize.
  2. Click the Menu tab.
  3. To reset all the non-context menus, submenus, and commands (for example, the Tools menu, Edit menu, Data menu and so on), under Application Frame Menus, click Reset.
  4. To reset a context menu, select the context menu and click Reset.
  5. Click Close.

Reset shortcut a key

  1. Choose Tools > Customize.
  2. Click the Keyboard tab.
  3. To reset all the keyboard shortcuts that you changed, click Reset All.
  4. To reset one keyboard shortcut, select the command, click in Current Keys, and then click Remove.
  5. Click Close.

Reset a button image

  1. Choose Tools > Customize.
  2. In Minitab, right-click a menu item or toolbar item and select Reset.
  3. Click Close.
By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy