Work with worksheets

All the data that are associated with a particular data set are contained in a worksheet. You can enter a description for the worksheet, use shortcut keys to move around the worksheet, define constants for the worksheet, and more.

Enter a worksheet description

A worksheet with a description has a red triangle in the cell that is above the row numbers.

  1. Click in the worksheet, then choose Editor > Worksheet Properties > Description, or File > Description > Worksheet.
  2. Enter worksheet information. For example, in Comments, you can enter a description of the worksheet and the commands that you used to analyze the data.
  3. Click OK.
  4. To view the description of the worksheet, do one of the following:
    • Hold the pointer over the red triangle in the cell that is above the row numbers.
    • Choose Window > Project Manager, then click the folder for the worksheet.

Rename a worksheet

To rename a worksheet, do one of the following:

  • Right-click the worksheet icon in the title bar, then choose Rename Worksheet.
  • In the Project Manager, right-click the worksheet folder, then choose Rename.
  • In the Project Manager, select the worksheet, then press the F2 key.
  • Click in the worksheet, choose File > Save Worksheet As, then enter a name for the worksheet.
    If you previously saved the worksheet, the original file stays the same, and current changes are saved in the new file.

Move around in the worksheet

When you click in a cell, the cell becomes active. You can also use the Editor menu or your keyboard to move the cursor and make other cells active.

The following table describes how to move to locations in the active worksheet.

Location Action
A specific cell Choose Editor > Find and Replace > Go To.
One cell to the right, left, up or down Press an arrow key.
The next cell down or to the right, depending on the data entry direction arrow Press Enter.
The beginning of the next row or column, depending on the data entry direction arrow Choose Editor > Find and Replace > Go To > Next Column, or Editor > Find and Replace > Go To > Active Cell, or press Ctrl+Enter.
The edge of the visible portion of the Data window Press Ctrl + an arrow key.
The first cell of the worksheet Press Ctrl+Home.
The last used worksheet cell Press Ctrl+End.
The next/previous brushed row (if you have brushed a graph) Choose Editor > Find and Replace > Go To > Next Brushed Row, or Editor > Find and Replace > Go To > Previous Brushed Row.
The next/previous formatted cell (if you have formatted cells) Choose Editor > Find and Replace > Go To > Next Formatted Cell, or Editor > Find and Replace > Go To > Previous Formatted Cell.

Change the data-entry direction in the current worksheet

The data-entry direction is determined by the arrow in the upper left corner of the worksheet. The direction of this arrow also determines how the Home and End keys work.

Arrow direction Action
When you press the Enter key, the active cell moves down.
When you press the Enter key, the active cell moves to the right.

To change the direction, click the arrow or click in the worksheet and choose Editor > Worksheet Properties > Change Entry Direction.

Change the default data-entry direction for all new worksheets

By default, the data-entry direction is down columns. Complete the following steps to change the data-entry direction to across rows for new worksheets.

  1. Choose Tools > Options > Data Window > General.
  2. From Entry Direction, select Enter moves across rows.
  3. Click OK.

Copy a worksheet

Complete the following steps to copy the entire contents of the active worksheet to another worksheet.

  1. Click the title bar of the worksheet that you want to copy to make it the active window.
  2. Choose Data > Copy > Worksheet to Worksheet.
  3. From Store Copied Data, select whether to create a new worksheet or to use an existing one.
  4. To copy the names as well as the content of the columns, constants, and matrices, select Name the copied columns, constants, and matrices.
  5. Click OK.

Modify the worksheet text size

To increase or decrease the size of the text in the worksheet, do one of the following:

  • With the worksheet active, scroll the mouse wheel while holding the Ctrl key.
  • To change the default text size of the data for open worksheets and new worksheets, choose Tools > Options > Data Window > Data Font.
  • To change the default text size of the column numbers, row numbers, and column names for open worksheets and new worksheets, choose Tools > Options > Data Window > Label Font.
After you adjust the text size, you may want to adjust the column width. Do one of the following:
  • To change the default column width for new worksheets, choose Tools > Options > Data Window > General.
  • To change the width of the selected columns, choose Editor > Column Properties > Width.

Define stored constants

Stored constants are single numbers or text values that are stored with a worksheet. You can use stored constants in formulas, calculations, session commands, macros, and Exec files. All stored constants have a unique ID that starts with a K (K1, K2, and so on), but you can also name stored constants (for example, name K1 "Adjustment" and name K2 "Target").

Note

Dialog box controls that accept text strings do not recognize stored constants. For example, if K1 contains the text string "My Scatterplot" and you enter K1 in Title under the label options for Graph > Scatterplot, Minitab displays "K1" as the title of your graph.

Complete the following steps to define a stored constant.

  1. Choose Calc > Calculator.
  2. In Store result in variable, enter the name of the stored constant (for example, K1).
  3. In Expression, enter the value for the constant. Enclose text values in double quotation marks (for example, "Green").
  4. Click OK.
Note

Stored constants are not displayed in the worksheet. To view stored constants in the Session window, choose Data > Display Data.

Copy constants to a column

Complete the following steps to copy data from stored constants into a new column in the current worksheet.

  1. Choose Data > Copy > Constants to Column.
  2. In Copy from constants, enter the stored constants to copy (for example, K1 K2 K3).
  3. In In current worksheet, in column:, enter a target column.
  4. Click OK.

Copy constants to constants

Complete the following steps to copy data from stored constants into new stored constants.

  1. Choose Data > Copy > Constants to Constants.
  2. In Copy from constants, enter the stored constants to copy (for example, K1 K2 K3).
  3. From Store Copied Data in Constants, select the storage location:
    • In new worksheet: You can enter a name for the new worksheet to copy the constants to.
    • In following worksheet, after last constant used: Enter the name of an open worksheet to copy the constants to.
    • In current worksheet, in constants: Enter the constants to copy to.
  4. Click OK.

Copy a column to constants

Complete the following steps to copy data from a column into stored constants.

  1. Choose Data > Copy > Column to Constants.
  2. In Copy from column, enter the column to copy.
  3. In In current worksheet, in constants:, enter the target constants (for example, K1 K2 K3). The number of constants that you enter must equal the number of values in the column. For example, if the column contains 20 values, you must enter 20 constants. To indicate a range, use a hyphen. For example, enter K1-K20
  4. To include a name for the constants, select Name the constants containing the copied data.
  5. To specify the rows to include or exclude, click Subset the Data and complete the following steps.
    1. Under Include or Exclude, specify whether to include or exclude rows from the copied columns.
    2. From Specify Which Rows To Include/Specify Which Rows To Exclude, select one of the following:
      • All rows/No rows: Include all rows or exclude no rows.
      • Rows that match: Include or exclude rows that match a condition. Click Condition to enter the conditional expression.
      • Brushed rows: Include or exclude rows that correspond to brushed points on a graph.
      • Row numbers: Include or exclude the specified rows. Enter individual row numbers and ranges of row numbers. Use a colon (:) to denote an inclusive range. For example, enter 1 4 6:10 to signify the set 1, 4, 6, 7, 8, 9, 10.
  6. Click OK in each dialog box.
By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy