Wiederholen einer Analyse

Übersicht

Wenn Sie in Minitab einen Menübefehl verwenden, speichert Minitab Sessionbefehle, mit denen Ihre Aktionen aufgezeichnet werden. Anhand dieser Sessionbefehle können Sie eine Analyse schnell für einen neuen Datensatz wiederholen.

Für jeden Menübefehl gibt es einen entsprechenden Sessionbefehl. Sessionbefehle bestehen aus einem Hauptbefehl und gewöhnlicherweise einem oder mehreren Unterbefehlen. Sowohl Befehlen als auch Unterbefehlen können eine Reihe von Argumenten folgen, z. B. Spalten, Konstanten, Matrizen, Textzeichenfolgen oder Zahlen. Minitab bietet drei Möglichkeiten, um Sessionbefehle zu verwenden:
  • Geben Sie Sessionbefehle im Fenster Session oder dem Befehlszeilen-Editor ein.
  • Kopieren Sie Sessionbefehle aus dem Ordner Verlauf in den Befehlszeilen-Editor.
  • Kopieren Sie Sessionbefehle, und speichern Sie sie in Exec-Dateien.

Wenn Sie die Befehlszeilen anzeigen und dann einen Befehl aus einem Menü ausführen, werden die entsprechenden Sessionbefehle im Bereich Befehlszeile des Sessionfensters angezeigt. Auf diese Weise können Sie sich schnell und einfach mit Sessionbefehlen vertraut machen.

Im Versandzentrum West werden fortlaufend die Lieferzeiten erfasst und analysiert, sobald neue Daten verfügbar sind. In Bewerten der Qualität haben Sie eine Prozessfähigkeitsanalyse mit Daten für den Monat März durchgeführt. In diesem Kapitel führen Sie mit Hilfe von Sessionbefehlen eine Prozessfähigkeitsanalyse mit Daten für den Monat April durch.

Aktivieren und Eingeben von Sessionbefehlen

Eine Möglichkeit zur Nutzung von Sessionbefehlen besteht darin, diese an der Eingabeaufforderung des Bereichs Befehlszeile im Fenster Session einzugeben. Dieser Bereich wird in Minitab nicht standardmäßig angezeigt, Sie müssen ihn daher aktivieren.

Aktivieren von Sessionbefehlen

  1. Wenn Sie zuletzt das vorherige Kapitel durchgearbeitet haben, wählen Sie Datei > Neu > Projekt aus. Wenn nicht, starten Sie Minitab.
  2. Öffnen Sie die Beispieldaten Sessionbefehle.MTW.
  3. Klicken Sie auf das Sessionfenster, um es zu aktivieren.
  4. Wählen Sie Editor > Befehlszeile anzeigen\tStrg+K aus.

    Im Bereich Befehlszeile des Fensters Session wird die Eingabeaufforderung MTB> angezeigt.

  5. (Optional) Legen Sie fest, dass Sessionbefehle standardmäßig für alle Minitab-Sessions aktiviert sind.
    1. Wählen Sie Extras > Optionen aus. Erweitern Sie Sessionfenster, und wählen Sie Befehle übermitteln aus.
    2. Klicken Sie unter Befehlszeile auf Anzeigen.

Durchführen einer Analyse mit Sessionbefehlen

In Bewerten der Qualität haben Sie eine Prozessfähigkeitsanalyse durchgeführt, um festzustellen, ob sich die Lieferzeiten innerhalb der Spezifikationen (weniger als 6 Liefertage) befinden. Zum Durchführen dieser Analyse haben Sie Statistik > Qualitätswerkzeuge > Prozessfähigkeitsanalyse > Normal verwendet. Anschließend haben Sie die Datenspalte, die Teilgruppenspalte und die obere Spezifikationsgrenze eingegeben.

Um die Auswertung der Versandzeiten im Versandzentrum West fortzusetzen, möchten Sie diese Analyse in regelmäßigen Abständen wiederholen. Wenn Sie neue Daten erfassen, können Sie diese Analyse mit nur wenigen Sessionbefehlen wiederholen.

  1. Geben Sie im Bereich Befehlszeile an der Eingabeaufforderung MTB > die Anweisung CAPABILITY 'Tage' 'Datum'; ein. Das Semikolon gibt an, dass Sie einen Unterbefehl eingeben möchten.
  2. Drücken Sie Eingabe. Beachten Sie, dass MTB > zu SUBC> wird. Verwenden Sie die Eingabeaufforderung SUBC>, um Unterbefehle für die Optionen aus den früheren Prozessfähigkeitsanalysen anzufügen.
  3. Geben Sie an der Eingabeaufforderung SUBC> den Text USPEC 6. ein. Der Punkt zeigt das Ende einer Befehlsfolge an.
  4. Drücken Sie Eingabe.
Prozessfähigkeitsanalyse für die Versanddaten des Monats April
Tipp

Um eine PDF-Datei zu öffnen, in der die Sessionbefehle von Minitab aufgeführt werden, geben Sie auf der Befehlszeile Help ein.

Erneutes Ausführen einer Reihe von Befehlen

Minitab erzeugt Sessionbefehle für die meisten Menübefehle und legt diese im Ordner Verlauf ab. Sie können diese Befehle erneut ausführen, indem Sie sie markieren und anschließend Bearbeiten > Befehlszeilen-Editor auswählen.

Verwenden Sie den Ordner Verlauf und den Befehlszeilen-Editor, um die Prozessfähigkeitsanalyse erneut durchzuführen.

  1. Wählen Sie Fenster > Project Manager aus.
  2. Klicken Sie auf den Ordner Verlauf.
  3. Klicken Sie auf CAPABILITY 'Tage' 'Datum';, halten Sie Umschalt gedrückt, und klicken Sie anschließend auf USPEC 6.
  4. Wählen Sie Bearbeiten > Befehlszeilen-Editor aus.
  5. Klicken Sie auf Befehle übermitteln.
Prozessfähigkeitsanalyse für die Versanddaten des Monats April

Sie haben die Prozessfähigkeitsanalyse mit wenigen einfachen Schritten neu erstellt.

Wiederholen von Analysen mit Exec-Dateien

Eine Exec-Datei ist eine Textdatei, die eine Reihe von Minitab-Befehlen enthält. Um eine Analyse wiederholen zu können, ohne Menübefehle oder Sessionbefehle verwenden zu müssen, speichern Sie die Befehle als Exec-Datei, und führen Sie diese Exec-Datei anschließend aus.

Tipp

Weitere Informationen zu Exec-Dateien und anderen komplexen Makros finden Sie in der Minitab-Hilfe zu Makros.

Erstellen einer Exec-Datei aus dem Ordner „Verlauf“

Speichern Sie die Sessionbefehle der Prozessfähigkeitsanalyse als Exec-Datei.

  1. Wählen Sie Fenster > Project Manager aus.
  2. Klicken Sie auf den Ordner Verlauf.
  3. Klicken Sie auf CAPABILITY 'Tage' 'Datum';, drücken Sie Umschalt, und klicken Sie anschließend auf USPEC 6.
  4. Klicken Sie mit der rechten Maustaste auf den ausgewählten Text und wählen Sie dann Speichern unter aus.
  5. Navigieren Sie zu dem Ordner, in dem Sie Ihre Dateien speichern möchten.
  6. Geben Sie im Feld Dateiname den Text Versandgrafiken ein.
  7. Wählen Sie im Feld Dateityp die Option Exec (*.mtb) aus. Klicken Sie auf Speichern.

Erneutes Ausführen von Befehlen

Sie können diese Analyse wiederholen, indem Sie die Exec-Datei ausführen.

  1. Wählen Sie Extras > Exec ausführen aus.
  2. Klicken Sie auf Datei auswählen.
  3. Wählen Sie die Datei Versandgrafiken.MTB aus, und klicken Sie dann auf Öffnen.
Prozessfähigkeitsanalyse für die Versanddaten des Monats April

Minitab führt die Befehle in der Exec-Datei aus, um die Prozessfähigkeitsanalyse zu generieren.

Sie können eine Exec-Datei für ein beliebiges Arbeitsblatt ausführen, wenn die Spaltennamen übereinstimmen. Daher können Sie eine Exec-Datei an andere Minitab-Benutzer weitergeben, die dieselbe Analyse ausführen müssen. So kann der Manager des Versandzentrums West die Datei Versandgrafiken.MTB an die Manager der anderen Versandzentren weitergeben, damit diese dieselbe Analyse für ihre eigenen Daten durchführen können. Wenn Sie eine Exec-Datei für ein anderes Arbeitsblatt oder andere Spalten verwenden möchten, bearbeiten Sie die Exec-Datei mit einem Texteditor.

Speichern des Projekts

Speichern Sie Ihre Arbeit in einem Minitab-Projekt.

  1. Wählen Sie Datei > Projekt speichern unter aus.
  2. Navigieren Sie zu dem Ordner, in dem Sie Ihre Dateien speichern möchten.
  3. Geben Sie im Feld Dateiname den Text MeineSessionbefehle ein.
  4. Klicken Sie auf Spiechern.

Im nächsten Kapitel

Sie haben Sessionbefehle kennen gelernt, die als Alternative zu Menübefehlen und zur schnellen Wiederholung einer Analyse verwendet werden können. Im nächsten Kapitel erstellen Sie einen Bericht, in dem Sie Ihren Kollegen die Ergebnisse Ihrer Analyse präsentieren können.

Durch Ihre Nutzung dieser Website stimmen Sie zu, dass Cookies verwendet werden. Cookies dienen zu Analysezwecken und zum Bereitstellen personalisierter Inhalte.  Lesen Sie unsere Richtlinien