Parts of the worksheet

A worksheet, displayed in the Data window, organizes your data into columns and rows. In addition to columns of data, a worksheet can also store constants, matrices, and design objects used in DOE procedures.

You can have many worksheets in a project. The active worksheet is identified by three asterisks (***) following the worksheet name in the title bar. If multiple worksheets are open, commands will act only on the data in the active worksheet.

Data can be stored in the following areas of a worksheet:
Columns

Each column contains the data for one variable. Each column has a unique ID that starts with a C (C1, C2, and so on). These column IDs are displayed at the top of each column in the worksheet. To give a columns a descriptive name, type the name in the shaded cell under the column ID.

Constants

Constants are single numbers or text values you can define and use in formulas and calculations. For example, you can define historical parameters for probability distributions. Using stored constants instead of individual values can save data entry time and add flexibility to macros. All stored constants have a unique ID that starts with a K (K1, K2, and so on). You can name stored constants; for example, K1 = Adjustment, K2 = Target.

Stored constants are not displayed in the worksheet. To view stored constants and matrices in the Session window, choose Data > Display Data.

Matrices
Matrices are rectangular blocks of numbers on which mathematical operations can be conducted. Matrices are often described by their dimensions. For example, here is a 3 x 4 (row x column) matrix:
14 22 23 44 
15 36 27 38
19 16 31 42

Matrices are often used in equations. In Minitab, you can store matrices with a worksheet and use stored matrices in some commands. Minitab can also store output in matrices for some statistical analyses, for example, the design matrix for regression, GLM, and DOE procedures. All stored matrices have a unique ID that starts with an M (M1, M2, and so on). You can also name matrices, for example, M1 = Output, M2 = Historical.

Stored matrices are not displayed in the worksheet. To view stored constants and matrices in the Session window, choose Data > Display Data.

How much data can a worksheet contain?

Each worksheet can contain up to 4000 columns, 1000 constants, and 10,000,000 rows. The total number of cells depends on the memory of your computer, up to 150,000,000. This worksheet size limit applies to each worksheet in a Minitab project. For example, you could have two worksheets in your project, each with 150 million cells of data. Minitab does not limit the number of worksheets you can have in a project file. The maximum number of worksheets depends on your computer's memory.

Rename a worksheet

Use one of the following ways to rename a worksheet:

  • Right-click the worksheet icon beside the worksheet name in the title bar and choose Rename Worksheet.
  • In the Project Manager, right-click the Worksheet folder and choose Rename.
  • In the Project Manager, select the worksheet and press the F2 key.
  • Click in the worksheet and choose File > Save Worksheet As.
    If you had previously saved the worksheet, the original file will remain as it was last saved, and current changes will apply to the new file.
  • Use the RENAME subcommand with the WORKSHEET session command.
    For example, to rename Worksheet 1 as "My Data", enter the following session commands:
    WORKSHEET "Worksheet 1";
    RENAME "My Data".

Modify the worksheet text size

Use one of the following ways to zoom in and out on the worksheet:

  • With the worksheet active, scroll with the mouse wheel while holding the Ctrl key. Scrolling down will zoom in, while scrolling up will zoom out.
  • To increase or decrease the default column width, choose Tools > Options > Data Window > General, or with the worksheet active, choose Editor > Column Properties > Width.
  • To increase or decrease the size of the worksheet cell text, choose Tools > Options > Data Window > Data Font.
  • To increase or decrease the size of the worksheet column label text, choose Tools > Options > Data Window > Label Font.
    Note

    Changes made with the Editor menu apply only to the active worksheet. Changes made with the Tools menu apply to all worksheets in the current project and all future worksheets.

By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy