Identify, recover, and update a corrupted project

Minitab is a very stable program, but projects occasionally become corrupted, especially in older releases of Minitab.

Symptoms of a corrupted project

If your project is corrupted, you may notice the following symptoms:
  • Error messages appear when you try to open the project or update a graph.
  • Items are missing from the project after you save and re-open it.
  • Graphs that seem to be linked to the worksheet are not actually linked.
  • The project does not open.

Recover a corrupted project

If your project is corrupted, you can take the following actions.

Try to retrieve a backup file of your project

When you successfully open a project file, Minitab automatically creates a backup file in the same folder as the original .MPJ file. The backup file has a .BAK extension. For example, if the project file is DEFECTS.MPJ, then the backup file is DEFECT.MPJ.BAK. The backup file contains the contents of the project as they were when you last opened the project successfully.

  1. Choose File > Open.
  2. From the files type drop-down list, , choose All (*.*).
  3. Browse to the folder where the original project file is saved.
  4. Double-click the .BAK file for the project.

Send Minitab Technical Support a copy so that we can try to recover it

If you believe your project may be corrupted, try to save the project and send a copy of the .MPJ and .BAK files to Minitab Technical Support. We might be able to recover some or all of the project's contents.

Try to recover individual worksheets

If you are not able to retrieve a backup copy, you can try to recover individual worksheets and graphs.

  1. In a new Minitab project, choose File > Open.
  2. From the files type drop-down list, choose All Minitab Files.
  3. Select the worksheets or graphs you want to recover, then click OK.
    Tip

    You can select multiple worksheets or graphs by pressing the Ctrl key as you select them.

Update a recovered project

After you recover a corrupted project file, update the project to prevent it from becoming corrupted again.

  1. In Minitab, choose Help > Check for Updates, and install any available updates.
  2. Open the project and re-create the graphs.
    Tip

    To quickly recreate a control chart or a graph that was created from the Graph menu:

    1. With the graph active, choose Editor > Copy Command Language to save the command language for the graph.
    2. Choose Edit > Command Line Editor.
    3. Press Ctrl+V to paste the session commands in the Command Line Editor.
    4. Click Submit Commands.

  3. Delete the old graphs from the project because they may be corrupting the file.
By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy